VirtualBox

Ticket #7265 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

VM crashes with Win7 guest

Reported by: ralf Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I am running VirtualBox 3.2.6 on Kubuntu 10.04 64bit with a Windows 7 32bit guest. Approximately every 5th to 10th time I use the VM, it freezes for no obvious reason - but I couldn't find any way to reproduce the issue. It then crashes so hard that I have to kill the virtualbox process, because clicking "Reset" in the menu won't do anything.

I attached a log file of the last crash which just happened (all I did was starting the OS and letting it idle on the login screen).

Attachments

VBox.log Download (39.0 KB) - added by ralf 4 years ago.
The log of a crash

Change History

Changed 4 years ago by ralf

The log of a crash

comment:1 follow-up: ↓ 2 Changed 4 years ago by frank

Can you provide a  core dump?

comment:2 in reply to: ↑ 1 Changed 4 years ago by ralf

Replying to frank:

Can you provide a  core dump?

I will try to - but without a way to trigger the issue, that can take a while.

comment:3 Changed 4 years ago by ralf

By returning to a snapshot I did yesterday evening, I could reproduce the crash while waiting for login: It runs fine for at least 15 minutes doing nothing (or maybe some defragmentation in background), and then I click the "shutdown" button - then the VM freezes. I can still use the menus etc. though, but as soon as I issue any command (like reset), those stop working, too.

I then clicked the "Close Window" button, and after some seconds, KWin suggested to kill the process, which I confirmed. No core dump was created though. Do I need to kill it in a specific way to get one?

comment:4 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.2.6 to VirtualBox 3.2.8

I've inspected your core dump which was taken from VBox 3.2.8 (as you told me via private E-mail). The core dump shows clearly that both guest CPUs are currently executing guest code. Do you have any special software installed into your Windows 7 guest?

There is a slight chance that your issue will be fixed with the upcoming 3.2.10 release. I will send you a test build via private E-mail.

comment:5 Changed 4 years ago by ralf

The VM, in the state I captured the dump, contained nothing but some scanner driver and the Qt SDK. But I had the issues from the beginning on, before I installed any software besides Windows itself.

I will try the test build, thanks a lot!

The only special part of my configuration coming to my mind is that the VMs live in my home directory, which is encrypted using ecryptfs (the way Kubuntu offers it during installation). Are there known issues of VirtualBox interfering with it, e.g. caused by the large virtual HD files? If everything else fails I might try to re-install the OS onto a HD that sits outside the encrypted folder - but in the end, I'd like it to be encrypted.

comment:6 Changed 3 years ago by frank

Still relevant with VBox 3.2.12?

comment:7 Changed 3 years ago by ralf

I was able to reproduce the issue with 4.0, but I also get other weird error messages that look like this in the logs: pdmacFileEpInitialize: RTFileOpen /home/ralf/vm/HardDisks/Windows 7.vdi / 000c0781 failed with VERR_INVALID_PARAMETER So I think I will create a new VM from scratch, something looks fundamentally broken there. I just did not yet have the time to do that.

comment:8 Changed 3 years ago by ifreecarve

I see this crash running windows vista or windows 7 as a guest, while ubuntu guests are not affected.

I'm running Ubuntu 10.10 with VirtualBox 4.0.2 r69518.

When I run "VirtualBox -startvm 7" or "VirtualBox -startvm vista" on the command line, the crash does not produce any helpful error messages. In fact, they terminate normally and return "0" to the shell.

There are some output messages while the VM runs, but they don't seem to be related to the crash. They are all this message:

Qt WARNING: X Error: BadAccess (attempt to access private resource denied) 10

Major opcode: 33 (X_GrabKey) Resource id: 0x5600105

comment:9 Changed 3 years ago by frank

Still relevant with VBox 4.0.6?

comment:10 Changed 3 years ago by ralf

I changed the encryption of my home directory (from ecryptfs to block-layer encryption) and re-created the Windows 7 VM from scratch. That worked seamlessly without any issues, so I consider this issue fixed and/or caused by some kind of HD file corruption.

Thanks for your assistance!

comment:11 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use