VirtualBox

Ticket #7261 (closed defect: wontfix)

Opened 4 years ago

Last modified 4 years ago

Your keyboard layout does not appear to [be] fully supported by VirtualBox -> obsolete

Reported by: john.doe Owned by:
Priority: minor Component: other
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Here is the beginning of the log

VirtualBox 3.2.6 r63112 linux.x86 (Jun 25 2010 14:03:15) release log
Log opened 2010-07-31T13:39:31.936559000Z
OS Product: Linux
OS Release: 2.6.32-24-generic
OS Version: #38-Ubuntu SMP Mon Jul 5 09:22:14 UTC 2010
DMI Product Name: MS-7253
DMI Product Version: 1.00
Host RAM: 1759MB RAM, available: 1242MB
Executable: /usr/lib/virtualbox/VirtualBox
Process ID: 10681
Package type: LINUX_32BITS_UBUNTU_10_04
Your keyboard layout does not appear to fully supported by
VirtualBox. If you would like to help us improve the product,
please submit a bug report and attach this logfile.
(Note: please ignore this if you are using a custom layout.)

The correct table for your layout is:
"\x0\x0","&1","\xe9""2","\"3","'4","(5","-6","\xe8""7","_8","\xe7""9","\xe0""0",")\xb0","=+",
"aA","zZ","eE","rR","tT","yY","uU","iI","oO","pP","RW","$\xa3",
"qQ","sS","dD","fF","gG","hH","jJ","kK","lL","mM","\xf9%","*\xb5",
"wW","xX","cC","vV","bB","nN",",?",";.",":/","!\xa7","<>","\x0\x0","\x0\x0"

It's an AZERTY Micro$oft Basic Keyboard 1.0A.

If you need more info, just tell me what you need Thanks

Change History

comment:1 Changed 4 years ago by michael

Sorry to have overlooked this for so long. It looks from the table you submitted that something is not quite the way we expect with the first key on the numeric row (the one on which you need "shift" to get numbers with an Azerty keyboard). Any idea what that might be?

comment:2 Changed 4 years ago by john.doe

My keyboard is exactly the following :  http://fr.wikipedia.org/wiki/Fichier:KB_France.svg The first key let us type the square symbol (as in math) but as you can guess, it's very rare to use it. In fact, it's rather a dead key so I'm not surprised if linux maps it as '\0'. (currently, I get the œ and Œ char with this key which is more used but still not very frequent in french)

But I recently changed my layout because I needed a quick way to type spanish chars like ó í ñ ... Currently, I'm using "France (Legacy) Alternative". I don't see this error anymore, sorry.

I tried to add some others french layout, switch a new one, launch a virtual machine and see log but I don't by get reproduce the issue.

I don't mind if you mark this bug as WONTFIX because it's just a harmless warning. Moreover, I guess (because I changed my layout) typing this key don't print the square symbol on linux either.

But thanks for your efforts anyway. And sorry for the bug in this case.

comment:3 Changed 4 years ago by michael

It certainly seems rather strange, since I know for a fact that X.Org knows about that symbol (our reference standard French keyboard map, which contains the symbol, was generated by setting my keyboard to a French layout and reading back the key symbol values; for that matter my normal layout has both a working square and a working cube symbol). I would be interested to know whether you had some sort of special mapping (like an xmodmap) and whether the square symbol actually worked in other X11 applications; if you are not interested in following this up yourself though we can just drop it and I will indeed set this to WONTFIX.

comment:4 Changed 4 years ago by john.doe

I really would like to help VirtualBox but the fact is that I don't even know what happened, how the square key became a \0 key.

To answer you, no I didn't set any special mapping for my keyboard.

The bug was opened 2 month ago, I run apt-get {update,upgrade,dist-upgrade} everyday, so maybe something was wrong and was fixed.

I know the X server is something very old, lacking documentation, with limited interest for most developers... Things are currently evolving with mesa/Gallium/nouveau, KDE ...etc

So as I can't give you any detail, any clue, any hint, any log or whatever you need .. I fear this bug will die here.

I only hope that the next user (if any) who'll have this bug will be more useful than I am. Now I feel a bit guilty because your wasting your time reading this. But I can swear it : the next bug I find will be with a test case or something like that.

Many thanks and sorry for the noise.

comment:5 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to wontfix
  • Summary changed from Your keyboard layout does not appear to [be] fully supported by VirtualBox to Your keyboard layout does not appear to [be] fully supported by VirtualBox -> obsolete

Thank you for your feedback - we might have got more out of the report if I had got round to looking at it faster.. If you or anyone else experiences this again we can still re-open the ticket though.

comment:6 Changed 4 years ago by john.doe

Just one more thing...

Can you add the verb 'be' in "Your keyboard layout does not appear to fully supported by VirtualBox." ?

English is not my mother tongue but I'm pretty sure be's missing here ...

comment:7 Changed 4 years ago by michael

Done that (in trunk).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use