VirtualBox

Ticket #7258 (closed enhancement: duplicate)

Opened 4 years ago

Last modified 4 years ago

Host freeze if intel VT is enabled (Gigabyte)

Reported by: woec Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 3.2.6 Keywords: VT-x, host freeze after S3
Cc: Guest type: Windows
Host type: Linux

Description

When resuming after having suspended (S3) and starting a VM with vt-x enabled, the host freezes. The VM runs without problems when starting it from host which was not ever suspended before since last boot. Seems to be same isssue as reported in #5048 and #7216.

Following new aspect: reading out the corresponding Machine register, which controls the VT-x function - IA32_Feature_Control (MSR 0x0000003a, Bits [2:0]) using the msr-tools (rdmsr), I got a value of 5 - which means VT-x is enabled. Result is 5, independently on machine history (S3 before or new booted machine). I found also that this register is write protected, I was not able to change its value by means of wrmsr. So I conclude, VT-x is enabled from the BIOS and it does not change its state while suspend and resume.

I am also quite sure, that the problem described here was not there on older versions of virtualbox under same machine configuration (maybe before 3.0.10).

My machine configuration: CPU: Intel E8400, Mobo: Gigabyte GA-EP35-DS3, 4 GB RAM, Debian Linux squeeze, kernel 2.6.32-5-686-bigmem

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Host freeze if intel VT is enabled to Host freeze if intel VT is enabled (Gigabyte)

Duplicate of #5048.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use