VirtualBox

Ticket #7255 (new defect)

Opened 4 years ago

Last modified 4 years ago

3D and 2D acceleration

Reported by: simon123 Owned by:
Priority: major Component: GUI/compiz
Version: VirtualBox 3.2.6 Keywords: 3D and 2D acceleration
Cc: Guest type: Linux
Host type: Windows

Description

Hi guys, I have being trying to find the solution to this problem I have been having with Virtualbox all over the net but I can't seem to find the answer. Hope you guys can help.

Firstly, here are the details: Host: Windows 7 Graphic Card: ATI Radeon HD 4550 Guest: Ubuntu 10.04 VirtualBox 3.2.6

I have been trying to enable the visual effects in ubuntu and set it to 'extra', but ubuntu keeps on telling me that the 'display effect could not be enabled'. I think the root cause of this problem is that fact that I cannot enable the 2D or the 3D acceleration in VirtualBox 3.2.6. The 2 boxes cannot be ticked; they are greyed out. Does anyone know how I can enable them?

Also everytime I start virtualbox, this error message pops up 'loadlibrary failed with error 126: The specific module could not be found'. After about 10 seconds, it disappears and virtualbox starts up fine. Also the same error message pops up everytime i click on settings in virtualbox.

Attachments

VBox.log Download (71.4 KB) - added by simon123 4 years ago.
virtual-box.jpg Download (86.5 KB) - added by simon123 4 years ago.
load-error.jpg Download (12.2 KB) - added by simon123 4 years ago.

Change History

Changed 4 years ago by simon123

Changed 4 years ago by simon123

Changed 4 years ago by simon123

comment:1 Changed 4 years ago by Technologov

Duplicate of bug #7254

-Technologov

comment:2 Changed 4 years ago by frank

Actually the other way around as this ticket contains more information.

comment:3 Changed 4 years ago by simon123

sorry guys, don't know why two tickets were created.

So any idea of how to fix this problem?

comment:4 Changed 4 years ago by Technologov

It happens if you, by mistake, clicked twice.

comment:5 Changed 4 years ago by misha

2D/3D support test is done with a separate app, VBoxTestOGL.exe, located in VBox install dir. Please try running

VBoxTestOGL.exe --test 2D --log <log_file_name1>
and
VBoxTestOGL.exe --test 3D --log <log_file_name2>

and attach the logs here.
If the logs show no error, please, close VBox, define global VBOXGLTEST_LOG=<log_file_path> environment variable, and run VBox GUI -> Display settings again. This should produce several <log_file_path>.<num>.log files containing 2D & 3D test results. Please attach them here also.

comment:6 Changed 4 years ago by simon123

I clicked on VBoxTestOGL.exe and the same load error message occurred, same as the one attached to this thread. I don't see any logs being created either. Will the logs only be create if VBoxTestOGL.exe runs successfully?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use