VirtualBox

Ticket #7245 (closed defect: obsolete)

Opened 4 years ago

Last modified 2 months ago

Windows 7 Pro 64 bit crashes periodically with BSOD

Reported by: jrlgillue Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

Have had periodical BSOD in Windows 7. After examining the memory dumps it seems that the cause is VirtualBox. I have uninstalled VirtualBox and the crashes have stopped so far.

The crashes occur randomly and don't depend on whether I am actually executing VirtualBox or not.

Basic WinDbg output for memory dump:

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64 Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Windows\Minidump\072710-18844-01.dmp] Mini Kernel Dump File: Only registers and stack trace are available

DbsSplayTreeRangeMap::Add: ignoring zero-sized range at ?fffff800`042c0500? Symbol search path is: SRV*c:\symbols* http://msdl.microsoft.com/download/symbols Executable search path is: Windows 7 Kernel Version 7600 MP (8 procs) Free x64 Product: WinNt, suite: TerminalServer SingleUserTS Built by: 7600.16539.amd64fre.win7_gdr.100226-1909 Machine Name: Kernel base = 0xfffff80002c18000 PsLoadedModuleList = 0xfffff80002e55e50 Debug session time: Tue Jul 27 21:19:49.045 2010 (UTC + 2:00) System Uptime: 0 days 4:50:52.169 Loading Kernel Symbols ............................................................... ................................................................ ..................... Loading User Symbols Loading unloaded module list ................ *

  • *
  • Bugcheck Analysis *
  • *

*

Use !analyze -v to get detailed debugging information.

BugCheck 9F, {3, fffffa800619f660, fffff800042c0518, fffffa8009bc7d60}

Unable to load image \SystemRoot\system32\DRIVERS\VBoxNetFlt.sys, Win32 error 0n2 * WARNING: Unable to verify timestamp for VBoxNetFlt.sys * ERROR: Module load completed but symbols could not be loaded for VBoxNetFlt.sys Probably caused by : ntkrnlmp

Followup: MachineOwner


Attachments

dump.txt Download (1.8 KB) - added by jrlgillue 4 years ago.
windbg output for memory dump
dump2.txt Download (1.7 KB) - added by jrlgillue 4 years ago.
crash at installation - memory dump
dump3.txt Download (1.7 KB) - added by jrlgillue 4 years ago.
crash 1 hour after installation - memory dump
083010-25740-01.dmp Download (270.9 KB) - added by frishrash 4 years ago.
VBOX-ZONEALARM BSOD minidump

Change History

Changed 4 years ago by jrlgillue

windbg output for memory dump

comment:1 Changed 4 years ago by Technologov

VirtualBox works fine here on Win7/x64 host. It seems you have some kind of conflicting driver on your host. We needs to find out what is it.

  1. How often does it crash?
  1. Can you reinstall VBox without network and without USB support ? ...and tell us if it still crashes.
  1. Which network cards/drivers are installed on your host?

-Technologov

comment:2 Changed 4 years ago by jrlgillue

Answers:

  1. How often does it crash?

It usually happens when I leave the computer for a while (let's say, an hour or so). When I come back I find windows has restarted and there's a message about the crash. A few times has also happened while I was actually working with the computer.

  1. Can you reinstall VBox without network and without USB support ? ...and tell us if it still crashes.

I will do it and let you know what happens. Btw, I didn't manage to get the network to work within VirtualBox, neither NAT nor bridged. The guest OS was XP SP3 and it reported I had no network card.

  1. Which network cards/drivers are installed on your host?

I have just one NIC installed. It's a "Broadcom NetLink Gigabit". The box, in case it may be of any use, is a Dell XPS Studio 8100.

comment:3 Changed 4 years ago by jrlgillue

I was reinstalling VirtualBox and I got a BSOD. This time, the memory dump blamed "vsdatant.sys" which belongs to Zone Alarm Security Suite.

I have shutdown ZoneAlarm (just in case), uninstalled VB and reinstalled it.

I'let you know if I get any more crashes.

comment:4 Changed 4 years ago by jrlgillue

It crashed again just an hour after reinstallation. Again, the fault seems to lay in vsdatant.sys.

I am attaching the analysis data for 2 minidumps: the one I reported at installation and the one I have just reported now.

Changed 4 years ago by jrlgillue

crash at installation - memory dump

Changed 4 years ago by jrlgillue

crash 1 hour after installation - memory dump

comment:5 Changed 4 years ago by misha

please attach actual minidump files here rather than windbg txt output

Changed 4 years ago by frishrash

VBOX-ZONEALARM BSOD minidump

comment:6 follow-up: ↓ 7 Changed 4 years ago by frishrash

Same happens here. VirtualBox 3.2.8 r64453 on Win7 64bit. ZoneAlarm Extreme Security installed, version 9.3.014.000, driver version 9.1.522.000

I attached last minidump... Thanks

comment:7 in reply to: ↑ 6 Changed 4 years ago by misha

Replying to frishrash: Unfortunately the minidump stack does not have anything VBox-related, so hard to tell what was causing it in your case.
BTW, the minidump says it's driver verifier fault. Did you enable it intentionally?
It's very likely that the driver would run ok w/o a verifier enabled.

comment:8 Changed 2 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use