VirtualBox

Ticket #7234 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Cannot start more than 8 guests

Reported by: zakiwi_dev Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Hi there,

I have an Intel Quad Core Q6600 with 8GB RAM running Debian Lenny i386 with the BIGMEM kernel (Linux dev 2.6.26-2-686-bigmem #1 SMP) and Virtualbox 3.2.6 r63112 PUEL.

I am trying to start a fair number of virtualbox VM's for our testing processes. The VM's are all different, but are low spec (1 or 2 VCPUs and less than 256 MB Ram). I can start 8 VM's, but when I start the 9th one, I get the following error:

VM creation failed (GVMM) (VERR_MAP_FAILED). Unknown error creating VM (VERR_MAP_FAILED).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

Two of my virtual machines are virtually identical (they are meant to mirror each other). One of them boots fine, but if I try and boot the other (as the ninth machine) then it fails.

I've attached the log of the machine that booted fine (good.log), and the log file of the machine that fails to boot (fail.log).

Please advise what I need to do to get this working.

Kind regards

Zakiwi

Attachments

fail.log Download (1.4 KB) - added by zakiwi_dev 4 years ago.
Log file of Ninth machine that fails to boot
good.log Download (40.1 KB) - added by zakiwi_dev 4 years ago.
Log file of machine that does boot
17.log Download (39.3 KB) - added by zakiwi_dev 4 years ago.
18.log Download (34.6 KB) - added by zakiwi_dev 4 years ago.

Change History

Changed 4 years ago by zakiwi_dev

Log file of Ninth machine that fails to boot

Changed 4 years ago by zakiwi_dev

Log file of machine that does boot

comment:1 Changed 4 years ago by Perryg

Adding comment so I can follow this ticket.

comment:2 follow-up: ↓ 3 Changed 4 years ago by frank

So far no success in reproducing this problem. Running 2.6.32-5-686-bigmem here with currently 16 Damn Small Linux instances, each VM configured for 256MB RAM.

comment:3 in reply to: ↑ 2 Changed 4 years ago by zakiwi_dev

Is there anything that you suggest that I could try to do that would assist with debugging?

comment:4 follow-up: ↓ 5 Changed 4 years ago by frank

Yes: Temporarily please disable all hard disks from all your VMs. Then try to start more than 8 VMs. They should at least boot until the BIOS want's to access the hard disk. Once there, you can pause the VM to save CPU cycles. Are you able to boot more than 8 VMs this way?

comment:5 in reply to: ↑ 4 Changed 4 years ago by zakiwi_dev

Hi Frank,

This was a good call.

I managed to fire up 17 x VM's like this. (256MB RAM, no disk, 1 CPU, 1 Nic - Bridged)

The 18th machine does not start, and gives the following error:

Failed to open a session for the virtual machine aaaaaaa18. Failed to open/create the internal network 'HostInterfaceNetworking-eth0' (VERR_MAP_FAILED). Failed to attach the network LUN (VERR_MAP_FAILED). Unknown error creating VM (VERR_MAP_FAILED).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

I've attached the log file of the 17th and 18th machines. 17th is good. 18th Failed.

Please let me know if there is anything else that you suggest.

Kind regards

Zakiwi

Changed 4 years ago by zakiwi_dev

Changed 4 years ago by zakiwi_dev

comment:6 follow-up: ↓ 7 Changed 4 years ago by frank

Too bad. I still cannot reproduce this issue here. I've limited the RAM of my 32-bit PAE host to 7033MB and still have started 20 instances of Damn Small Linux (each configured with 384MB RAM, 2 processors). I didn't try to start more instances. Perhaps I have to retry this with the Lenny kernel 2.6.26 (I'm using 2.6.32 here).

comment:7 in reply to: ↑ 6 ; follow-up: ↓ 8 Changed 4 years ago by zakiwi_dev

I'd very much appreciate that if you could.

I have ordered another machine that we will use for testing this on 64 bit, and will report the results in the next few days.

Kind regards

Zakiwi

comment:8 in reply to: ↑ 7 Changed 4 years ago by zakiwi_dev

Further feedback:

I purchased another machine that I can test on without reinstalling my development box.

I've installed Debian Lenny 5.04 AMD64 on the machine, and I have transferred the virtual box machines to that server. I am able to run all 32 VM's without any problem on that machine without a problem, so I am very confused as to why I can't get this working in 32 bit.

If it helps to address the problem, I am happy to reinstall the machine with i386 bigmem. It will be a bit of work, but if it's helpful, I'll be happy to do it.

Kind regards

Zakiwi

comment:9 Changed 4 years ago by frank

I've install a self-compiled 2.6.26.8 PAE kernel on my box as the Debian/Lenny kernel wouldn't boot there. Still no problem starting 20 instances.

comment:10 Changed 3 years ago by frank

Still relevant with VBox 4.0.4?

comment:11 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use