VirtualBox

Ticket #723 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH)

Reported by: RSMayer Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords: VERR_VM_DRIVER_VERSION_MISMATCH
Cc: r.mayer@… Guest type: other
Host type: other

Description

After a succesfull installation of VirtualBox in a openSuSE 10.2 64bit environment, after installing requested 32-bit drivers and Kernel-sources I can't go further.

Starting a recently created VM( for WinXP, I get the following error message. Since internet search on VERR_VM_DRIVER_VERSION_MISMATCH doesn't get any result, I hope to get a usefull hint from here. Thanks in advance!

Unknown error initializing kernel driver (VERR_VM_DRIVER_VERSION_MISMATCH). VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH).

Fehlercode: 0x80004005 Komponente: Console Interface: IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

Change History

comment:1 follow-ups: ↓ 2 ↓ 3 Changed 7 years ago by frank

Which package did you use, the opensuse 10.2 package from our website? Did you mix different versions of VirtualBox?

comment:2 in reply to: ↑ 1 Changed 7 years ago by RSMayer

Replying to frank:

Which package did you use, the opensuse 10.2 package from our website? Did you mix different versions of VirtualBox?

My SuSE-Version is: (cat /proc/version) Linux version 2.6.18.2-34-default (geeko@buildhost) (gcc version 4.1.2 20061115 (prerelease) (SUSE Linux)) #1 SMP Mon Nov 27 11:46:27 UTC 2006. In addition I needed to install: Xalan-c-1.10-30.i586.rpm Xerces-c-2.7.0-31.i586.rpm

VirtualBox package is from your website, downloaded today: VirtualBox-1.5.0_24069_openSUSE102-2.i586.rpm

comment:3 in reply to: ↑ 1 Changed 7 years ago by RSMayer

Replying to frank:

Which package did you use, the opensuse 10.2 package from our website? Did you mix different versions of VirtualBox?

Addendum to reply from 09/28/07 19:07:26 changed by RSMayer
In order to provide USB-support due to another Error Message, Kernel was recompiled according to Lösung 2 in  http://de.opensuse.org/SDB:VMware_-_USB_Unterst%C3%BCtzung:
cd /usr/src/linux
make oldconfig
make menuconfig
...selecting USB support a described
make modules
make modules_install
...added to fstab the entry
usbfs /proc/bus/usb usbfs auto 0 0
After a reboot, VirtualBox doesn't show the USB-Error Message again.

However VERR_VM_DRIVER_VERSION_MISMATCH still persists.

comment:4 Changed 7 years ago by frank

Please could you post the output of

  find /lib/modules -name vboxdrv*

comment:5 Changed 7 years ago by RSMayer

$>find /lib/modules -name vboxdrv*
/lib/modules/2.6.18.2-34-default/misc/vboxdrv.ko
/lib/modules/2.6.18.8-0.5-default/misc/vboxdrv.ko

comment:6 Changed 7 years ago by tobias

Seems the wrong module-version to be loaded.

Please try

/etc/init.d/vboxdrv setup

for recompiling and restarting virtualbox kernel module

comment:7 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

VirtualBox version 1.5.4 ensures that all old modules are removed before compiling a new module.

comment:8 Changed 6 years ago by hemcii

On ubuntu i got that error to and the /etc/init.d/vboxdrv setup failed to fix it.
I solved that error by installing virtualbox-ose-modules-2.6.24-19-386 by apt-get.

comment:9 Changed 6 years ago by frank

Right, you are talking about the OSE version while I was talking about the PUEL version from this website.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use