VirtualBox

Ticket #7217 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

Virtualbox 3.2.6 fails to compile

Reported by: sloonz Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Under latest ArchLinux, I can’t get VirtualBox compiling :

kBuild: cpp VgaBiosBin - /var/abs/local/virtualbox-ose/src/VirtualBox-3.2.6_OSE/src/VBox/Devices/Graphics/BIOS/vgabios.c
gcc: Corporation": No such file or directory
gcc: VM: No such file or directory
gcc: VirtualBox": No such file or directory
<command-line>::14: warning: missing terminating " character
<command-line>::15: warning: missing terminating " character
kmk[2]: *** [/var/abs/local/virtualbox-ose/src/VirtualBox-3.2.6_OSE/out/linux.x86/release/obj/VgaBiosBin/_vgabios_.c] Error 1
kmk[2]: *** Deleting file `/var/abs/local/virtualbox-ose/src/VirtualBox-3.2.6_OSE/out/linux.x86/release/obj/VgaBiosBin/_vgabios_.c'

Attachments

log.bz2 Download (389.7 KB) - added by sloonz 4 years ago.
Output of kmk -d

Change History

comment:1 Changed 4 years ago by frank

Please post the output which comes after the lines you posted. The kmk build system should print the command line of the failing command.

Changed 4 years ago by sloonz

Output of kmk -d

comment:2 Changed 4 years ago by sloonz

No, I don't have any command after that (only kmk leaving directories after the error). Attached the output of kmk -d, I hope there's something here

I suppose the problem is located in src/VBox/Devices/Graphics/BIOS/Makefile.kmk near line 77 : when I replace $(VBOX_VENDOR) and $(VBOX_PRODUCT) by empty strings, the error is gone — but it seems to fail to parse the vendor string a short while after. The problems are :

  1. I have absolutely no knowledge in kmk
  2. Why the hell I seem to be the only one having this problem on something that looks so trivial ? (escaping)

If I remove $(QUIET) before the suspect command, I get this : gcc -E -P \

-DVBOX -DVBOX_VERSION_STRING=\"3.2.6_OSE\" \ -DVBOX_VENDOR='"Oracle Corporation"' -DVBOX_PRODUCT='"Oracle VM VirtualBox"' \ -DVBE -DVGABIOS_DATE="" -DVBOX -DVBOX_OSE -DVBOX_WITH_64_BITS_GUESTS -DVBOX_WITH_HARDENING -UDEBUG \ -o /var/abs/local/virtualbox-ose/src/VirtualBox-3.2.6_OSE/out/linux.x86/release/obj/VgaBiosBin/_vgabios_.c /var/abs/local/virtualbox-ose/src/VirtualBox-3.2.6_OSE/src/VBox/Devices/Graphics/BIOS/vgabios.c

Which seems just fine to me, but if I run it manually (both under zsh and bash) I have the same error : gcc: Corporation": No such file or directory gcc: VM: No such file or directory gcc: VirtualBox": No such file or directory

I find this strange…

comment:3 Changed 4 years ago by sloonz

Sorry, I’m not used to WikiFormatting. The command :

gcc -E -P \
        -DVBOX -DVBOX_VERSION_STRING=\"3.2.6_OSE\" \
        -DVBOX_VENDOR='"Oracle Corporation"' -DVBOX_PRODUCT='"Oracle VM VirtualBox"' \
        -DVBE -DVGABIOS_DATE="''" -DVBOX -DVBOX_OSE -DVBOX_WITH_64_BITS_GUESTS -DVBOX_WITH_HARDENING -UDEBUG \
        -o /var/abs/local/virtualbox-ose/src/VirtualBox-3.2.6_OSE/out/linux.x86/release/obj/VgaBiosBin/_vgabios_.c /var/abs/local/virtualbox-ose/src/VirtualBox-3.2.6_OSE/src/VBox/Devices/Graphics/BIOS/vgabios.c

The error:

gcc: Corporation": No such file or directory
gcc: VM: No such file or directory
gcc: VirtualBox": No such file or directory

comment:4 Changed 4 years ago by sloonz

Shame on me. It was colorgcc fault — I installed years ago and eventually forgot that I installed it. You can close this bug :)

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for the feedback. But I'm using colorgcc as well without any problems (version 1.3.2.0-8). So you should probably update it and it should work.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use