VirtualBox

Ticket #7182 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Slower network transfer rate form host than any other machine on the net

Reported by: diputacionavila Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I have a two nodes (Node01 and Node02) cluster, each one is a blade, as host machine running CentOS 5.4 Linux 2.6.18-164.11.1.el5 #1 SMP Wed Jan 20 07:32:21 EST 2010 x86_64 x86_64 x86_64 GNU/Linux

Guest machine: Bridged network. CentOS 5.4 Linux 2.6.18-164.11.1.el5 #1 SMP Wed Jan 20 07:32:21 EST 2010 x86_64 x86_64 x86_64 GNU/Linux

If Node1 is running the guest VM these are the results:

Node1: [root@node01 ~]# scp guest:/root/VBoxTransfeRtest.iso . VBoxTransfeRtest.iso 100% 548MB 9.3MB/s 00:59

Node2: [root@node02 ~]# scp guest:/root/VBoxTransfeRtest.iso . VBoxTransfeRtest.iso 100% 548MB 15.2MB/s 00:36

Other machine on the net: [root@other ~]# scp guest:/root/VBoxTransfeRtest.iso . VBoxTransfeRtest.iso 100% 548MB 13.1MB/s 00:42

If I move the VM to node02 then that node is the slowest.

Guest machine could also be W2003/W2008 Server, results are similar.

The real problem comes doing a tape backup, then transfer slows down to 12-18 Kb/s when the backup software is running on the same node than the VM; otherwise gets up to 15 Mb/s.

Attachments

VBox.log Download (38.4 KB) - added by diputacionavila 4 years ago.

Change History

Changed 4 years ago by diputacionavila

comment:1 Changed 4 years ago by diputacionavila

Getting back to version 3.2.4 everything runs fine.

comment:2 Changed 4 years ago by frank

  • Component changed from network to network/hostif

comment:3 follow-up: ↓ 4 Changed 4 years ago by hoeferbe

I am seeing the same thing.

I'm running a CentOS 5.5 (x86_64) host with a Fedora 12 guest (x86_64). I noticed this behavior after uninstalling VirtualBox-3.1-3.1.8_61349_rhel5-1.x86_64.rpm and installing VirtualBox-3.2-3.2.6_63112_rhel5-1.x86_64.rpm on the host. Guest Additions were updated on the guest.

I have not tried down-grading as I have a work-around, for now.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 6 Changed 4 years ago by hoeferbe

I upgraded to VirtualBox 3.2.8 and this is still an issue.

comment:5 Changed 4 years ago by diputacionavila

After upgraded to 3.2.8 no differences found. Getting back to 3.2.4. everything looks fine.

comment:6 in reply to: ↑ 4 Changed 3 years ago by hoeferbe

I upgraded to VirtualBox 3.2.10 and this is still an issue. One thing I noticed -- and I'm not sure if this was happening back in 3.2.8 & 3.2.6 -- but the slowness only appears to be one way.

I scp'ed a 11 MB file from the guest to the host and it took over 9 minutes. (~151 kbps.) When I scp'ed that same file from the host to the guest it took less than 3 seconds. (34.6 Mbps.)

I've seen other examples of this; the host is a print & web server. If I try printing from the guest to the host, it takes a long time. If I try downloading a file from the host to the guest via a web browser, it goes quickly.

comment:7 Changed 3 years ago by diputacionavila

VirtualBox 4.0.4 still has this issue. Transfer rate slows down from several Mb/s to few b/s.

comment:8 Changed 3 years ago by aleksey

Could you try to disable TSO in the guests? Just in case, in Linux it can be done with:

ethtool -K eth0 tso off

comment:9 Changed 3 years ago by hoeferbe

Just a note: VirtualBox 4.0.6 still has this issue. However, I saw aleksey's 2011-04-15 note about disabling TSO (TCP Segmentation Offload) and tried it. It worked!

comment:10 Changed 3 years ago by diputacionavila

As hoeferbe says VirtualBox 4.0.6 still has this issue, but disabling TSO in the guest works fine.

comment:11 follow-up: ↓ 13 Changed 3 years ago by frank

Just to be sure: You guys are running CentOS 5 as host, correct?

comment:12 Changed 3 years ago by diputacionavila

That's right. CentOS 5 as host. I have upgraded recently to CentOS 5.6 Linux 2.6.18-238.9.1.el5

comment:13 in reply to: ↑ 11 Changed 3 years ago by hoeferbe

Replying to frank: ===

Just to be sure: You guys are running CentOS 5 as host, correct?

===

Yes:

# cat /etc/redhat-release
CentOS release 5.6 (Final)

# uname -a
Linux localhost.localdomain 2.6.18-238.9.1.el5 #1 SMP Tue Apr 12 18:10:13 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

comment:14 follow-up: ↓ 15 Changed 3 years ago by frank

In that case this sounds like a duplicate of #8683. Could you try to disable TSO like described there?

comment:15 in reply to: ↑ 14 Changed 3 years ago by hoeferbe

Replying to frank:
===

In that case this sounds like a duplicate of #8683. Could you try to disable TSO like described there?

===

I did, and it works! (See comment 9.)

comment:16 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Sorry, didn't see that comment. Closing as duplicate.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use