VirtualBox

Ticket #7181 (closed defect: fixed)

Opened 4 years ago

Last modified 12 months ago

Hostkey set to "None" blocks key "a" (similar effect that #7022)

Reported by: nbrouard Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description (last modified by frank) (diff)

Using latest 3.2.6 on Mac OSX, 3.2.6, when you change in Preferences -> Input and set your host key to None, the "a" key ("q" on French keyboard) doesn't work anymore on a WinXP or Linux Mandriva guest. On Linux even an xev doesn't react anymore.

When you set your hostkey back to Command Left (default) it works again. This is the first bug easy to reproduce.

The second limitation (bug?) is that when you set the default hostkey to Apple key and are using an external PC/Linux keyboard (not the MacBook? Pro keyboard). Then, you can't use anymore the Alt Gr (right) key to access any composed key. Clicking on the Alt right key makes it permanent and you can't type any normal key. The only way that I found to exit that strange state is to click and hold the left Alt key and click on the right Alt key.

To resume, I can't change the default hostkey to "none" because of the first bug and can't keep the default because of the second bug (on non Apple keyboard).

Change History

comment:1 Changed 4 years ago by frank

  • Host type changed from Linux to Mac OS X

So the host type is Mac OS X not Linux, correct?

comment:2 Changed 4 years ago by nbrouard

Yes, sorry. The host is a Mac OS and its effect in on any guest Linux or Windows. The 'none' option for the host key seems to be new.

comment:3 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use