VirtualBox

Ticket #714 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Bidirectional shared clipboard doesn't work and breaks clipboard of host -> please retry with 1.5.2 when it is released

Reported by: jay Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords: shared clipboard copy paste
Cc: Guest type: other
Host type: other

Description

When setting the "Shared Clipboard" to bidirectional copy&paste from host to guest doesn't work (unreadable signs get inserted in the guest), however from guest to host it works fine.

The second problem is that when virtualbox is started with "shared clipboard" set to bidirectional it completely breaks the copy & paste mechanism of the host operating system, in my case ubuntu feisty. With that I mean that I can copy text, but not paste it, because when pressing paste, most of the time nothing gets inserted and sometimes some unreadable signs get inserted. This applies to every program such as firefox, gedit, xterm, gnome-terminal, open office etc.

The other "shared clipboard" modes work fine (disabled, Host To Guest, Guest To Host).

My Guest is Windows XP SP2 and my Host is Ubuntu Feisty 7.04.

Change History

comment:1 Changed 7 years ago by michael

  • Summary changed from Bidirectional shared clipboard doesn't work and breaks clipboard of host to Bidirectional shared clipboard doesn't work and breaks clipboard of host -> please retry with 1.5.2 when it is released

This is most likely a problem with the Windows Guest Additions which has been fixed for 1.5.2 (due out in a few days time). It would be great if you could retry this when that version is released (you will have to install the Guest Additions from the new release).

comment:2 Changed 7 years ago by Murz

I have this problem too. VirtualBox 1.5. Guest is Ubuntu Feisty 7.04, 7.10. Host is Windows XP SP2.

When Guest system is loaded I can't copy and paste anything from clipboard in host system (WinXP), but in guest system (Linux) clipboard works good.

In VirtualBox 1.4 all works good.

I waiting for 1.5.2 version for testing.

comment:3 follow-up: ↓ 4 Changed 6 years ago by rgesswein

I can confirm this still happens under 1.5.2. Odd characters no longer appear, but clipboard on guest will often stop working. Text appears to be cut/copied properly, but paste does nothing. This seems to happen most frequently when non text data is copied on the host (with no intention of pasting to the guest) and then trying to copy and paste other data wholly within the guest.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 6 years ago by michael

Replying to rgesswein:

I can confirm this still happens under 1.5.2. Odd characters no longer appear, but clipboard on guest will often stop working. Text appears to be cut/copied properly, but paste does nothing. This seems to happen most frequently when non text data is copied on the host (with no intention of pasting to the guest) and then trying to copy and paste other data wholly within the guest.

Which host(s) and guest(s) did you see this with? It would be great if you could come up with a "recipe" with which you can consistantly reproduce it.

Thanks.

comment:5 in reply to: ↑ 4 Changed 6 years ago by rgesswein

Replying to michael:

Replying to rgesswein:

I can confirm this still happens under 1.5.2. Odd characters no longer appear, but clipboard on guest will often stop working. Text appears to be cut/copied properly, but paste does nothing. This seems to happen most frequently when non text data is copied on the host (with no intention of pasting to the guest) and then trying to copy and paste other data wholly within the guest.

Which host(s) and guest(s) did you see this with? It would be great if you could come up with a "recipe" with which you can consistently reproduce it.

Thanks.

I'm running Vista Business Host, Windows XP Guest. Unfortunately, I cannot reproduce this on demand. The problem seems to occur most when working on the host for a while, copying and pasting non-text data, and then going back into the guest. Even if the host copy/paste had nothing to do with the guest.

I've set clipboard to Host->Guest only and will see what effect that has.

comment:6 follow-up: ↓ 7 Changed 6 years ago by sunlover

Please try with the clipboard fix attached to ticket 824.

comment:7 in reply to: ↑ 6 Changed 6 years ago by rgesswein

Replying to sunlover:

Please try with the clipboard fix attached to ticket 824.

I've been running with the ticket 824 fix for a few days now (bi-directional) and copy paste works well except for one issue. On the host only, cut/copy of files within the host stops working in programs not related to VirtualBox. For example, I select "cut" in Windows Explorer, the file dims like the cut operation has been done, but paste doesn't work and nothing appears in the clipboard. This clears itself after a time, but immediate attempts of copy/paste on the host only doesn't seem to clear the problem. Copy/paste of text still works as expected.

comment:8 follow-up: ↓ 9 Changed 6 years ago by sunlover

I can not reproduce the WindowsExplorer cut/paste problem here (XP guest/XP host). Does it happen always or there are some specific steps to reproduce it? I'll try with Vista, but I need to know what exactly to do.

comment:9 in reply to: ↑ 8 Changed 6 years ago by rgesswein

Replying to sunlover:

I can not reproduce the WindowsExplorer cut/paste problem here (XP guest/XP host). Does it happen always or there are some specific steps to reproduce it? I'll try with Vista, but I need to know what exactly to do.

So far, the problem only appears when I'm running a Vista host (XP guest). This issue shows up daily, but not with any particular actions. For example, yesterday the problem surfaced immediately after starting my guest. No actions on the guest yet, just the file cut/paste didn't work after booting up XP my guest.

My only suggestion to reproduce this is to try a bunch of copy/paste of text between the host and guest then see if copy/paste works within explorer (or any other similar application). I'll also see if I can notice any specific circumstances that can consistently cause the behavior.

comment:10 follow-up: ↓ 11 Changed 6 years ago by oxmosys

I also have this bug in Linux Ubuntu Gutsy 7.10 host and Windows XP guest. I can't find a "recipe" to reproduce the bug but it happens very often, most of time when I copy text from the ubuntu host system that contain special characters like / : ? ( a Internet adress, for example ).

And sometime, when I copy a file from a place to another inside Ubuntu Nautilus file manager or just a Internet URL, Guest Windows XP in VirtualBox is suddenly dropped/crashed.

I must say that I oftenly use listening ultraVNC client in guest Windows XP which share clipboard between Windows and the remote computer. I suspect that it help to provoke the bug.

comment:11 in reply to: ↑ 10 Changed 6 years ago by michael

Replying to oxmosys: Could you describe your particular symptoms a bit more precisely? Or are they always VirtualBox/guest system crashes?

comment:12 Changed 6 years ago by oxmosys

Yes. On a machine which use Linux Ubuntu as host and Windows XP as guest, when I run Windows XP inside VirtualBox and that I copy a Internet URL or if I copy a file in nautilus under Linux Ubuntu, the Windows XP guest system will sometime be dropped (Aborded). The Windows XP guest windows just disappear like if the system was shut down, approximately 2 seconds after I've copied something in my clipboard, and then I see the state of this system in VirtualBox which is set to "Aborded".

comment:13 Changed 6 years ago by h3

Similar problem here on Ubuntu Gutsy with VB 1.5.0_OSE, whenever I start the VM it breaks the host clipboard.

After that whatever I copy/paste on the host (host->host, not host->guest or guest->host) will be replaced by "ŸŸ".

This is a VERY annoying bug, I will try to update to 1.5.2 but I'm not sure how..

comment:14 Changed 6 years ago by michael

The current release is 1.5.6, with 1.6.0 in preparation. If you are having trouble upgrading Ubuntu's package, you might want to try the binary release from virtualbox.org/Sun.

comment:15 Changed 6 years ago by h3

Thanks michael,

I managed to install 1.5.6 with these instructions:

 http://untitledfinale.wordpress.com/2007/10/22/virtualbox-152-a-lot-of-improvements-lets-install-it-on-ubuntu-gutsy/

It wasn't quite easy.. I first installed it and removed the old one in the same operation, that was a no go. So I uninstalled both and reinstalled, got some weird errors.. After reinstalling twice VB would start but I had to discard the state of the VM in order to boot it.

After that everything worked fine and the clipboard problem is gone.

Great :) Thanks again.

comment:16 Changed 6 years ago by h3

Damn.. I spoke too fast, now the seamless mode is completely broken.. Will check if there is a bug report about it, if not I'll create one.

comment:17 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

I will close this defect however, as it seems to be fixed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use