VirtualBox

Ticket #7112 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

VirtualBox GUI has stopped working - Linux Guests

Reported by: dean67 Owned by:
Priority: major Component: GUI
Version: VirtualBox 3.2.6 Keywords: VirtualBox GUI crash
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

When selecting machine->close->Send the shutdown signal => error: Virtualbox GUI stopped working.

  • This also happens when the machine shuts down from the guest os.
  • The error also happens with the ACPI shutdown.

This only happens with linux guests (Ubuntu 10.04, 9.10 OpenSUSE 11.2), shutdowns with windows guests (XP prof , W2k) are going well.

The Virtualbox GUI that is crashing is the Virtualbox GUI of the guest machine, the main GUI (where the VM's are listed) keeps working.

This error could be related to ticket:6857, except that in my case machine->close->power off machine works fine.

Attachments

Ubuntu 10.04-2010-07-02-16-33-13.log Download (71.3 KB) - added by dean67 4 years ago.

Change History

Changed 4 years ago by dean67

comment:1 Changed 4 years ago by dean67

Update:

On creating a new VM with a fresh virtual disk, VirtualBox 3.2.6 assigns this disk to a SATA controller by default, these were the Linux guests where the VirtualBox GUI stopped working after a shutdown signal. Assigning the virtual disk to an IDE controller solved this for me.

The window guests were some "old" VM where the disks are assigned to an IDE contoller

So the problem is not a Linux/Window guest problem but a IDE\SATA controller problem.

comment:2 Changed 4 years ago by marcori

Hi, Using VirtualBox 3.2.8 on Windows XP Host, i have the same problem when i shutdown an Ubuntu 10.04 Linux Guest; When i've disabling the absolute pointing device in the guest settings, all seems working fine now... Mmmm. Linux use ahci for his controller, isn't it ?

comment:3 Changed 4 years ago by frank

  • Description modified (diff)

dean67, any change with VBox 3.2.8?

marcori, your problem seems to be different because AHCI has nothing to do with the absolute pointing device.

comment:4 Changed 4 years ago by dean67

@Frank

So far so good , no problems with 3.2.8

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

In that case I will close this ticket. Please reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use