VirtualBox

Ticket #7102 (closed defect: fixed)

Opened 4 years ago

Last modified 19 months ago

3.2.x No longer PXE Boot Ubuntu 9.04, 9.10, 10.04 Guests - DHCP fails (AFTER PXE has TFTP'd Kernel and initramfs)

Reported by: nickb834 Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.2.6 Keywords: DHCP PXE Regression
Cc: Guest type: Linux
Host type: Mac OS X

Description (last modified by frank) (diff)

I am no longer able to succesfully PXE boot Ubuntu 9.04,9.10 or 10.04 from my Ubuntu 10.04 server using at least3.2.6.x versions of Virtualbox.

The server itself is configured correctly (I can PXE boot any of the aforementioned Ubuntu versions using either Paralles or VMWare Fusion - ergo server config proved right). I can also PXE boot real machines from this PXE Server.

My Vbox host is Intel MacBook Pro running 10.6.4.

In Virtualbox what happens is the guest pxe boots, receives the kernel and the initramfs, and right at the point before it mounts the root fs over nfs (this is a livecd version of Ubuntu remember) it stops with the following on the console:

ipconfig: /tmp/net-eth0.conf : SIOCGIFINDEX: No such device

That error in and of itself is not a problem, even when the PXE boot works in VMware / Parralells or a real PC that message is always present.

This behaviour occurs no matter which of the Bridged nic types (either of the amds or the three intel versions) I select.

On a working PXE boot (Vmware, parralells, real pc) what should appear next is:

IP-Config: eth0 guessed broadcast address 10.0.0.31

So it appears as if the DHCP offer is not making it back to the guest in Vbox OR the DHCP req is not making it from the guest in Vbox. Which is why my guest hangs.

The very last Sun branded version of VirtualBox definately booted these Ubuntu Live CD's so therefor I am certain that this is a regression since the Oracle branding was applied (though I am not implying that this is the cause!!).

I beleive there is a regression in the networking stack / layer / implementation of Virtualbox.

Through my troubleshooting I beleive I have performed the following:

Proved that the PXE server and NFS server config is correct as VMware, Parallels and Real PC's can PXE boot from it. This proves the media they are booting from (cables etc). Proved that my OS X install is sane. Proved it isnt a Ubuntu bug as Ubuntu 9.04 for eg is over 12 months old without change as it's a live cd - and I used to be able to boot this via PXE with the same server in VirtualBox.

I will endeavour to find the last working version of Vbox such that it is easier to track down what changed between now and then in the portions of the source pertaining to networking.

Attachments

VBox.2.log Download (55.8 KB) - added by nickb834 4 years ago.
VBox.log - check line 726 for the last activity before I shutdown the guest
VBox.log Download (55.8 KB) - added by nickb834 4 years ago.
VBox.log - check line 726 for the last activity before I shutdown the guest
PXE_Linux.xml Download (3.8 KB) - added by nickb834 4 years ago.
VM Config

Change History

comment:1 Changed 4 years ago by nickb834

This may actually be related to #7101 - bridging regression on windows host - as I'm trying to use bridging too.

That said bridging works enough for me that the guest can pull down the kernel and initramfs, but fails when it attemps to dhcp an address to pull down the rootfs over nfs.

comment:2 Changed 4 years ago by nickb834

Installed Virtualbox versions all the way back to 3.0.0 issue still persists - which indicates that this may be down to a change in my OS X host - which has been patched from 10.6.0 to 10.6.4 (and all versions inbetween) since I've been running Virtualbox.

I'll try VirtualBox on Windows 7 host to see if issue persists.

comment:3 Changed 4 years ago by nickb834

Windows 7 host on different hardware and bridging in 3.2.6 is even worse.

I flat out don't get a DHCP offer at all - not even for the PXE firmware client. At least in VB on OS X I can get past that part.

So to recap:

OS X (10.6.4) with VB 3.x.x (I tried all versions) can PXE the kernel and initramfs from a working PXE and NFS server - but can't rx DHCP offer to mount root filesystem over NFS.

Windows 7 Ult x86 with VB 3.2.6 using the exact same real PXE server as my OS X machine can't even PXE the kernel and initramfs.

My OS X with VMWare Fusion or Parallels can PXE just fine from the server - ergo it must be VirtualBox. Although in mitigation - 3.1.x has worked on versions of OS X (at least 10.6.0 and 10.6.1) but now now version works on 10.6.4.

Changed 4 years ago by nickb834

VBox.log - check line 726 for the last activity before I shutdown the guest

Changed 4 years ago by nickb834

VBox.log - check line 726 for the last activity before I shutdown the guest

Changed 4 years ago by nickb834

VM Config

comment:4 Changed 4 years ago by frank

  • Component changed from network to network/hostif

comment:5 Changed 3 years ago by nickb834

Still present bug in VB 4.0.0 :-(

Beginning to wonder if this is an OS X regression rather than VB? Although, VMWare and Parralels continue to PXE boot of the same server whilst ANY version of VB from at least 3.0.0 onwards continues to fail.

comment:6 Changed 2 years ago by frank

  • Description modified (diff)

Still relevant with VBox 4.1.14? If so, could you test if  this build fixes your problem?

comment:7 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use