VirtualBox

Ticket #7101 (reopened defect)

Opened 4 years ago

Last modified 3 years ago

Bridging not working anymore (VBox 3.2.0 regression; Marvell?)

Reported by: screenie Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

i am running debian lenny 32bit and upgraded virtualbox from 3.1. up to 3.2.6; after the upgrade it works expect the network (windows xp guest with intel pro 1000 driver); the host is a dell xps m1530 notebook with the marvell 88e8040 ethernet controller;

setting it to nat mode works, but bridging mode does not work anymore....

deinstalling 3.2.6 and re-installing 3.1 does also not help, because the windows xp guest is starting and network in bridging mode works again - but the console window will not be displayed on 3.1 now....

so i upgraded again to 3.2.6 where only nat is working...

Attachments

VBox.log Download (79.1 KB) - added by screenie 4 years ago.
Screenshot-winxppro - Settings.png Download (102.0 KB) - added by screenie 4 years ago.
Screenshot-winxppro [Running] - Oracle VM VirtualBox.png Download (97.5 KB) - added by screenie 4 years ago.

Change History

comment:1 Changed 4 years ago by frank

Please explain bridged mode not working in detail.

comment:2 Changed 4 years ago by screenie

hum....

you have the choice to select on the network settings 'Not Attached, NAT, Bridged Adapter, Internal Network, Host only Adapter'

i am talking about 'Bridged Adapter' which was working in version 3.1 but not after upgrading to 3.2.6 (no connectivity to other ip's in the same subnet) - when i change it to 'NAT' than i can reach ip's outside;

the 'Bridged Adapter' is 'br0' on the host, guest adapter type is 'Intel PRO/1000 MT Desktop (82540EM)'

Exactly the same settings as on version 3.1 with the difference that it will not work in 3.2.6;

msi-x:/# lsmod | grep vbox
vboxnetadp              7392  0 
vboxnetflt             15848  1 
vboxdrv               182632  3 vboxnetadp,vboxnetflt


msi-x:/# cat /etc/vbox/interfaces 
# This file is for registering VirtualBox permanent host networking interfaces
# and optionally adding them to network bridges on the host.
# Each line should be of the format <interface name> <user name> [<bridge>].
vbox0 ajoelly br0


msi-x:/# cat /etc/group | grep vbox
vboxusers:x:117:ajoelly


msi-x:/# cat /etc/network/interfaces 
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto br0
iface br0 inet dhcp
	bridge_ports eth0
	bridge_maxwait 5
	bridge_fd 0


msi-x:/# ifconfig
br0       Link encap:Ethernet  HWaddr 00:21:9b:d2:6f:e4  
          inet addr:10.16.252.11  Bcast:10.16.252.63  Mask:255.255.255.192
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:41176 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24488 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:51932437 (49.5 MiB)  TX bytes:1770794 (1.6 MiB)

eth0      Link encap:Ethernet  HWaddr 00:21:9b:d2:6f:e4  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:41177 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24488 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:51932792 (49.5 MiB)  TX bytes:1770794 (1.6 MiB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1306 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1306 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:57428 (56.0 KiB)  TX bytes:57428 (56.0 KiB)

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

This doesn't work anymore. The bridge setup you are describing was changed long time ago (in VBox 2.2 IIRC). Please open the VM settings, change to bridged mode, then select the host eth0 adapter where you want to attach your guest VM. All this is described in the user manual.

comment:4 Changed 4 years ago by screenie

  • Status changed from closed to reopened
  • Resolution worksforme deleted

there is no difference if i use the br0 or the eth0 adapter - it works in none of them in bridged mode, only in nat mode

comment:5 Changed 4 years ago by frank

In that case please add a VBox.log file where you attached your VM to the eth0 device. And please make sure that eth0 is properly connected.

Changed 4 years ago by screenie

comment:6 Changed 4 years ago by screenie

VBox.log added and this are the host network setting:

msi-x:/# cat /etc/network/interfaces 
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface

allow-hotplug eth0
iface eth0 inet dhcp


msi-x:/# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:21:9b:d2:6f:e4  
          inet addr:10.16.252.11  Bcast:10.16.252.63  Mask:255.255.255.192
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1618 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1818 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:166887 (162.9 KiB)  TX bytes:264085 (257.8 KiB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:992 errors:0 dropped:0 overruns:0 frame:0
          TX packets:992 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:40264 (39.3 KiB)  TX bytes:40264 (39.3 KiB)


msi-x:/# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.16.252.0     0.0.0.0         255.255.255.192 U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
0.0.0.0         10.16.252.1     0.0.0.0         UG    0      0        0 eth0

Changed 4 years ago by screenie

Changed 4 years ago by screenie

comment:7 Changed 4 years ago by frank

Any firewall rules set up on your host?

comment:8 Changed 4 years ago by screenie

no, nothing installed like this....

comment:9 Changed 4 years ago by screenie

when i go back to version 3.1 it works without any changes on the host, virtualbox settings or on the guest:

msi-x:/# dpkg -r virtualbox-3.2
(Reading database ... 184018 files and directories currently installed.)
Removing virtualbox-3.2 ...
Stopping VirtualBox kernel module:done..


msi-x:/# dpkg -i /home/ajoelly/software/virtualbox/virtualbox-3.1_3.1.2-56127_Debian_lenny_i386.deb 
Selecting previously deselected package virtualbox-3.1.
(Reading database ... 183493 files and directories currently installed.)
Unpacking virtualbox-3.1 (from .../virtualbox-3.1_3.1.2-56127_Debian_lenny_i386.deb) ...
Setting up virtualbox-3.1 (3.1.2-56127_Debian_lenny) ...
Installing new version of config file /etc/init.d/vboxdrv ...
addgroup: The group `vboxusers' already exists as a system group. Exiting.
Starting VirtualBox kernel module:done..


msi-x:/# ping 10.16.252.12
PING 10.16.252.12 (10.16.252.12) 56(84) bytes of data.
64 bytes from 10.16.252.12: icmp_seq=37 ttl=128 time=0.560 ms
64 bytes from 10.16.252.12: icmp_seq=38 ttl=128 time=0.451 ms
64 bytes from 10.16.252.12: icmp_seq=39 ttl=128 time=0.441 ms
64 bytes from 10.16.252.12: icmp_seq=40 ttl=128 time=0.382 ms
64 bytes from 10.16.252.12: icmp_seq=41 ttl=128 time=0.318 ms
64 bytes from 10.16.252.12: icmp_seq=42 ttl=128 time=0.323 ms
64 bytes from 10.16.252.12: icmp_seq=43 ttl=128 time=1.54 ms
64 bytes from 10.16.252.12: icmp_seq=44 ttl=128 time=0.555 ms
64 bytes from 10.16.252.12: icmp_seq=45 ttl=128 time=0.273 ms
64 bytes from 10.16.252.12: icmp_seq=46 ttl=128 time=0.345 ms
^C
--- 10.16.252.12 ping statistics ---
46 packets transmitted, 10 received, 78% packet loss, time 45103ms
rtt min/avg/max/mdev = 0.273/0.519/1.544/0.354 ms
msi-x:/#

comment:10 Changed 4 years ago by frank

The previous log looks strange. Did you start the VM after you installed VBox 3.1.2?

comment:11 Changed 4 years ago by screenie

yes, there are some missed ping's but that's ok;

after installing 3.1.2 i started the ping, then i started the vm via the virtualbox gui and ping started to work when the network part from the guest was running;

comment:12 Changed 4 years ago by frank

That's really strange. I have no idea what changed but you could help if you would try if VBox 3.1.4, 3.1.6 and 3.1.8 work/don't work for you.

comment:13 Changed 4 years ago by screenie

just tried - all 3.1 versions working up to 3.1.8, but none of the 3.2.x versions

comment:14 Changed 4 years ago by frank

  • Summary changed from bridging not working anymore after upgrade from 3.1 tu 3.2.6 to Bridging not working anymore (VBox 3.2.0 regression; Marvell?)

Thanks for this additional information.

comment:15 Changed 4 years ago by Technologov

interesting...

comment:16 Changed 4 years ago by jcw40

I am experiencing a similar problem with bridged networking and VirtualBox 3.2.x. My host environment is somewhat different though. I did not have problems with 3.1.x. I upgraded for Fedora13 support.

My host is: OpenSolaris snv134 64 bit on AMD Phenom II 8GB (AMD-V and Nested paging features enabled) with Realtek Gigabit interface and rge driver. I'm running Windows XP, Fedora13 and SuSE 11 as 32bit guests.

I find that the bridged interface works for a while after booting the guest but always hangs at some point afterwards. NAT works reliably. All guests experience the interface hang. A restart of the guest usually fixes the problem for a while.

comment:17 in reply to: ↑ description ; follow-up: ↓ 18 Changed 4 years ago by maru

I have yet a similar problem on my setup here.

For me Birdging is partly working with partly I mean the following.

I have a macosx host with a windows xp guest. The guest is using the bridge networking. Which works ok. I can reach everything. Inside this guest I am running yet another Virtual PC 2007 instance to emulate a Pocket PC for ActiveSync testing. This one is also using the network with its own NE2000 driver. Up the the latest 3.1 release this emulated Pocket PC gets an IP as well and can connect to the internet. Starting with 3.2.0 this no longer works. I can see some packages when using tcpdump it even gets a return from a DNS request but that's it. I can ping it but it cannot connect to anything. As I said 3.0.x and 3.1.x releases work with this setup. Only the 3.2.x releases are broken for me.

comment:18 in reply to: ↑ 17 Changed 3 years ago by vwin

I have a similar problem too. I recently upgraded to 3.2.1 in Ubuntu 10.04 , NAT works fine and takes up the IP address of the host computer. Windows XP host when set up using bridge eth0 does not have internet connectivity.

dmes gives the following log:

[ 1311.944858] e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
[ 1311.944863] 0000:00:19.0: eth0: 10/100 speed: disabling TSO
[ 1311.945118] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1311.945199] bridge0: port 1(eth0) entering forwarding state
[ 1320.536007] tap1: no IPv6 routers present
[ 1321.448008] bridge0: no IPv6 routers present
[ 1322.916009] eth0: no IPv6 routers present
[ 2559.908619] e1000e: eth0 NIC Link is Down
[ 2559.924787] bridge0: port 1(eth0) entering disabled state
[ 2564.492865] e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
[ 2564.492870] 0000:00:19.0: eth0: 10/100 speed: disabling TSO
[ 2564.493121] bridge0: port 1(eth0) entering forwarding state
[ 4420.532521] VBoxTestOGL[3629]: segfault at 4 ip 00fa95a0 sp bf81dfac error 4 in libGL.so.1.2[f3c000+b4000]
[ 5033.313609] gnome-screensav[3660]: segfault at 4 ip 0075b5a0 sp bff43b0c error 4 in libGL.so.1.2[6ee000+b4000]
[ 5374.860552] VBoxTestOGL[3707]: segfault at 4 ip 00f935a0 sp bfa0193c error 4 in libGL.so.1.2[f26000+b4000]
[ 5377.027726] VBoxTestOGL[3715]: segfault at 4 ip 005b45a0 sp bfcead7c error 4 in libGL.so.1.2[547000+b4000]

Has anybody solved this problem yet? I need to have two separate IP addresses for the host and guest and this is not happening at the moment,

Replying to maru:

I have yet a similar problem on my setup here.

For me Birdging is partly working with partly I mean the following.

I have a macosx host with a windows xp guest. The guest is using the bridge networking. Which works ok. I can reach everything. Inside this guest I am running yet another Virtual PC 2007 instance to emulate a Pocket PC for ActiveSync testing. This one is also using the network with its own NE2000 driver. Up the the latest 3.1 release this emulated Pocket PC gets an IP as well and can connect to the internet. Starting with 3.2.0 this no longer works. I can see some packages when using tcpdump it even gets a return from a DNS request but that's it. I can ping it but it cannot connect to anything. As I said 3.0.x and 3.1.x releases work with this setup. Only the 3.2.x releases are broken for me.

comment:19 Changed 3 years ago by frank

  • Component changed from network to network/hostif

comment:20 Changed 3 years ago by aleksey

Can anybody confirm the problem is still present in 4.0.2?

comment:21 Changed 3 years ago by philippe41

Similar problem here on vbox 4.0.6 running on CentOS 5.6 x86_64 for 2 bridged guests (WinXP x86 + Linux CentOS 5.6 x86_64). Oracle Extension on host and VBox guest additions on guests are installed. Dhcp guests fails to get their adress, pinging guests may work from time to time but not reliable. Trying to reach tcp services hosted on vbox guests (ssh, http, ftp) from outside always fails (timeout), with or without firewall on host and/or guests. Trying to reach tcp services from guests to outside works. No problem in nat mode.

comment:22 Changed 3 years ago by aleksey

If the problem still persists please enable internal packet capture for VM (see  http://www.virtualbox.org/wiki/Network_tips), reproduce the problem, and send the resulting file along with the log to aleksey dot ilyushin at oracle dot com. Thanks in advance!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use