VirtualBox

Ticket #7096 (closed defect: duplicate)

Opened 4 years ago

Last modified 2 years ago

VM state change fail when host disk is full

Reported by: alien_from_far Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: other
Host type: Windows

Description

If VM is running or i'm trying to pause or save state of VM and host disk is full then the VM sould be paused but it's not. It gray's out and on any manipulations it says "INVALID VM STATE".

Attachments

VBox.log Download (52.9 KB) - added by alien_from_far 4 years ago.
2.JPG Download (27.9 KB) - added by alien_from_far 4 years ago.
VB full.log Download (104.7 KB) - added by alien_from_far 3 years ago.
Full log of VM, saving fail, (after fail) resize and termination (from task manager)
VB cut around error.log Download (1.8 KB) - added by alien_from_far 3 years ago.
The place exactly around error.
VB.log Download (1.8 KB) - added by alien_from_far 3 years ago.
Sorry, correction for wrong log post.

Change History

Changed 4 years ago by alien_from_far

Changed 4 years ago by alien_from_far

comment:1 Changed 3 years ago by alien_from_far

Current version of VB is 4.1 Host: Win XP x64 Guest: Ub 10.04 x64

During saving of guest state host disk runed out of free space. Guest grayd out and says that paused but there not possible to pause/unpause it (error appears: VBOX_E_INVALID_VM_STATE (0x80BB0002)) - even host disk have more then enough space now. Now I have to terminate it. Now log attached.

Changed 3 years ago by alien_from_far

Full log of VM, saving fail, (after fail) resize and termination (from task manager)

Changed 3 years ago by alien_from_far

The place exactly around error.

comment:2 Changed 3 years ago by alien_from_far

VB 4.1.2 Host: Win XP x64 Guest: Win 7 x64

07:35:35.231 Changing the VM state from 'RUNNING' to 'SUSPENDING'. 07:35:35.305 AIOMgr: Endpoint for file 'Q:\.VirtualBox\HardDisks\HDD_10.vdi' (flags 000c0781) created successfully 07:35:35.339 Changing the VM state from 'SUSPENDING' to 'SUSPENDED'. 07:35:37.055 Changing the VM state from 'SUSPENDED' to 'RESUMING'. 07:35:37.055 AIOMgr: Endpoint for file 'Q:\.VirtualBox\HardDisks\HDD_10.vdi' (flags 000c0723) created successfully 07:35:37.106 Changing the VM state from 'RESUMING' to 'RUNNING'. 07:37:21.724 Changing the VM state from 'RUNNING' to 'SUSPENDING'. 07:37:21.803 AIOMgr: Endpoint for file 'Q:\.VirtualBox\HardDisks\HDD_10.vdi' (flags 000c0781) created successfully 07:37:21.836 Changing the VM state from 'SUSPENDING' to 'SUSPENDED'. 07:37:24.983 Changing the VM state from 'SUSPENDED' to 'SAVING'. 07:37:31.815 ssmR3StrmWriteBuffers: Write failed with rc=VERR_DISK_FULL at offStream=0x1a49adb9 07:37:31.884 SSM: Execute save failed with rc=VERR_DISK_FULL for data unit 'pgm'/#1. 07:37:32.351 SSM: Failed to save the VM state to 'Q:\.VirtualBox\Machines\W7\Snapshots\2011-09-27T18-49-56-890625000Z.sav' (file deleted): VERR_DISK_FULL 07:37:32.368 Changing the VM state from 'SAVING' to 'SUSPENDED'. 07:38:14.396 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={Cannot resume the machine as it is not paused (machine state: Saving)}, preserve=false 07:38:37.472 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={Already paused}, preserve=false 07:38:45.619 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={Cannot resume the machine as it is not paused (machine state: Saving)}, preserve=false

Version 0, edited 3 years ago by alien_from_far (next)

Changed 3 years ago by alien_from_far

Sorry, correction for wrong log post.

comment:3 Changed 2 years ago by alien_from_far

Still in version 4.1.6

comment:4 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Most probably a duplicate of #6189.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use