VirtualBox

Ticket #7073 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Export two times slower and creates larger vmdk file (3.2.6 regression) => fixed in SVN

Reported by: mooninite Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I was happily exporting a RHEL5 VM in about 40 minutes with a 876 meg VMDK file under VBox 3.2.4. After upgrading to 3.2.6 today, I wanted to see if the export would be faster. Boy was I surprised when it has taken well over an hour (approximately 1 hour and 10 minutes) and the VMDK file is 1.2 gigs in size to perform the exact same export operation. Please note I have not started the VM inbetween export attempts between the two VBox versions. I am exporting to a locally mounted file system (my root partition to be exact) so there is no network interference.

Host: Fedora 13 x86_64
Kernel: kernel-2.6.33.5-124.fc13.x86_64
Version: VirtualBox-3.2-3.2.6_63112_fedora13-1.x86_64
Host Filesystem: xfs

Change History

comment:1 Changed 4 years ago by frank

  • Component changed from GUI to virtual disk
  • Summary changed from Export two times slower and creates larger vmdk file to Export two times slower and creates larger vmdk file (3.2.6 regression)

comment:2 Changed 4 years ago by klaus

Can you provide more details about the source disk image? What's its nominal capacity (see virtual media manager)? What's approximately in it? If it's an OS install, what OS? What kind of files are filling up the majority of the disk space used? What filesystem?

From your description it vaguely sounds as if VirtualBox incorrectly writes "more data" than it should, i.e. replaces zero data with non-zero data. That would explain why it takes longer and why the resulting image is bigger.

comment:3 Changed 4 years ago by mooninite

Guest Info:
RHEL 5.5
All defaults used during OS install.
File System: ext3
Only one drive is attached. 32 GB dynamic storage.

$ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                       30G  2.3G   26G   9% /
/dev/sda1             487M   17M  445M   4% /boot
tmpfs                 252M     0  252M   0% /dev/shm

Mostly OS files are installed. There is a small, user-space only, proprietary program installed (roughly 100 megs).

comment:4 Changed 4 years ago by aeichner

  • Summary changed from Export two times slower and creates larger vmdk file (3.2.6 regression) to Export two times slower and creates larger vmdk file (3.2.6 regression) => fixed in SVN

This was fixed in svn and will be included in the next maintenance release. Thanks for the report and sorry for any inconveniences!

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:6 Changed 4 years ago by mooninite

Just tried out 3.2.8. While it's not as bad as 3.2.6, it still took about 1 hour and the file size is 953MB. I guess this will do.

comment:7 Changed 4 years ago by mitchellh

Just tried out 3.2.8 as well. Some notes about a completely untouched VM since 3.1.x:

Host: Mac OS X 10.6.4

Guest: Ubuntu Lucid 32-bit

3.1.8 export: 272 MB

3.2.6 export: 751 MB

3.2.8 export: 495 MB

So while there was an improvement, something is still amiss with the 3.2.x series and exporting.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use