VirtualBox

Ticket #7017 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

POP3 not working with NAT in versions since 3.2.0

Reported by: pupemail Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.2.2 Keywords: NAT POP3
Cc: Guest type: Windows
Host type: Windows

Description

Windows 7 64 bit host, Windows XP SP3 guests. When I upgraded to 3.2.0 none of my guests were able to POP my email accounts when using NAT, bridged they are fine. I downgraded to 3.1.8 and the guests could once again POP my email using NAT (even leaving 3.2.0 guest additions installed on the guest). I then tried 3.2.2 and experienced the same issue, had to go back to 3.1.8. I tried numerous variations of --nataliasmode1 sameports, proxyonly but never got NAT and POP to work with 3.2.x. I haven't tried 3.2.4 since the change log doesn't look promising and I've been pressed for time. No VBox.log file is attached because I had to revert back to 3.1.8 and don't have the time to switch 3.2.x in and out again. I need NAT because I travel alot and bridging to my wireless adapter doesn't work at most hotels and some client sites.

Change History

comment:1 Changed 4 years ago by Hachiman

Unfortunately, I couldn't reproduce the problem you've described. What I have done:

  1. created test gmail account
  2. configured account/mail client
  3. send mail from the host and received it in guest's mail client.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Please reopen if it still does not work with VBox 3.2.8 and you can provide more information.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use