VirtualBox

Ticket #6993 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

NAT network loses connectivity after using p2p like program

Reported by: kidault Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.2.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Host: win7pro, guest: winXP home

Yesterday, I made a snapshot and installed Xunlei(an download accelerator with p2p function, popular in China). After starting the program for 2 or 3 hours, the guest OS lost the NAT connectivity, while the host-only network was still working fine. The traffic mainly passed through the NAT adapter.

Ping to the NAT gateway(10.0.2.2) received no response. After I released the network address and renewed it, I got the "An error occurred while renewing interface LC : unable to contact your DHCP server. Request has timed out." message.

The problem has happened twice, in exactly the same routine.

I have setup a socks proxy on the host and run the Xunlei for about 10 hours. There is no problem with host-only adapter.

Xunlei homepage:  http://www.xunlei.com/ The client link:  http://down.sandai.net/Thunder5.9.21.1442.exe

The problem seems to happen around 02:13:52.669 in the log. I remember that when I noticed the loss of network connectivity, I release and renew the NAT adapter, get some information in chinese, like "the adapter has gotten an address the same as another adapter on the network, this adapter will be disabled"(translate from Chinese to English, not very exact). Several minutes late, when I tried the release and renew of NAT adapter process again, I got the "An error occurred while renewing interface LC : unable to contact your DHCP server. Request has timed out." message.

Attachments

WorkXP-2010-06-14-19-11-29.zip Download (12.3 KB) - added by kidault 4 years ago.

Change History

Changed 4 years ago by kidault

comment:1 Changed 4 years ago by Hachiman

Thanks for report. I will try to reproduce the issue.

comment:2 follow-up: ↓ 3 Changed 4 years ago by kidault

The Xunlei (or Thunder, "Lei" means thunder in chinese) is a program dedicated to Chinese market. So there is no English version. And I'm not sure whether it would work properly out of China. The Xunlei server may block IP out of China due to copyright reasons.

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 4 years ago by Hachiman

Replying to kidault:

The Xunlei (or Thunder, "Lei" means thunder in chinese) is a program dedicated to Chinese market. So there is no English version. And I'm not sure whether it would work properly out of China. The Xunlei server may block IP out of China due to copyright reasons.

Does it have some limit on open connections, some maximum value? The other question could you please when network problem occurred, shutdown vm to enforce statistic dump.

comment:4 in reply to: ↑ 3 Changed 4 years ago by Hachiman

Replying to Hachiman:

Replying to kidault:

The Xunlei (or Thunder, "Lei" means thunder in chinese) is a program dedicated to Chinese market. So there is no English version. And I'm not sure whether it would work properly out of China. The Xunlei server may block IP out of China due to copyright reasons.

Does it have some limit on open connections, some maximum value? The other question could you please when network problem occurred, shutdown vm to enforce statistic dump.

Could you please try 3.2.6 b2?

comment:5 Changed 4 years ago by kidault

I have used the Xunlei several times recently, it worked ok. The problem seems to have been fixed. Thank you.

comment:6 Changed 4 years ago by kidault

tested on 3.2.6 and 3.2.8

comment:7 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use