VirtualBox

Ticket #6984 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Default SATA port count of 30 is problematic for some users => Fixed in SVN

Reported by: UglyPercy Owned by:
Priority: critical Component: other
Version: VirtualBox 3.2.4 Keywords: sata port count
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

When creating a CentOS 4.6 VM via in VB 3.2.4 OSE via LibVirt 0.8.1 (modified to handle VB 3.2), the created VM will not start properly. It either freezes during hardware detection (for at least several minutes, possibly forever), or panics. Yet, frustratingly, if you perform *any* edit of the VM configuration -- even a null one where you just bring up the VM settings in the GUI and click "OK" -- the VM will start normally. This is very confusing to the user, since it is easy to believe that whatever random change you might have made is the one that fixed the VM.

Doing a simple "diff" before and after the null edit shows the following:

135c138
<       <StorageController name="SATA Controller" type="AHCI" PortCount="30" useHostIOCache="false" IDE0MasterEmulationPort="0" IDE0SlaveEmulationPort="1" IDE1MasterEmulationPort="2" IDE1SlaveEmulationPort="3"/>
---
>       <StorageController name="SATA Controller" type="AHCI" PortCount="1" useHostIOCache="false" IDE0MasterEmulationPort="0" IDE0SlaveEmulationPort="1" IDE1MasterEmulationPort="2" IDE1SlaveEmulationPort="3"/>

So there is at least one problem, that the default of 30 causes problems for CentOS 4.6 (and perhaps other Linuxes). Note that LibVirt does not itself provide the max port count -- that is hard-coded into VB 3.2.4 OSE at line 159 of "Main/StorageControllerImpl.cpp". But there also might be a second problem, where the VB GUI silently changes the value of the maximum SATA port count -- why would it do this, and does it silently modify (perhaps just clamp within certain bounds) the values of other fields?

Considering the days of effort I wasted over the past few months due to confusion caused by this subtle, insidious bug, I declare it to be "critical", but of course, feel free to adjust as desired.

Attachments

VBox.log Download (46.9 KB) - added by UglyPercy 4 years ago.
Log of run with 30 SATA ports that froze at "Initializing hardware" line

Change History

Changed 4 years ago by UglyPercy

Log of run with 30 SATA ports that froze at "Initializing hardware" line

comment:1 Changed 4 years ago by frank

  • Description modified (diff)
  • Summary changed from Default SATA port count of 30 is problematic for some users to Default SATA port count of 30 is problematic for some users => Fixed in SVN

This will be fixed in the next maintenance release.

comment:2 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 Changed 4 years ago by Technologov

UglyPercy: a bit offtopic question: (I ask here, because I don't have your email)

Do you use libvirt with which application ? A standard version of "Virt-Manager" GUI, to my understanding, does not expose VirtualBox engine to the end-users.

So you use a custom version of virt manager, or a different application? May we know, which one ?

-Technologov, al4321@…

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use