VirtualBox

Ticket #6976 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

64-bit Windows 7 guest refuses to finish installation on 64-bit Lucid host

Reported by: xtknight Owned by:
Priority: critical Component: other
Version: VirtualBox 3.2.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Hi,

I've got an Ubuntu Lucid 64-bit host and also a CPU with vmx support (Core i7). Motherboard is ASUS P6T Deluxe. kvm modules are not loaded on Ubuntu, and should not interfere with VMX.

I'm trying to run a Windows 7 64-bit guest on VirtualBox 3.2.4 r62467. I've tried installing it at least five times. One time it succeeded but after that I just got random errors.

I ran memtest86+ inside of the VM and there were no errors reported. I am almost certain this is either a VT-x issue or hard drive controller problem.

All the errors I get could have been caused by the VT-x feature or the hard drive controller. One time I got KERNEL_STACK_INPAGE_ERROR and other times I just get messages saying a file is corrupt and the Windows installation has to stop.

I have tried with and without nested paging, PAE/NX, 1 cpus, 2 cpus, video memory adjustments, 2d/3d acceleration, Host I/O caching on the cd (booting from an ISO) and hard drive, on an ext4 mdRAID5 and xfs non-raid partition. A SCSI controller. A PIIX4. An ICH6. Nothing fixes it. I obviously haven't tried all permutations of those, but I've tried a lot of things. I tried increasing the RAM from 1024MB to 1536, doesn't fix it. There is nothing in any log that I've seen. The bug is deep down in there somewhere.

Why would this be a 64-bit issue? My Windows 7 32-bit guest doesn't have a single error.

I've run Windows 7 64-bit guests under VIrtualBox before with no issues (on older Ubuntu hosts, on "Sun VirtualBox" before the Oracle switchover). I did update my BIOS since then, but honestly, I doubt it's this, anyway. My motherboard has been rock solid and every problem I've ever had was a software one.

Each time I'm allocating a 40 GB disk dynamically on either ext4(thru MDRAID) or xfs. I then tried allocating a 20 GB fixed disk on my xfs partition, and that also failed.

I did not try the patch posted here because I statically allocated my disk and it still happened.

Every time I am reading an ISO from disk. I am going to try and burn the ISO and use my actual CD drive.

If you want any sort of background on any component in my computer, let me know, but I posted what I felt was pertinent here.

I also posted at this forum thread:  http://forums.virtualbox.org/viewtopic.php?f=7&t=31192&p=142493#p142493

Thank you for your time.

Attachments

Screenshot.png Download (203.6 KB) - added by xtknight 4 years ago.
just one of the many random errors i may get when i attempt to install windows
win7x64logsconf.tar.gz Download (44.5 KB) - added by xtknight 4 years ago.
vbox logs of several windows installation attempts with different configurations, and also the xml configuration when the specific error in the screenshot occurred
system_info Download (79.3 KB) - added by xtknight 4 years ago.
almost everything about my system

Change History

Changed 4 years ago by xtknight

just one of the many random errors i may get when i attempt to install windows

Changed 4 years ago by xtknight

vbox logs of several windows installation attempts with different configurations, and also the xml configuration when the specific error in the screenshot occurred

comment:1 Changed 4 years ago by xtknight

SMART passes on all my hard disks.

I ran the following commands in this order and attached them as a log file.

sudo lsb_release -a uname -a free -m lsmod sudo lspci -vvv cat /proc/cpuinfo sudo lshw -sanitize sudo sensors sudo fdisk -lu sudo sfdisk -g sudo mount sudo df -h cat /proc/mdstat

I was installing onto /home(ext4 MDRAID5) and also /vm(xfs).

Changed 4 years ago by xtknight

almost everything about my system

comment:2 Changed 4 years ago by xtknight

Nope, I burned the iso to a CDROM and I still had the issue. BTW I tried running from two different Win7 x64 ISOs too.

comment:3 Changed 4 years ago by xtknight

In a strange twist I think both ISOs are corrupt. VMware fails too. Huh? :| Someone can close it if they want, it's obviously not VirtualBox, but something else is going on.

comment:4 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use