VirtualBox

Ticket #6970 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

USB dialogs non-functional in 3.2.4 -> duplicate of #6983

Reported by: jpadamson Owned by:
Priority: critical Component: USB
Version: VirtualBox 3.2.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

USB Devices dialog box first appears with incorrect listing, then disappears when mouse moves into box, and will not appear again. End result is that I cannot connect to USB devices within the Guest. Device appears just fine in the host.

Only began occurring after update to Oracle VirtualBox 3.2.4, 3.2.2 was fine.

(Virtual Machine status never gets updated in VirtualBox, either. After vm shuts down, status still shows as "running" unless I close VirtualBox and restart it.)

Attachments

WinXP1_1-2010-06-11-11-29-09.log Download (88.3 KB) - added by jpadamson 4 years ago.
Log file?
Hardy_XP-guest_2010-07-07T07.15.56.629030000Z.log Download (64.6 KB) - added by skv 4 years ago.

Change History

Changed 4 years ago by jpadamson

Log file?

comment:1 Changed 4 years ago by frank

Unfortunately I have no idea as we didn't change any related code between 3.2.2 and 3.2.4.

comment:2 Changed 4 years ago by CarnivorouZ

I am getting the same errors as above while running 3.2.4 in Ubuntu Jaunty i386. The USB devices that used to show up with their correct names now appear as Unknown Devices and give the following errors when I try to attach them: Failed to attach the hard disk (/media/disk/Virtual Machines/Vista 32 Bit Virtual.vdi) to slot IDE Primary Master of the machine .

Failed to attach the hard disk (--) to slot Floppy Device 0 of the machine . Callee RC: With details: NS_ERROR_FAILURE (0x80004005)

comment:3 Changed 4 years ago by jpadamson

Frank,

I generally update VirtualBox within a few days of an update notice, so I'm reasonably certain I was running 3.2.2 prior to the 3.2.4 update, but I did have to roll back all the way to 3.1.4 to get USB working again after the 3.2.4 update. Rolling back one version didn't help.

Hope this gets found and fixed soon! (Also wish I could get VirtualBox to stop nagging me to update to 3.2.4, given that it doesn't work for me)

John

comment:4 Changed 4 years ago by frank

The version notifier is only a minor issue. Just have a look at the global settings.

comment:5 Changed 4 years ago by hhedberg

I have the same issues, RHEL 5.4 Host with Windows 7 64bit guest. Reverted to 3.1.8 to resolve issue.

comment:6 Changed 4 years ago by dkopelove

I have the issue as well, Ubuntu 9.04 64-bit host with Windows XP 32-bit guest. I'm going to try reverting to 3.1.8 first to see if that fixes the issue.

comment:7 Changed 4 years ago by jpadamson

Not fixed in 3.2.6, I'm afraid. Exact same behavior. Back to 3.1.4.

Oh, well, I think I like the Sun logo better anyway. ;)

John

Changed 4 years ago by skv

comment:8 Changed 4 years ago by skv

I'm having similar problems on Ubuntu Hardy, running an XP host. USB devices worked in 3.2.2, but in 3.2.4 and 3.2.6 the USB menu shows 'Unknown' devices at first menu activation; but here after the menu will never show again. NS_ERROR_FAILURE (0x80004005) events are generated in the log while attempting to access the USB menu's.

comment:9 Changed 4 years ago by michael

Anyone having these issues might see if these testbuilds (disclaimer here) from the stable branch fix them:

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-07-21-16-31-32-lin32-3.2-3.2.7-r63866.run (32 bit version)

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-07-21-16-37-12-lin64-3.2-3.2.7-r63867.run (64 bit version)

comment:10 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem persists with VBox 3.2.8.

comment:11 Changed 4 years ago by The Law

  • Status changed from closed to reopened
  • Resolution fixed deleted

Running 3.2.8 / Hardy Heron Host / WinXP VM - I am seeing the same issue.

Right Click VM / Settings / USB / Add Filter. I see Hard Drive, Microsoft Device (keyb) and unknown devices for USB drives.

When going back into look again, there are no devices. Right clicking on VM shows all options greyed out besides "show log"

When the VM is powered on, I click the USB icon and note the devices. Clicking on them subsequently disables icons. Restarting VM and trying again, I hover over the USB icon and receive "no devices attached". Clicking on an "unknown device" I receive the following:

Failed to attch the USB device Unknown device to the virtual machine. Argument ald is invalid (must be Guid(ald).isEmpty() == false).

Details: Callee RC: NS_ERROR_FAILURE (0x80004005)

comment:12 Changed 3 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to duplicate
  • Summary changed from USB dialogs non-functional in 3.2.4 to USB dialogs non-functional in 3.2.4 -> duplicate of #6983

I will mark this ticket a duplicate of #6983, as the issue is handled there. The original fix was indeed a partial one which only worked with some setups. I believe we have now fixed the remaining cases.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use