VirtualBox

Ticket #6967 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

CentOS 4.6 VM's with LSILogic disks fail to halt properly under VB 3.2.4

Reported by: UglyPercy Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.2.4 Keywords: LSILogic
Cc: aeichner Guest type: Linux
Host type: Linux

Description

Problem occurs if I boot a CentOS 4.6 VM that uses a VMDK disk under the LSILogic controller -- this same VM halted fine in VB 3.2.0, so this seems to be a regression.

Have not been able to capture beginning of the failure messages, but they begin with "Syncing SCSI data to disk"; failure messages are then issued in an endless loop (screen shot will be attached). Guest is CentOS 4.6, host is a CentOS 4.2 variant.

Attachments

rnSjt.png Download (63.8 KB) - added by UglyPercy 4 years ago.
run-buslogic Download (6.5 KB) - added by UglyPercy 4 years ago.
Serial console output for SCSI BusLogic adapter
run-lsilogic Download (33.6 KB) - added by UglyPercy 4 years ago.
Serial console output for SCSI LSILogic adapter
run-ide-piix3 Download (7.1 KB) - added by UglyPercy 4 years ago.
Serial console output for IDE PIIX3 adapter
run-ide-ich6 Download (7.1 KB) - added by UglyPercy 4 years ago.
Serial console output for IDE ICH6 adapter
run-sata-ahci Download (6.1 KB) - added by UglyPercy 4 years ago.
Serial console output for SATA AHCI adapter

Change History

Changed 4 years ago by UglyPercy

comment:1 Changed 4 years ago by michaln

Redirect the guest's console to serial port ('console=ttyS0', instead of or in addition to 'console=tty0') and tell VirtualBox to save the serial port output to a file. That way you'll easily capture panic messages etc. from the guest.

comment:2 Changed 4 years ago by michaln

See also the new entry at  http://www.virtualbox.org/wiki/Serial_redirect for details.

comment:3 Changed 4 years ago by UglyPercy

Thanks -- I'll try that later today. But I believe "aeichner" was trying to replicate the CentOS 4.6 LSILogic halting problem. Is there any chance for a fix or workaround soon?

comment:4 Changed 4 years ago by aeichner

I can reproduce the problem but don't have an idea at the moment.

comment:5 Changed 4 years ago by UglyPercy

That is excellent news -- thanks for the update. For the record, this problem is critical to me, since it makes difficult for me to demonstrate successful operation of VB with my company's existing CentOS 4.6 VM's. Of course, my priorities are not automatically yours; still I am hoping to hear good news soon :-)

comment:6 Changed 4 years ago by frank

Well, the CentOS 4 guest should be able to run with a configured SATA controller as well...

comment:7 Changed 4 years ago by UglyPercy

Unfortunately, I am not at liberty to change the controller type in my application -- I'm prototyping the use of VB in an embedded hypervisor system to support our customer's existing VM's. Basically, I need VB to work well for a wide variety of new and old OS's, and CentOS 4 happens to be our official standard guest type....

comment:8 Changed 4 years ago by frank

That's not what I mean. Every Linux distribution has normally drivers for many hardware included so it wouldn't probably matter if you would change the VM setting and let VirtualBox emulate a SATA controller rather than an LsiLogic SCSI controller. I assume that the guest would still work.

comment:9 Changed 4 years ago by UglyPercy

You mean *just* changing the virtual controller type in VB? I'm afraid I've never had much luck doing anything but LSILogic with these CentOS 4 VM's. I just tried again, and every controller failed.

Specifically, in addition to SCSI LSILogic crashed, BusLogic panics. All three IDE controllers hang after "System halted." for at least a few minutes (perhaps forever). The virtual SATA controller looks as if it just did not exist in CentOS 4.6. I will attach logs for your reference.

Changed 4 years ago by UglyPercy

Serial console output for SCSI BusLogic adapter

Changed 4 years ago by UglyPercy

Serial console output for SCSI LSILogic adapter

Changed 4 years ago by UglyPercy

Serial console output for IDE PIIX3 adapter

Changed 4 years ago by UglyPercy

Serial console output for IDE ICH6 adapter

Changed 4 years ago by UglyPercy

Serial console output for SATA AHCI adapter

comment:10 Changed 4 years ago by aeichner

You have to add "ide2=noprobe ide3=noprobe" in grub to make it work. (see #6293)

comment:11 Changed 4 years ago by UglyPercy

That is very good to know, aeichner -- thanks.

But I made one mistake: when I tried to use the IDE Controllers PIIX3 and PIIX4, each appeared to freeze on shutdown right after the "System halted", such that the VM window hung seemingly forever. But I believe this is just a side-effect of my environment: I run VB at work, and connect over VPN from home to view the GUI/VM's via X11. Unfortunately, the default VB VGA refresh rate is so high (50 FPS) and the amount of data to be transmitted so great, that it takes a couple of minutes for the X11 data to be received (even over a cable modem), during which time the window is frozen. But I have changed the refresh rate to 1 FPS, and now it is obvious that the IDE controller (at least PIIX4) works with my CentOS 4.6 VM.

So, while this bug is still open, it is less critical to me than before, thanks.

comment:12 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Seems obsolete to me.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use