VirtualBox

Ticket #6964 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

BSOD 0x3B on Windows 7 x64 host after resume page fusion enabled VM from saved state -> fixed in SVN

Reported by: jo2k Owned by:
Component: guest smp Version: VirtualBox 3.2.4
Keywords: BSOD 3B Cc:
Guest type: Windows Host type: Windows

Description (last modified by frank) (diff)

Windows XP 32bit guest with 3.2.4 guest additions and page fusion enabled let crash the Windows 7 x64 host with BSOD 0x3B SYSTEM_SERVICE_EXCEPTION (file VMMR0.r0) after resume from saved state. This behavior is reproducible in my setup. No other VM was active.

Steps to reproduce:

  1. boot page fusion enabled Windows XP x86 VM on Windows 7 x64 host
  2. save virtual machine state
  3. resume from this state
  4. "enjoy" BSOD 0x3B on the host

VBox.log is defect (many 0x00 bytes only in log after the crash).

If I disable page fusion for the VM, everything is fine.

Attachments

061010-18844-01.dmp Download (279.8 KB) - added by jo2k 11 years ago.
Requested minidump from BSOD
VBox - page fusion disabled.log Download (72.1 KB) - added by jo2k 11 years ago.
VBox - page fusion enabled.log Download (52.9 KB) - added by jo2k 11 years ago.
061510-18096-01.dmp Download (280.0 KB) - added by jo2k 11 years ago.

Change History

comment:1 Changed 11 years ago by frank

  • Description modified (diff)

comment:2 Changed 11 years ago by sandervl73

Unable to reproduce. Could you attach a minidump? (see  http://www.virtualbox.org/wiki/Core_dump at the bottom for instructions)

Changed 11 years ago by jo2k

Requested minidump from BSOD

comment:3 Changed 11 years ago by frank

Minidump attached.

comment:4 Changed 11 years ago by sandervl73

Attach the VBox.log of the session please (just start, but don't let it crash).

Changed 11 years ago by jo2k

Changed 11 years ago by jo2k

comment:5 Changed 11 years ago by jo2k

Some seconds after booting the VM with page fusion enabled, the host crashed with BSOD 0x3B. Log is OK this time. :)

Changed 11 years ago by jo2k

comment:6 Changed 11 years ago by sandervl73

  • Summary changed from BSOD 0x3B on Windows 7 x64 host after resume page fusion enabled VM from saved state to BSOD 0x3B on Windows 7 x64 host after resume page fusion enabled VM from saved state -> fixed in SVN

Thanks, I've found the problem. A fix will be included in the next maintenance release. If you're interested, then I can point you to a test build.

comment:7 Changed 11 years ago by sandervl73

  • Component changed from VMM to guest smp

comment:8 Changed 11 years ago by jo2k

Nice. Yes, I would like to try the test build on my machine.

comment:10 Changed 11 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:11 Changed 11 years ago by jo2k

With this test build the guest crashes with BSOD 0x8E after installing the 3.2.5 guest additions. I'll test again with the final version. :-)

Thanks for support.

comment:12 Changed 11 years ago by sandervl73

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:13 Changed 11 years ago by sandervl73

Not entirely fixed according to #7087

comment:14 Changed 11 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Hopefully finally fixed in VBox 3.2.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use