VirtualBox

Ticket #6963 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

The host CD/DVD drive tray ejects when mounting an image while the VM is running

Reported by: Phyds Owned by:
Priority: minor Component: DVD
Version: VirtualBox 3.2.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

By default, the VM virtual CD/DVD drive is setup to use the host CD/DVD drive. The host CD/DVD drive tray ejects when I mount an image on the virtual CD/DVD drive while the VM is running. This is very annoying for those who have a desktop with a door to hide the drives and always keep the door closed. When the tray ejects and the door is closed, I'm afraid that it could damage the tray ejection mechanism. Here's the steps to reproduce the bug:

  1. Install any Windows as a guest VM.
  2. After complete installation, shut down the Windows guest VM.
  3. Remove any disc from the host CD/DVD drive.
  4. Go in the Windows guest VM Settings, Storage section, and make sure you have an IDE Controller with a virtual CD/DVD device. In the Attributes, make sure this virtual CD/DVD device is linked to the host CD/DVD drive. Click OK to save & exit the Settings.
  5. Go in File/Virtual Media Manager, CD/DVD Images tab, and add an image, for example VBoxGuestAdditions.iso. Click OK to save & exit the Virtual Media Manager.
  6. Start the Windows VM and wait until you see the desktop.
  7. Right-click on the CD icon on the bottom right of the VM window, and select the image you added earlier.
  8. Now the host CD/DVD drive tray should eject automatically with nothing in it.

Attachments

VBox.log Download (79.8 KB) - added by Phyds 4 years ago.

Change History

Changed 4 years ago by Phyds

comment:1 Changed 4 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #5825

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use