VirtualBox

Ticket #6944 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

Seamless Mode Fails with High Display Resolution (2560 x 1600) on Host and Ubuntu Guest

Reported by: demonGeek Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 3.2.4 Keywords: ubuntu high resolution windows 7
Cc: Guest type: Linux
Host type: Windows

Description

Host: Windows 7 x64
Guest: Ubuntu x32 9.10/10.04 with latest guest additions installed
Host display resolution: 2560 x 1600

Switching to seamless mode on an Ubuntu guest causes display problems. In the attached screenshot you can see the Windows desktop (blue) and the Ubuntu desktop (black) with an instance of Firefox running in Ubuntu and the VirtualBox console running in Windows. Notice that the Firefox window overlaps into the Windows desktop but the window border is missing on the portion that overlaps the Windows desktop. The Ubuntu desktop is truncated to about the top third of the screen but windows contained on it are still visible below that.

Notes:

  1. Seamless mode with a Win2K3 guest works properly which seems to indicate that the issue may be related to the Linux x32 Guest Additions. The guest OS is a factor.
  1. Tested with the host display resolution at a lower setting and seamless mode with the Ubuntu guest works properly. The host display resolution is a factor.
  1. Tested with a second monitor connected and without - results are the same. The second monitor is not a factor.
  1. Tested with the Windows Taskbar at the top and bottom of the screen - results are the same. The location of the Windows Taskbar is not a factor.

Attachments

6944.png Download (332.6 KB) - added by demonGeek 4 years ago.
VBox.log Download (56.2 KB) - added by demonGeek 4 years ago.
VirtualBox Log File
viewwindows.cpp Download (3.9 KB) - added by michael 4 years ago.
Window location display utility, source code
viewwindows.tar.gz Download (11.9 KB) - added by michael 4 years ago.
Window location display utility, 32bit and 64bit Intel binaries
viewwindows.log Download (2.6 KB) - added by demonGeek 4 years ago.
ubuntu-screenshot1.png Download (242.6 KB) - added by demonGeek 4 years ago.
Ubuntu 10.04 Default Install Screenshot
Normal.jpg Download (259.3 KB) - added by frm 4 years ago.
Desktop before activating seamless.
Seamless.jpg Download (209.8 KB) - added by frm 4 years ago.
Desktop with seamless activated.

Change History

Changed 4 years ago by demonGeek

comment:1 Changed 4 years ago by demonGeek

I forget to mention that the video hardware is a GeForce 8800GTS.

comment:2 Changed 4 years ago by frank

How many video memory did you assign to the guest? Please attach the VBox.log file to the ticket.

Changed 4 years ago by demonGeek

VirtualBox Log File

comment:3 Changed 4 years ago by demonGeek

Video Memory: 30MB 3D Acceleration: Enabled 2D Video Acceleration: Disabled

Log file attached.

comment:4 Changed 4 years ago by michael

Do you have Compiz enabled in the guest? If so, does disabling it make a difference?

comment:5 Changed 4 years ago by poetzsch

Or disabling 3D in the VirtualBox configuration of the guest?

comment:6 Changed 4 years ago by demonGeek

I'm not using Compiz.

Disabling 3D makes no difference.

comment:7 Changed 4 years ago by michael

I am attaching a small application (source and 32bit and 64bit binaries, based on the seamless Additions code) that prints out information about the X11 window layout as the seamless Guest Additions see it. It would be great if you could run it inside the guest to give me an idea of what the Additions think the layout actually is.

Changed 4 years ago by michael

Window location display utility, source code

Changed 4 years ago by michael

Window location display utility, 32bit and 64bit Intel binaries

comment:8 Changed 4 years ago by demonGeek

Results are attached (viewwindows.log). I tested it twice, once with the guest window just maximized (which works fine) and then again with seamless mode enabled.

Changed 4 years ago by demonGeek

comment:9 Changed 4 years ago by michael

Looks to me like the block of visible guest desktop at the top is "Docky", which the utility thinks stretches from (0, 0) (upper left) to (2560, 157) (lower right). If you run "xwininfo" in the guest (in seamless mode) and click in that black rectangle, does it also think so?

comment:10 Changed 4 years ago by michael

And are you using Metacity as a window manager or something else?

comment:11 Changed 4 years ago by demonGeek

No, the black rectangle is identified as 'x-nautilus-desktop' which stretches from (0,0) to (2560,1560) which would correctly equate to the entire screen less the height of the Windows taskbar.

I also tested with a different VM running Ubuntu 9.10 without Docky and seamless mode is still broken. So Docky doesn't seem to be a factor.

Yes, I'm using Metacity.

comment:12 Changed 4 years ago by michael

You might try  this updated version of VBoxClient (obgligatory disclaimer here).

I must admit that I am rather puzzled. The output from the test utility that you posted here looked much more like what I would expect from Compiz than from Metacity. The current version of VBoxClient does not work with Compiz. Although there are other reasons why Compiz in the guest and seamless can't be used together, the test version of VBoxClient should now work with it somwhat better (possibly with artifacts in non-rectangular bits of window decorations). I am interested to see whether it also helps with your issue.

comment:13 Changed 4 years ago by michael

Did you get a chance to try the updated VBoxClient daemon?

comment:14 Changed 4 years ago by demonGeek

Sorry, no luck, it still looks the same. Tested with both Ubuntu 10.04 and 9.10.

For comparison I also tested with Linux Mint 8 - using Compiz - and although a lot better than the Ubuntu client with Metacity, it wasn't quite right: dragging windows was slow and showed redraw problems and no desktop icons were visible.

comment:15 Changed 4 years ago by michael

I'm interested that it did more or less work with Compiz on Mint. I will have to give that a try myself.

If you have enough time available I might ask you to try something else to help track down the problem. Could you do an absolutely default install of Ubuntu 9.10 or 10.04 into a VM and install the Additions? (Everything you need to install the Additions should be in the default install without even needing to update the installed software from the Ubuntu repositories.) If you see these issues with a default install I will have to think of something else, otherwise you could do some experiments to try to find what the difference between the two VMs is that is causing this.

comment:16 Changed 4 years ago by michael

I will also try to find someone here with a display of that size who can test this.

comment:17 Changed 4 years ago by demonGeek

I did a default install of Ubuntu 10.04 plus the guest additions - no other changes, updates or anything.

The result still shows problems which are similar but not exactly the same as I'm getting with my other 10.04 install (with Docky etc.). The screenshot shows that the black rectangle has vanished but the Ubuntu windows are missing their title bars and frames. The Terminal window is interesting since it shows part of the title bar and window frame where it overlaps the Firefox instance that's also running in Ubuntu.

For the sake of clarity, I'd suggest that we should continue testing with the default Ubuntu 10.04 install and leave my modified version alone for now so that we can be sure that Docky and my other changes aren't a contributing factor. If we can make progress with the default Ubuntu install, I'll go back and try again with the modified version.

Changed 4 years ago by demonGeek

Ubuntu 10.04 Default Install Screenshot

comment:18 Changed 4 years ago by demonGeek

Any updates on this issue?

Changed 4 years ago by frm

Desktop before activating seamless.

Changed 4 years ago by frm

Desktop with seamless activated.

comment:19 Changed 4 years ago by frm

I'm having the same issue, see the two screenshots for comparison. Those are with Docky and compiz activated. As demonGeek noted, disabling those and using metacity makes no difference.

comment:20 Changed 4 years ago by frm

My bad, I just updated to the most recent version using the Ubuntu ppa, updated the host extensions (this time without D3D support) and it works fine.

comment:21 Changed 4 years ago by demonGeek

Not sure why I'm bothering to update this since it seems there's no real interest but, for the record, I just installed 3.2.10 (including updating the guest additions) and seamless mode is now almost working.

I say almost because the window redraw is not quite right - moving a guest window on the desktop causes the window to flicker constantly while in motion. Everything else appears to be fine except for the redraw.

comment:22 Changed 4 years ago by michael

demonGeek: it's not that it doesn't interest us - but take a look at the number of open entries in the bug tracker and you may understand why we can't always give each the attention it deserves. The flicker is expected, it is an unfortunate effect of the way we currently implement seamless (a new implementation is due sometime, but I can't even estimate when it will be started). As for the other problems, I am rather intrigued, since I can't see any changes to the guest code since VirtualBox 3.2 was first released (perhaps there was a host-side change), but I am glad that it is now working for you.

comment:23 Changed 4 years ago by demonGeek

Thanks for the response Michael. I do understand that you're busy and have other priorities which is why I haven't really worried too much about this but from my perspective it looked like you'd just lost interest 4 months ago while we were in the middle of running some testing scenarios.

The issue was never assigned to anyone and, to me, appeared forgotten. I pinged the thread again in August just to see if anything was happening but got no response from that either. A simple 'we're working on it' would have gone a long way.

As far as the problem is concerned I might be able to shed some light on it. Looking back at changes to my system, I see that I had to update my nVidia drivers when I installed Adobe CS5 a couple of weeks ago. I went from the drivers supplied by Windows Update to using the nVidia drivers downloaded from their website (v3.3.532.01) which were released 19-Jul-2010. Whether or not that is a factor, I can't say for sure but, given that the guest code hasn't changed, it's certainly an interesting coincidence.

Since the flicker is already a known issue, I think we can call this one resolved and close the ticket. Thanks for you help.

comment:24 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for the feedback and sorry for the patchy response. The usual reason is that I put off answering immediately and then something else pushes it out of my mind again... anyway, glad that this is working now.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use