Ticket #6905 (reopened defect)

Opened 6 years ago

Last modified 2 years ago

Can't spawn some VMs with a SATA HDD controller when the VDI file is on a btrfs partition => fixed in SVN

Reported by: rocko Owned by:
Priority: minor Component: virtual disk
Version: VirtualBox 3.2.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

VirtualBox can't spawn some VMs if both these conditions are true:

  • the HDD storage controller is set to SATA, and
  • the VDI file is on a btrfs partition.

VBox shows a window saying "Spawning..." and later another box appears saying "Spawning (20%)... 2/2". Neither box ever disappears (their processes must be killed).

An example error in the log is:

00:00:00.733 AioMgr0-N: Request 0x000000018b0df0 failed with rc=VERR_INVALID_PARAMETER, migrating endpoint /vbox/maverick32-2.vdi to failsafe manager.

Note however that some VDI files do load successfully from the btrfs partition using the SATA controller.

Workaround are:

  • Moving the VDI file to an ext4 partition fixes the problem.
  • Changing the storage type for the HDD to IDE instead of SATA also fixes the problem (ie even if the VDI file is on the btrfs partition).

Version info:

VirtualBox: 3.2.2-62298~Ubuntu~lucid Host: Ubuntu 10.04, kernel 2.6.34-generic or 2.6.35-rc1-generic


VBox.log Download (41.5 KB) - added by rocko 6 years ago.
VBox.log file

Change History

Changed 6 years ago by rocko

VBox.log file

comment:1 Changed 6 years ago by Longinus00

This happens if "use host I/O cache" is disabled. It is disabled on default for the sata controller but disabled by default for the ide controller. This explains the confusion in the original bug report.

comment:2 Changed 6 years ago by Longinus00

I mean, of course, to say that it is enabled by default for the ide controller.

comment:3 Changed 6 years ago by rocko

OK, I can confirm that's correct. So the conditions to reproduce this are:

(a) the VDI file on btrfs partition, and (b) use host I/O controller is not set

Is this bug already reported elsewhere?

comment:4 Changed 6 years ago by frank

  • Description modified (diff)

comment:5 Changed 6 years ago by aeichner

  • Summary changed from Can't spawn some VMs with a SATA HDD controller when the VDI file is on a btrfs partition to Can't spawn some VMs with a SATA HDD controller when the VDI file is on a btrfs partition => fixed in SVN

Will be fixed in the next maintenance release. Thanks for the report!

comment:6 Changed 6 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed

comment:7 Changed 3 years ago by frumble

  • Status changed from closed to reopened
  • Resolution fixed deleted

I can confirm this bug on VirtualBox 4.2.6 with Windows 8 guest on a btrfs partiton on Linux 3.7.6. Moving the VDI to an Ext4 partition "solves" the problem.

comment:8 Changed 3 years ago by dremon

I have the same problem with VirtualBox 4.2.6 (and beta 4.2.7) with VM guests located on btrfs filesystem. Tested on Ubuntu 13.04 AMD64 with kernel 3.8.0.

Enabling I/O host cache for SATA controller seems to help.

comment:9 Changed 3 years ago by nahuel

This happens also using kernel 3.11-1-amd64 on Debian with VirtualBox 4.2.16_Debian, also using a .VDI disk on a SATA/btrfs disk. Enabling "Host I/O cache" seems to solve it.

comment:10 Changed 2 years ago by 3vi1J

I ran into symptoms I think are related to this ticket last weekend; I have also seen some issues when using BTRFS partitions with some VDIs - with the current (4.3.12) version of VirtualBox. I'm adding my observations here in case it will help the devs:

On my Ubuntu Utopic host (3.16 kernel), I have several VDI images (Debian, Windows, etc.) on a BTRFS partition (using lzo compress) that have been working work fine for a long time. However, when I tried to use a Fedora 17 image I acquired for a class, I noticed continual corruption issues.

I eventually tried building a Fedora 20 guest from scratch, and to my surprise it would suffer the same corruption issues after installing and cleanly rebooting only once or twice. This is 100% re-creatable. I did clean builds of Fedora 20 three times. Building the same machine with the image on an Ext4 partition showed no problem whatsoever.

I ended up using the same workarounds as mentioned in this post: Set the SATA controller to use the Host I/O, and the problems magically go away. I am still completely puzzled as to why this affects my Fedora VMs, and not my Debian or Arch machines... perhaps it has something to do with creating those VDIs before I enabled BTRFS compression.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use