VirtualBox

Ticket #6877 (closed defect: fixed)

Opened 4 years ago

Last modified 16 months ago

Broken if cancel creation snapshot => fixed in SVN

Reported by: gerasev Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

If cancel creation snapshot, then the configuration will remain in the record about the snapshot and virtual machine is broken.

Change History

comment:1 in reply to: ↑ description Changed 4 years ago by vcoder

Replying to gerasev:

If cancel creation snapshot, then the configuration will remain in the record about the snapshot and virtual machine is broken.

I can confirm this bug also exists in VBox 3.2.8, but with a Linux guest under a Windows7 host and the Linux guest is accessed as a VMDK.

A clearer summary of how to reproduce the bug:

  1. Start VBox and the guest.
  1. Start taking a snapshot.
  1. Hit the Cancel button on the dialog before the snapshot has finished being created.
  1. Restart VBox and try to start the guest.
  1. The guest will not start, failing with a fatal error: "{hard disk} cannot be directly attached to the virtual machine because it has 1 differencing child hard disks"

Possibly there is a way to recover VBox after this bug occurs, but I do not know how to do it and I did read the manual completely, especially the sections on VBoxManage and VMDKs.

comment:2 Changed 4 years ago by klaus

I suspect that "fixing" the problem is quite easy: simply delete the (unattached!) differencing disk under the specified hard disk using the Virtual Media Manager. Untested, so create a backup before trying.

comment:3 Changed 4 years ago by vcoder

Thank you very much Klaus and MichalN too.

Summary:

  1. In the GUI, remove the existing guest VM,
  2. Create a new guest VM (click the New button),
  3. Use the wizard to set up the new VM (be careful, you should probably select Use existing image VMDK if VBox was accessing the guest via VMDK / raw partition),
  4. Change the Settings (it can be found under the Machine menu) per your requirements,
  5. Quit VBox,
  6. Restart VBox,
  7. Run the guest VM.

Do not do anything to VBox on the command-line; especially, do not edit the VBox XML files by hand and do not use VBoxManage. That's all!

comment:4 Changed 3 years ago by steffen123

Bug still occurs in VirtualBox 4.0.4. This was on a Gentoo Linux host with a Win7 guest, and whilst I didnt cancel the snapshotting, it auto-cancelled it due to lack of diskspace. Will following the workaround listed in the last commend by vcoder destroy the snapshots of the VM?

comment:5 Changed 17 months ago by klaus

  • Summary changed from Broken if cancel creation snapshot to Broken if cancel creation snapshot => fixed in SVN

After lots of debugging we could finally find the cause of this problem. A nasty issue which was very very hard to find.

comment:6 Changed 16 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is included in VBox 4.2.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use