VirtualBox

Ticket #683 (closed defect: duplicate)

Opened 7 years ago

Last modified 4 years ago

VirtualBox is always aborting

Reported by: kimus Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

VirtualBox is always aborting after a random period of use.

System
Ubuntu 7.10 (Gutsy Gibbon)
Linux netjer 2.6.22-11-generic #1 SMP Fri Sep 7 05:07:05 GMT 2007 i686 GNU/Linux

VirtualBox Virtual Machine
Name: Windows XP Professional SP2 OS Type: Windows XP
Base Memory: 512 MB
Video Memory: 16 MB
Boot Order: CD/DVD-ROM, Hard Disk
ACPI: Enabled
IO APIC: Disabled

Hard Disks:

Primary Master: lvm-sys-winxpdev.vmdk [Writethrough, 10.00 GB]
Primary Slave: lvm-sys-devdisk.vmdk [Writethrough, 10.00 GB]

CD/DVD-ROM: Not mounted
Floppy: Not mounted
Audio: Disabled
Network: Adapter 0 (NAT)
Serial Ports: Disabled
USB: Disabled
Shared Folders: 1
Remote Display: Disabled

Change History

comment:1 Changed 7 years ago by frank

What means 'aborting'? Crash or hang? Please try to boot your Linux host kernel with the kernel parameter 'nohz?off'.

comment:2 Changed 7 years ago by kimus

it 'crashes' (just closes) and the status of the VM is 'Aborted'!

comment:3 Changed 7 years ago by dmpayton

Hello,

I can confirm this: the VM windows abruptly closes, and the status is 'Aborted'

My host OS is Ubuntu 7.04, and I'm running Windows XP in the VM. I notice that this ticket hasn't been updated in almost a month, and it's been really bothersome (I need Photoshop for work, and dual-booting is a major PITA). Anything I can do to help?

--D.

comment:4 Changed 7 years ago by frank

dmpayton: Do you have different VM settings? Do you use a .vmdk as well? Please could you both guys attach the corresponding log file (Main Menu => Machine => Show Log ...)?

comment:5 Changed 7 years ago by dmpayton

Frank,

There were 4 logs that showed up. You can view them here:  http://www.dmpayton.com/vbox_logs/

Here's my VBox setup:

Name: DMP-WINXP OS Type: Windows XP Base Memory: 768 MB Video Memory: 64 MB Boot Order: Floppy, CD/DVD-ROM, Hard Disk ACPI: Enabled IO APIC: Disabled Hard Disks: Primary Master DMP-WINXP.vdi [Normal, 15.00 GB] Floppy: Not mounted CD/DVD-ROM: Not mounted Audio: Disabled Network: Adapter 0 NAT USB Controller: Disabled Remote Display: Disabled

Hope that helps.

--D.

comment:6 Changed 7 years ago by frank

dmpayton: Thanks for the info. Unfortunately, the log files do not contain any interesting information, the VM just aborted. Could you enable core dumps? Do

ulimit -c unlimited
VirtualBox

and then start your VM. The next time it crahes there should be a core dump. If so, please attach the file(s) after compression to this report or make it accessible to me at your website.

Please try if the problem also occurs if you start your VM with

VBoxSDL -vm <vm name>

comment:7 Changed 7 years ago by dmpayton

Next time it crashes, I'll grab a core dump for you. It shouldn't be too long before it does so, as I'm currently working on a mockup for a client in Photoshop, and that's when it likes to crash the most. :)

One other thing I just noticed... when I start VirtualBox from the command line, I get this:

derek@dmp-nix:~$ VirtualBox
Qt WARNING: X Error: BadDevice, invalid or uninitialized input device 169

Major opcode: 147
Minor opcode: 3
Resource id: 0x0

Qt WARNING: Failed to open device
Qt WARNING: X Error: BadDevice, invalid or uninitialized input device 169

Major opcode: 147
Minor opcode: 3
Resource id: 0x0

Qt WARNING: Failed to open device

Then the VBox windows appears as normal. Does that tell you anything?

--D.

comment:8 Changed 7 years ago by frank

No idea so far...

comment:9 Changed 7 years ago by michael

For the record, those Qt warnings appear when starting any Qt application from the command line in Ubuntu as far as I can see.

comment:10 Changed 7 years ago by michael

This ticket is likely a duplicate of #557.

comment:11 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate

Followups can go to that ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use