VirtualBox

Ticket #6820 (closed defect: fixed)

Opened 4 years ago

Last modified 3 months ago

Found no handler for unit 'QGLVHWAData0' instance #0!

Reported by: Gregoo Owned by:
Priority: minor Component: 3D support
Version: VirtualBox 3.2.0 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

Hello :) .

I've posted on the forums ( http://forums.virtualbox.org/viewtopic.php?f=6), but nobody seems to know about it. Bugtracker search didn't give any result.

I'm assuming it hasn't been reported yet. Sorry if it's not the case o: .

Sometimes when I was resuming a saved machine, the GUI was silently crashing on VirtualBox 3.1 series (I don't know for 3.0 and earlier). After the crash the session was lost and the machine had to boot again from scratch. The crashes appear randomly I guess.

I think I had that bug only while powering the machine via Remote Desktop (not sure if it's related though). It crashed on Windows XP Professional x64, and it continued crashing on Windows 7 Professional x64.

Oh, the guest is a Windows Server 2003.

With the new VirtualBox 3.2, I had that message (Found no handler for unit 'QGLVHWAData0' instance #0! / VERR_SSM_INTEGRITY_UNIT_NOT_FOUND) when trying to resume a machine.

00:00:05.249 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={6375231a-c17c-464b-92cb-ae9e128d71c3} aComponent={Console} aText={Virtual machine is being powered down} aWarning=false, preserve=false
    00:00:05.264 Changing the VM state from 'DESTROYING' to 'TERMINATED'.
    00:00:05.479 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={6375231a-c17c-464b-92cb-ae9e128d71c3} aComponent={Console} aText={Found no handler for unit 'QGLVHWAData0' instance #0 (VERR_SSM_INTEGRITY_UNIT_NOT_FOUND)} aWarning=false, preserve=false
    00:00:05.506 Power up failed (vrc=VERR_SSM_INTEGRITY_UNIT_NOT_FOUND, rc=ERROR_SUCCESS (0X000000))

The machine didn't resume, but I didn't lose the saved state and no Windows message about the GUI crashing. When I tried to resume it a second time, the same message appeared and I received the Windows message telling me VirtualBox GUI had crashed.

No clue if it's the same error I had with VirtualBox 3.1 series.

There was those lines in the log o.o . Don't know if it's helpful though.

00:00:04.929 SSM: Found no handler for unit 'QGLVHWAData0' instance #0!
    00:00:04.929 VMSetError: E:\tinderbox\win-rel\src\VBox\VMM\SSM.cpp(7918) ssmR3LoadExecV2; rc=VERR_SSM_INTEGRITY_UNIT_NOT_FOUND
    00:00:04.935 VMSetError: Found no handler for unit 'QGLVHWAData0' instance #0

Anyways I've attached the log. No minidump sorry, I don't seem to have that feature enabled on my Windows 7.

Attachments

vbox.log Download (63.4 KB) - added by Gregoo 4 years ago.
Microsoft Windows Server 2003-2010-06-03-14-52-08.log Download (62.7 KB) - added by Gregoo 4 years ago.

Change History

Changed 4 years ago by Gregoo

comment:1 Changed 4 years ago by frank

  • Component changed from other to 3D support

This error is related to 2D support.

comment:2 Changed 4 years ago by misha

What VBox frontend are you using when trying to resume from the saved state? Is it VBoxHeadless or VirtualBox or whatever?

comment:3 Changed 4 years ago by Gregoo

I'm using the VirtualBox GUI :) .

When the machine crash, it's only the window for that machine crashing, the VirtualBox main window (with the machine list) and the other powered machines aren't affected :).

comment:4 Changed 4 years ago by Gregoo

It happened again today, when I resumed the machine via a Remote Desktop connection.

I didn't lose the session. So I logged to the machine (meaning without a remote connection) and tried to resume the machine again. It didn't crash this time.

So I guess it's Microsoft RDP causing that crash o: .

Changed 4 years ago by Gregoo

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

comment:6 Changed 3 years ago by matthew72

  • Status changed from closed to reopened
  • Resolution fixed deleted

sorry but it ain't fixed.
it just happened to me with 4.0.4 on ubuntu lucid and a windows xp guest, for no apparent reason.
vm additions installed without 3d support, 2d support enabled in the vm properties.
i've been using that vm since several months (i created it with vbox 3.x btw);
i didn't make any changes in the vm apart from mounting a cd image every now and then;
once i got a satisfying setup i created a live snapshot and always reverted to it at shutdown.
pretty much the very same thing everyday, i can't guess what could ever caused it.
btw, i never ever accessed it thru RDP (nor any other vbox vm for that matter).
i already tried to restart it several times with no luck.
any workaround? should i "discard" the saved state? disable 2d support?

comment:7 Changed 3 years ago by matthew72

ah, the forum link in the first message is incomplete, it should be  http://forums.virtualbox.org/viewtopic.php?f=6&t=31389

comment:8 Changed 3 years ago by matthew72

udpate: i discarded the saved state and restarted the vm, it booted without any problem.
at shutdown (initiated with hostkey + Q, not from the guest os) it offered to restore to the live snapshot (which i thought was lost).
started again, and this time it worked; interestingly, the saved state i previuosly discarded was still there.

maybe i realized the only thing i did differently today: for the first time i used the new "scale mode" with this vm.
since a previous comment states that "This error is related to 2D support" i guess it might be relevant.

comment:9 Changed 3 years ago by misha

The reason you're hitting this is because your snapshot is created with vbox < 4.0 and has a 2D data, while the 2D engine is disabled for some reason on snapshot restore. The work-around is to load the snapshot the 2D engine enabled (i.e. with the average VirtualBox frontend) and create a new snapshot with VBox >= 4.0.

comment:10 Changed 3 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

Most likely fixed in VBox 4.3.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use