VirtualBox

Ticket #6819 (closed defect: duplicate)

Opened 4 years ago

Last modified 2 years ago

virtualbox unable to allocate "handy pages" when lots of memory is available.

Reported by: vultaire Owned by:
Priority: minor Component: host support
Version: VirtualBox 3.2.0 Keywords: hostmemorylow handy
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

Greetings,

Sorry to be a bother. I work for oracle and use this as a tool for troubleshooting x86, oel, and other os issues. I am running a quad core phenom 955 am3 with 6 GB ddr3 memory(3x2). My host system is windows xp pro 64bit. When I run virtual box and the guests combined memory usage(not allocation) exceeds around 1 GB, I get a severity non-fatal error, with an error-id of HostMemoryLow. If I put 12 GB of ram in the system(2x4,2x2). I get the same error when the combined used memory in the guests exceeds a little over 3GB of ram. I have run memtest on the system multiple times. I can allocate the memory in vmware player and everything is happy. I love virtualbox - it works fine on my mac, but my mac doesn't have the horsepower of my desktop. This has been present since 3.1.4 at least. I have seen similar posts as well.

Any ideas?

Attachments

vbox_error_message.jpg Download (29.0 KB) - added by vultaire 4 years ago.
image of the error when vbox cannot find "handy pages"
VBox.log Download (45.3 KB) - added by vultaire 4 years ago.
log file up until system paused itself waiting for more "handy pages"
VMLog.txt Download (78.8 KB) - added by gwaddell 2 years ago.
VMLog as guest crashes out…

Change History

Changed 4 years ago by vultaire

image of the error when vbox cannot find "handy pages"

Changed 4 years ago by vultaire

log file up until system paused itself waiting for more "handy pages"

comment:1 Changed 4 years ago by vultaire

This is still present and keeping me from using virtualbox - I have seen posts with this similar issue for the past couple of years. It appears to be a bug that has gone unfixed and should be addressed. Any suggestions - I can use vmware player and it works fine, but that limits what I can do.

comment:2 Changed 4 years ago by frank

Please attach a VBox.log file from a VBox 3.2.6 session.

comment:3 follow-up: ↓ 4 Changed 4 years ago by sandervl73

It might be related to XP64. That version is only half-supported by Microsoft anyway. I have no issues whatsoever with Windows 7 x64 with 16 GB RAM.

comment:4 in reply to: ↑ 3 Changed 2 years ago by gwaddell

Replying to sandervl73:

It might be related to XP64. That version is only half-supported by Microsoft anyway. I have no issues whatsoever with Windows 7 x64 with 16 GB RAM.

I'm having same issue with Windows 7 Professional 64 bit, on 6GB RAM with virtualbox VirtualBox 4.1.8r75467

If I try and run any guest with over 1 GB RAM, I get the following error at "boot up"

Error ID: HostMemoryLow, Severity: Non-Fatal Error

The host machine then pauses and wont restart and I have to switch it off and take the RAM down to 1GB.

Also, if I'm running a 1GB Ram guest, and start another one to run concurrently, I get the same error on the second machine. Is there some sort of size limit set at 1GB Ram?

Host Details: windows 7 Professional 64 bit Service Pack 1, 6 GB Ram, Intel core i7-2620M CPU @ 2.7GHz Guest Details: windows 7 Professional 32bit Service Pack 1, 2048 MB Ram

Task Manager while Guest is running: CPU Usuage 1-3%, RAM 3.02GB used

Changed 2 years ago by gwaddell

VMLog as guest crashes out...

comment:5 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Duplicate of #10219.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use