VirtualBox

Ticket #6817 (closed defect: fixed)

Opened 4 years ago

Last modified 10 months ago

Menubar preferences not being honored and other bugs

Reported by: sierpins Owned by:
Priority: major Component: GUI
Version: VirtualBox 3.2.0 Keywords: menubar
Cc: Guest type: other
Host type: Mac OS X

Description

The menubar preferences, which worked fine in VB pre-3.2, seem to be broken. I have denoted in my vm preferences that I don't want to be able to view the system menubar in full-screen mode, but it displays anyways. Furthermore, when I switch to windowed mode, the menubar disappears! The desired behavior is for the menubar to disappear in fullscreen mode, and to appear in windowed mode.

Attachments

Screen shot 2010-10-20 at 6.10.17 PM.jpg Download (18.8 KB) - added by sierpins 4 years ago.
I don't have auto show dock and menubar selected
Screen shot 2010-10-20 at 6.10.43 PM.jpg Download (110.2 KB) - added by sierpins 4 years ago.
It still shows the menubar in fullscreen
Screen shot 2010-10-20 at 6.11.05 PM.jpg Download (121.2 KB) - added by sierpins 4 years ago.
The menubar is gone in non-fullscreen (should never happen)

Change History

comment:1 Changed 4 years ago by sierpins

This behavior is also in 3.2.2

comment:2 Changed 4 years ago by sierpins

This bug is also present in 3.2.4

comment:3 Changed 4 years ago by poetzsch

Have you more than one monitor connected?

comment:4 Changed 4 years ago by sierpins

Nope, I am just using the laptop screen from the Macbook4,1. I am not attaching another monitor.

comment:5 Changed 4 years ago by sierpins

This bug is also present in 3.2.6

comment:6 Changed 4 years ago by sierpins

This behavior is also present in 3.2.10. I will try to post screenshots to help explain the problem.

comment:7 Changed 4 years ago by sierpins

The problem is related to bug # 5636

Changed 4 years ago by sierpins

I don't have auto show dock and menubar selected

Changed 4 years ago by sierpins

It still shows the menubar in fullscreen

Changed 4 years ago by sierpins

The menubar is gone in non-fullscreen (should never happen)

comment:8 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Obsolete. Please open a new ticket if you still see problems with VBox 4.2.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use