VirtualBox

Ticket #6816 (reopened defect)

Opened 4 years ago

Last modified 3 months ago

Sound is very choppy as of 3.2

Reported by: sierpins Owned by:
Priority: major Component: audio
Version: VirtualBox 3.2.0 Keywords: choppy
Cc: Guest type: Windows
Host type: Mac OS X

Description

I am using a Mac OS X 10.6.3 host on a Macbook4,1 (early '08), and with both Windows XP and Ubuntu Linux (8.04) guests, I am getting very choppy audio. It seems to happen more with sounds with short duration, like error sounds. The login sound is also very choppy. I've noticed some small amount of choppiness before, but it is now very severe. I can submit any logs/core dumps/etc requested.

Attachments

VBox.log Download (80.6 KB) - added by matteosistisette 3 years ago.
WinXP-2010-10-30-11-19-33.log Download (45.4 KB) - added by Mahrvin 3 years ago.
Ubuntu-2010-12-17-11-14-33.log Download (48.3 KB) - added by hightek 3 years ago.
VBox Log file Host XP Guest Ubutu
VBox.2.log Download (44.1 KB) - added by teyesahr 3 years ago.
teyesahr's VBox.log file

Change History

comment:1 Changed 4 years ago by krid

Running vbox 3.2 on OS X 10.6.3 with an Ubuntu 10.4 guest I get choppy audio as well. Short sounds are the worst, but music has glitches every 1-3 seconds.

comment:2 Changed 4 years ago by sierpins

This bug is also present in 3.2.2

comment:3 Changed 4 years ago by HipHoppity

I've also noticed this on Mac OSX 10.5.8 Hosts with WinXP SP3 Guests since VBox 3.2.0 release. Let me know if you would like logs, etc.

comment:4 Changed 4 years ago by lnozot

I have found this on my Linux x64 host with linux and windows clients (32bit and 64bit). It first showed up for me in 3.2 but downgrading to 3.1.8 the issue was evident there as well. Version 3.1.6 does not have this problem. I have verified on my system that 3.2.2 and 3.2.4 also have the choppy sound issue. The issue goes away when removing the current version and reinstalling 3.1.6.

To me is sounds like a driver timing issue. Maybe unrelated but after jumping from 3.1.6 I/O on 3.2 was horrible. The system doesn't go into I/O storm in 3.2.2 but I have trouble running 2 clients concurrently. I have yet to test 2 clients in 3.2.4.

My system basic info: Linux x64 openSuSE 11.1 kernel 2.6.27.45 ALSA 1.0.23 pulse audio 0.9.15 (only used for skype)

comment:5 Changed 4 years ago by sierpins

This bug is also present in 3.2.4

comment:6 Changed 4 years ago by ZeB

Same problem here since v3.2 on a Mac Pro running Mac OS 10.5.8. All kind of sounds (i tried ingame with command & conquer) are more than laggy.

comment:7 Changed 4 years ago by macalves

Host: Mac OSX 10.6.4

Guest: Windows XP SP3

VBox: 3.2.4 & 3.2.6

I first noticed the choppy sound when updated to 3.2.4, but the problem persists in 3.2.6. It is easily recognized when starting Windows (the welcome sound)

comment:8 Changed 4 years ago by ZeB

I still have this bug, but strangely the sound is choppy only at startup in my case ! I just tried playing some songs on deezer.com and no lag at all… System alert sounds too are fine. I'll retry with a game in the next days.

comment:9 Changed 4 years ago by archguest

Same problem here. Sound is very choppy and generally lower quality compared to VMWare Fusion (which has other problems btw).

Host: OS X 10.6.4 Guest: Arch Linux 2.6.34 stock kernel OR Debian Lenny VBox: 3.2.6 and 3.2.8

comment:10 Changed 4 years ago by mikepalmergee

Host: OS X 10.6.4 on MacBook Pro Guest: Windows XP Pro SP3 Sound quality fine on VBox 3.1.8, really bad on everything since (3.2.6, 3.2.8)

comment:11 Changed 4 years ago by josephdaniel

Host: OS X 10.6.4 on Macbook 5,1 Guest: Windows XP Pro Sp3. Audio is choppy, some graphics tearing and machine is generally slower since 3.2.0

comment:12 Changed 4 years ago by cdome

I can confirm that I have the same issue. The sound is very choppy (unbearable to hear). Host - arch linux kernel 2.6.35, alsa - 1.0.23, virtualbox - 3.2.8. Guest - windows xp sp3, vbox additions installed. I have tried both Alsa and OSS drivers with the same results.

comment:13 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Retry with 3.2.10 please.

comment:14 Changed 4 years ago by HipHoppity

Installed VBox 3.2.10 today. Bug fix seems to be working with my configuration:

Hosts = Mac OSX 10.5.8
Guests = WinXP SP3

I never thought I would be so pleased to once again hear the dulcet tones of the Windows startup theme. . .

Thanks for working on this bug!

comment:15 Changed 4 years ago by josephdaniel

3.2.10 is finally working fine for me. Mac OS X 10.6.4 Host with WinXP SP3 guest. Thanks a lot for correcting this. I had been stuck with 3.1.8 for some months!

comment:16 Changed 3 years ago by sierpins

Using 3.2.10 for a few days, seems to be fixed. Thanks!

comment:17 Changed 3 years ago by matteosistisette

  • Status changed from closed to reopened
  • Resolution fixed deleted

I've just upgraded to 3.2.10 and IT IS NOT FIXED

Windows 7 guest, Ubuntu 10.04 host. It's EXACTLY as before, it has not even improved the slightest bit.

comment:18 Changed 3 years ago by sierpins

@ matteosistisette : The original bug report was for Mac OS X hosts; I'm not sure if re-opening the bug or creating a new one for Linux hosts is appropriate. Does anyone know?

comment:19 Changed 3 years ago by matteosistisette

@sierpins, the original reporter had a Mac host but more people had confirmed the issue on linux hosts also.

By the way #7312 described the same issue with Windows host (and windows guest) and had been marked as duplicate of this one

comment:20 Changed 3 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

You don't supply any information. Instead of LOUDLY complaining you should open a new defect and attach at least the VBox.log of that session. This ticket's problem is solved.

comment:21 Changed 3 years ago by matteosistisette

  • Status changed from closed to reopened
  • Resolution fixed deleted

I do supply information: I'm saying that the problem persists. I didn't think the log would be of much help in this case, sorry about that, I will attach it.

This ticket's problem is that the sound is very choppy. Since the sound is still choppy, this ticket problem is not completely solved. The bug that was thought to be the cause, or that was actually the cause of this problem in some cases, is (i guess) solved. I don't see any point in opening a new ticket with exactly the same description.

I was not complaining, I was _informing_ that the problem is not fixed, since thinking it is fixed won't help fixing it.

Changed 3 years ago by matteosistisette

Changed 3 years ago by Mahrvin

comment:22 Changed 3 years ago by Mahrvin

The Problem persists for me as well. Host is Ubuntu 10.04, guest is Windows XP.

comment:23 Changed 3 years ago by padde

I'm having this problem as well - Host is Linux x86_64, guest Windows XP, Audio output ALSA / ICH AC97. I can play back audio with Windows Media Player just fine, but when I play the same file with VLC, it's a choppy, noisy mess.

Changed 3 years ago by hightek

VBox Log file Host XP Guest Ubutu

comment:24 Changed 3 years ago by hightek

I'm having the same choppy audio problem using XP as Host and Ubuntu as Guest.

Vbox Version: 3.2.12 Audio Host Driver: Windows DirectSound Controller: ICH AC97

Guest Additions have been installed which improved video card performance but did not do anything for the audio.

I attached the log file named: Ubuntu-2010-12-17-11-14-33.log if that will help.

comment:25 Changed 3 years ago by matteosistisette

Issue still present in 3.2.12 (Windows 7 64bit guest on Ubuntu 10.04 32bit host)

comment:26 in reply to: ↑ description ; follow-up: ↓ 28 Changed 3 years ago by onecsguy

I am using Windows7 x64 guest on Ubuntu 10.10, I am using Windows for Visual Studio / Adobe and subscription music services. I was having the choppy sound issue, It went crazy anytime I did anything graphics or cpu intense on the linux host even with virtualbox minimized which makes sense. But I knew it had to be some kind of virtual box guest->host communication issue maay just not have the proper priority. I have verified that the Audio hardware emulation is perfect. The workaround for me is to RDP into Windows 7 from the Terminal Server Client within Ubuntu. The sound is then flawless. Maybe VBox needs to borrow some ideas, maybe making an audio driver that communicates over a TCP stream instead of w/e guest->host communication they are currently using. This is actually something that could probably be developed by a third party ... Also VLC might already be capable of transmitting the flawlessly created sound from the guest to the host. Im just glad I have my sound now, but it would be nice if Virtual Box had proper sound support natively. I have not tried the RDP extension withing Virtual Box yet but I imagine it will suffer the same choppy audio as it is outside of the emulator where the RDP Server resides.

Hopefully this helps the VBox community as well as the developers diagnose and resolve or work around the problem.

Changed 3 years ago by teyesahr

teyesahr's VBox.log file

comment:27 Changed 3 years ago by teyesahr

I am using Windows 7 Ultimate x32 guest on an Ubuntu 10.04 x64 host, and one of the major reasons for me virtualizing was so I could watch Netflix without having to dual-boot. Unfortunately, I am suffering the same choppy sound as everyone else here. I use the ALSA / ICH AC97 combo. I have VirtualBox 4.0.6 r71344 installed. I have attached my log file. Any help would be appreciated. I haven't tried RDP, yet, but will in a minute.

comment:28 in reply to: ↑ 26 Changed 3 years ago by teyesahr

Replying to onecsguy:

The workaround for me is to RDP into Windows 7 from the Terminal Server Client within Ubuntu.

I just tried using Terminal Server Client to RDP into my Windows 7, but it didn't work. Anything special I need to know about RDPing into a virtualized machine? The error reads: "ERROR: 10.0.2.15: unable to connect".

comment:29 Changed 3 years ago by matteosistisette

Too sad to hear that this hasn't been fixed in version 4.

@onecsguy could you please explain your workaround in more detail? It sounds like it really works but I don't understant what you did.

Thanks m.

comment:30 Changed 3 years ago by teyesahr

I just found a solution that works for me. As I noted previously, I am running VirtualBox 4.0.6 on Ubuntu 10.04 x64, with a Windows 7 x32 guest. Sound was very scratchy with the ALSA / ICH AC97 combo. I followed the instructions in this thread:  http://forums.virtualbox.org/viewtopic.php?p=51237#p51237 (creating a .asoundrc file in my home directory) which fixed the problem. I now use Pulse audio. Next step is to get the video smoothed out....

comment:31 follow-ups: ↓ 32 ↓ 33 Changed 3 years ago by matteosistisette

I confirm the issue is still present in version 4.0.12.

I have tried the workaround suggested by tetesahr which seems to have worked for so many people: creating a .asoundrc file in my home directory. It didn't work.

I created the file and rebooted the guest (host sound driver was set as ALSA). No luck. I set "pulse audio" as the host driver and rebooted the guest. No luck either. Not the slightest improvement.

Do I have to reboot the host too?

Can anybody guide me through the RDP workaround? I don't know what that is...

comment:32 in reply to: ↑ 31 Changed 3 years ago by onecsguy

Replying to matteosistisette:

I confirm the issue is still present in version 4.0.12.

I have tried the workaround suggested by tetesahr which seems to have worked for so many people: creating a .asoundrc file in my home directory. It didn't work.

I created the file and rebooted the guest (host sound driver was set as ALSA). No luck. I set "pulse audio" as the host driver and rebooted the guest. No luck either. Not the slightest improvement.

Do I have to reboot the host too?

Can anybody guide me through the RDP workaround? I don't know what that is...

comment:33 in reply to: ↑ 31 Changed 3 years ago by onecsguy

Replying to matteosistisette: .........

Can anybody guide me through the RDP workaround? I don't know what that is...

*RDP Workaround*

The RDP Workaround requires a Pro or Server Guest OS, Windows XP Pro, I was using Windows 7 Professional ... This does not use the Virtual Box built in RDP as it would route the sound after the hardware issue so itl still be choppy

  1. Step one Enable RDP in the Windows [Guest] from My Computer(Right Click)->Properties->Remote ... Allow Remote Connections
  1. The get the IP address or DNS name of the Windows Guest (itl need to be on the same network as your host, NAT, or Host Only should work well)
  1. Use a RDP Terminal Services client on the host to connect to the IP address, your VirtualBox can be minimized to the background.
    • Linux Ubuntu: Im using Terminal Server Client
    • Windows: just Start->Run ... "mstsc.exe"

comment:34 Changed 3 years ago by matteosistisette

Thanks onecsguy

I've tried that. I run tsclient and got a dialog window where I entered the server ip, user name etc. When I clicked "connect" the window disappeared (without any error message) and nothing happened. The tsclient process seems to be still running but I don't see any client window.

What am I missing?

I launched it by typint "tsclient &" from a terminal (I'm on a ubuntu host).

But by the way won't that add a tremendous overhead to everything, especially graphics??

comment:35 Changed 3 years ago by matteosistisette

Ah, ok, an error message did appear after a pretty long while:

(tsclient:8537): WARNING : Autoselected keyboard map en-us ERROR: channel_register WARNING: Initializing sound-support failed! ERROR: 10.0.2.15: unable to connect

That is the IP as seen from the guest. Isn't it the same ip seen from the host?

comment:36 Changed 2 years ago by matteosistisette

Very sadly, this is still not fixed in 4.1.8.

comment:37 Changed 2 years ago by positron96

I confirm the bug in Win 7 Pro x64 host, Win XP Pro SP3 x86 guest, VB 4.1.8

comment:38 Changed 2 years ago by matteosistisette

Not fixed in 4.1.10 either.

comment:39 Changed 13 months ago by rogerx

I had staticky audio using Virtual Box Alsa Intel AC97 emulation within Windows XP guest on Linux/ALSA/JACK. The other Alsa drivers, Intel HD and Soundblaster 16, failed to work. The OSS drivers also seemed to appear to fail in the past until now with virtualbox-4.1.24.

How I resolved my poor audio playback:

1) Choose Audio driver: OSS

2) Choose Audio Controller: ICH A97

3) Make sure you don't have Jack Audio running, or other audio processes using the audio device.

This is the first time in a long time I've finally gotten sound to work with decent quality in a long time! Now, to try to get things playing nice with Jack.

Version 2, edited 13 months ago by rogerx (previous) (next) (diff)

comment:40 Changed 8 months ago by matteosistisette

Still an issue in 4.2.16. Unbelievable. Is Oracle even looking into this?

comment:41 Changed 8 months ago by frank

At the moment there is no direct investigation going on here. The reason is that quality of the sound emulation in a virtualized environment depends heavily on the environment (guest, host, host hardware) and it is hard to take every bit into account. Several audio backends allow the tuning of some buffer parameters (actually not yet documented, we want to fix this eventually). Also, there are many many other problems open, and it the goal of the VirtualBox developers at Oracle, to prioritize problems. Bugs/requests from paying customers have a higher priority. Bugs which affect the host/guest availability/stability or security have a higher priority either. It does not matter if a bug is open for 3 days, 3 weeks or 3 years, sorry.

As we are currently rewriting the VT-x/AMD-V code in VirtualBox, this might also influence such scheduling problems.

comment:42 Changed 5 months ago by dbohdan

I ran into a problem with choppy sound with a Windows XP Pro SP3 guest and the ICH AC97 audio controller. It happened in VirtualBox versions 4.2.16 and 4.3 on hosts running Windows 8.1 and Ubuntu 12.04 (Linux kernel 3.2.0-55-generic, PulseAudio). Switching the guest audio controller to SB16 made the audio less choppy but did not eliminate the problem completely. What resolved the sound issues for me was the solution from  http://superuser.com/a/271736. This resolved all sound issues with a Windows XP guest on every host computer/OS combination I tried. The instructions are reproduced below:

[Do the following inside the guest Windows XP installation:]

Go to: Start -> Control Panel -> System -> Hardware -> Drivers, select the sound controller (SigmaTel), then Update driver -> No web update, find the driver yourself -> select Intel 82801AA AC’97 Controller

I also investigated the cause for the Windows XP guest selecting the wrong driver. In our case it looks like the use of the nLite deployment tool to integrate driver packs into the OS disc image before installation is to blame. Specifically, integrating DriverPack Sound B ( http://driverpacks.net/node/735/drivers) into a Windows XP installation CD leads to the wrong driver being used for the virtual sound device. I tried it and it did not happen with an unaltered original Windows XP Professional installation CD.

Last edited 5 months ago by dbohdan (previous) (diff)

comment:43 Changed 3 months ago by quickbooks

Host Fedora 20 - Gnome Desktop.

When watching Netflix on Windows 8.1 in Internet Explorer, the sound is static sometimes, or the sound breaks, or choppy / jittery.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use