VirtualBox

Ticket #6813 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

VERR_NO_MEMORY, can not run guest system => Retry with 3.2.2

Reported by: SergeyPerm Owned by:
Priority: major Component: host support
Version: VirtualBox 3.2.0 Keywords:
Cc: r61806 Guest type: Windows
Host type: Windows

Description

I download VirtualBox 3.2.0 r61806, and create new virtual machine for Windows XP, connect hdd-file as local drive and start exist installed guest os windows xp. All right, but some time after virtual machine crashed. Then I restart virtual machine and guest os cant found (SystemRoot)\WINDOWS\ntoskrnl.exe. Then restart and I saw next message:

VirtualBox - Error

Failed to open a session for the virtual machine Windows XP.

Failed to load VMMR0.r0 (VERR_NO_MEMORY)

Unkonwn error create VM (VERR_NO_MEMORY)

Details

Result Code: 
E_FAIL (0x80004005)
Component: 
Console
Interface: 
IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

that is all :( its permanently message if I start virtual machine (run guest os).

If I create a new virtual machine, I have seen it message again.

Attachments

Windows XP-2010-05-26-18-14-57.log Download (1.1 KB) - added by SergeyPerm 4 years ago.
VBox.log
Windows XP-2010-06-01-15-20-56.log Download (40.1 KB) - added by SergeyPerm 4 years ago.
Successfully start VM log
Windows XP-2010-06-01-16-48-17.log Download (1.1 KB) - added by SergeyPerm 4 years ago.
Failure VM run
VBox.log Download (1.2 KB) - added by brocky 4 years ago.
Windows XP SP3 - 2010-06-02 22:10:51

Change History

Changed 4 years ago by SergeyPerm

VBox.log

comment:1 Changed 4 years ago by SergeyPerm

Additional to main post:

Host system: Vista Ultimate x64, Service Pack 2. RAM 8 Gb, other parameters is ok (video RAM, HDD). CPU Celeron E3200 2.4GHz (2 kernels)

hdd-file located at server, mounted as network drive to host system via ssh, first run is ok. Into guest OS I begin copying 4gb files and guest system is crashed. Then see main post.

what else? I do not known :(

comment:2 Changed 4 years ago by brocky

I too have had this problem 1 day after updating to 3.2.0, I was not in a position to capture any logs, but the error was the same.

to get this error I had:

  1. run a VM with WinXP SP3 (2048MB memory allocated)
  2. closed WinXP SP3 VM (with pause state)
  3. logged in via remote desktop
  4. tried to start the same VM - got VMMR0.r0 (VERR_NO_MEMORY)
  5. deleted saved state and tried to start again, same error
  6. tried to start a VM with only 64MB memory allocated (at this point windows was

reporting over 4GB free)

Additional notes:

  1. I later tried to update my graphic drivers(for nVidia) from the local machine and they too complained about no memory available to start the newly installed drivers
  2. I was able to run blender 3D and use ~1GB of memory with it, while over remote desktop
  3. Resetting the computer fixed the problem, I have not had it since however have not gone through the steps above since

comment:3 follow-up: ↓ 4 Changed 4 years ago by SergeyPerm

I think, VM have a problem if a system use over 4GB RAM at start VM.

comment:4 in reply to: ↑ 3 Changed 4 years ago by SergeyPerm

Replying to SergeyPerm:

I think, VM have a problem if a system use over 4GB RAM at start VM.

Hmm, now I started VM successfully. New log attached.

Changed 4 years ago by SergeyPerm

Successfully start VM log

comment:5 Changed 4 years ago by frank

Did you test an older version of VirtualBox or is version 3.2.0 the first version you tested on this host? Trying to find out if this is a regression ...

comment:6 Changed 4 years ago by SergeyPerm

I installed VirtualBox on this host first, I never used VirtualBox under Windows (under Debian only).

Now I am testing runned VM: start copying big file from host over network.

How I can crash testing VM otherwise?

comment:7 Changed 4 years ago by brocky

In my case, my virtual machine has been upgraded over the last year with every stable release as it comes out. The last few updates were 3.1.2->3.1.4->3.1.6->3.2.0

I am running it on Windows 7 Pro x64, 8GB RAM, Intel Core Quad.

I have not had this problem with any previous versions, and i have been using it for years

Changed 4 years ago by SergeyPerm

Failure VM run

comment:8 Changed 4 years ago by SergeyPerm

I am using for copying is "FAR Manager". Copying is done successfully. Next, I am press F8 to delete file (in FAR Manager is key to delete file) and my VM began shutdown...

And now I read message about VERR_NO_MEMORY... VM no runs again.

comment:9 follow-up: ↓ 10 Changed 4 years ago by brocky

It seems that it might be a memory leak that windows doesn't catch. Resetting you computer should fix this as it did mine, although that is often a pain.

comment:10 in reply to: ↑ 9 Changed 4 years ago by SergeyPerm

Replying to brocky:

Resetting you computer should fix this as it did mine, although that is often a pain.

It seems, reset helps for one run only... is not solve a problem.

comment:11 follow-up: ↓ 14 Changed 4 years ago by misha

to all having this issue: are/were you running any VMs that use bridged networking when this error occurs?

comment:12 Changed 4 years ago by brocky

Yes, all of mine are.

If it matters, bridged network adapters seem to be bringing me more troubles too. Making the adapter disappear from WinPCap, and when i go to change a setting it disappears from windows too as soon as i start a VM. There are more strange symptoms if you are interested, otherwise i will start a new ticket for these

comment:13 Changed 4 years ago by frank

  • Summary changed from VERR_NO_MEMORY, can not run guest system to VERR_NO_MEMORY, can not run guest system => Retry with 3.2.2

brocky, there is a bug in VBox 3.2.0 causing a memory leak when using bridged networking. Maybe this is the cause for your problems as well.

Please update to VBox 3.2.2 which is released soon. If you still experiment the same problem, please attach a VBox.log file again. We instrumented the code a bit and expect to see more information if that case triggers again.

Changed 4 years ago by brocky

Windows XP SP3 - 2010-06-02 22:10:51

comment:14 in reply to: ↑ 11 Changed 4 years ago by SergeyPerm

Replying to misha:

to all having this issue: are/were you running any VMs that use bridged networking when this error occurs?

yes, my VM use bridged network.

comment:15 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

In that case we believe your problem is fixed with VBox 3.2.2. Make sure to download the correct build (3.2.2-62321).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use