VirtualBox

Ticket #6759 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Second virtual monitor via VRDP sends clicks to first display => Fixed in 3.2.4

Reported by: feb Owned by:
Priority: major Component: RDP
Version: VirtualBox 3.2.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I have a 32-bit windows xp sp3 guest (started via VBoxHeadless) with two displays running on a 64-bit Debian 5.0.4 host, and I use rdesktop 1.0.6 to connect to them. When using VirtualBox 3.1.8, they behave as expected. When using VirtualBox 3.2.0, any clicks on the second display appear only on the first; i.e., clicking the lower-left corner of display 2 activates the start menu on display 1. For another example, I can drag a window from display 1 to display 2, but then can't drag it back because my clicks are registering on display 1. I thought it may be an interaction with either KDE4 (I rebuild the whole thing from trunk every couple of days) or my window manager (awesome 2.3.3 as packaged in Debian) but stopping KDE and switching to metacity didn't fix the issue. This does not happen if I start the machine from the GUI and use it directly.

Other possibly-relevant item: I have an ATI Radeon HD 2400 XT card (using the fglrx driver) driving two HP L2245w monitors, each rotated 90 degrees via xrandr.

Change History

comment:1 Changed 4 years ago by aaanchan

Can confirm same results with both rdesktop 1.6.0 or WinXP RDP client. Seems to be issue with VBoxHeadless on 3.2.0 and not desktop environment.

comment:2 Changed 4 years ago by frank

This works fine here with VBox 3.2.2. Can you re-check?

comment:3 Changed 4 years ago by frank

I take that back. Now I'm able to reproduce this. VBoxHeadless only, works fine if the VBox is started from the GUI.

comment:4 Changed 4 years ago by frank

  • Summary changed from Second virtual monitor via VRDP sends clicks to first display to Second virtual monitor via VRDP sends clicks to first display => Fixed in 3.2.4

This issue will be fixed in the next maintenance release.

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use