VirtualBox

Ticket #6751 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

VBoxManage openmedium Create uuid with Parentuuid

Reported by: robcarr Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.1.8 Keywords: openmedium
Cc: dfurphy@… Guest type: Windows
Host type: Linux

Description

When VBox is open I cant use the openmedium to update VirtualBox.xml when I need to add a uuid that has a partent uuid. It is able to detect the parent uuid, but when it writes to the XML file it doesnt insert it within a parentuuid HardDisks tag

Change History

comment:1 Changed 4 years ago by robcarr

To further explain: When I first start up the VM's from a closed state, the xml file is correct:

<mediaRegistry>  
  <HardDisk>
   <HardDisk uuid="{302ec89b-31e5-47a5-b2f2-39c926c1d953}" location="VM/WIN-O7S5E3WN0T2/C.vmdk" format="VMDK" type="Normal">
          <HardDisk uuid="{cfd13764-ce1a-b85a-4d0d-c636d93e26ac}" location="VM/WIN-O7S5E3WN0T2/C-s0001.vmdk" format="VMDK"/>
   </HardDisk>
  </HardDisk>
 <DVDImages/>
 <FloppyImages/>
</MediaRegistry>

If VBox is running and I use openmedium to inserty a new VM the XML will look like this, where the child is not nested:

<mediaRegistry>  
  <HardDisk>
   <HardDisk uuid="{302ec89b-31e5-47a5-b2f2-39c926c1d953}" location="VM/WIN-O7S5E3WN0T2/C.vmdk" format="VMDK" type="Normal" />
   <HardDisk uuid="{cfd13764-ce1a-b85a-4d0d-c636d93e26ac}" location="VM/WIN-O7S5E3WN0T2/C-s0001.vmdk" format="VMDK"/>
   </HardDisk>
 <DVDImages/>
 <FloppyImages/>
</MediaRegistry>

comment:2 Changed 4 years ago by klaus

Please state exactly what you're doing, where the images come from etc. Otherwise it's highly likely that we end up doing something subtly different, and are not able to reproduce.

comment:3 Changed 4 years ago by robcarr

When Virtual Box is running on the host and I want to add a new guest I am adding vmdk images that I already have there are 2 and one is a parent and the other a child and when trying to use openmedium to add both these images with the parent child relationship doesn't seem possible. It seems like openmedium adds them both as independent images as noted in my second code block. Openmedium has the --parentuuid option and I am trying to add a disk So I am using something like this.

VBoxManage openmedium disk /path/to/parent --uuid "Puuid"
VBoxManage openmedium disk /path/to/child --parentuuid "Puuid" --uuid "Cuuid"

comment:4 Changed 4 years ago by klaus

I asked where the images come from - are they from VMware or some other product besides VirtualBox? Because that's about the only way I can imagine which might cause trouble.

Also, using the "uuid hacking" switches should be limited to cases where you absolutely need them, and they might result in unexpected behavior due to their "make some extremely unusual cases work" nature. They are certainly not necessary if you simply register some images from another VirtualBox install.

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in VBox 3.2.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use