VirtualBox

Ticket #6722 (closed defect: worksforme)

Opened 4 years ago

Last modified 19 months ago

Full Screen Mode Does Not Work in Secondary Monitor

Reported by: gaborbay Owned by:
Priority: major Component: GUI
Version: VirtualBox 3.2.0 Keywords: Full Screen Mode
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

I just upgraded from 3.1.6 to 3.2. When I have VBox open in a secondary monitor and hit Full Screen Mode (Host+F), it opens into full screen in the main monitor instead of the Secondary Monitor. This used to work correctly in 3.1.6. If you search the forums under Windows XP Host for "Multimonitor host and singlemonitor guest fullscreen?" you can see that several people have this issue after upgrading to 3.2.

I am running WinXP Pro Host and WinXP Pro Guest.

Attachments

VBOX1-2010-05-19-11-18-07.log Download (45.8 KB) - added by gaborbay 4 years ago.
Log File
VBox.log Download (58.0 KB) - added by nahun 4 years ago.
log from Ubuntu host and Win7 guest
Vbox_Host_Home.png Download (15.3 KB) - added by gaborbay 4 years ago.
Host + Home Screenshot for WinXP
fullscreen-dual.png Download (114.5 KB) - added by nahun 4 years ago.
Menu option to choose which screen

Change History

Changed 4 years ago by gaborbay

Log File

Changed 4 years ago by nahun

log from Ubuntu host and Win7 guest

comment:1 Changed 4 years ago by nahun

same problem for me. Upgraded from 3.1.8 to 3.2 and now have this problem. Attached a log file from an Ubuntu host and Win7 guest

comment:2 Changed 4 years ago by poetzsch

Had you a look at the new view menu when in fullscreen? You can use HOST+Home or the mini tool bar to reach that menu.

comment:3 Changed 4 years ago by gaborbay

Re poetzsch: I have no idea what you are trying to say. Why would I look at the new view menu when in fullscreen. The problem is that it's showing fullscreen in the wrong monitor. Also, HOST+Home drops down the "Machine" menu, which has "Fullscreen Mode (Host +F)" as an option. What does looking at the menu accomplish. Am I missing something?

comment:4 Changed 4 years ago by Aphax

Just wanted to add that after upgrading to 3.2.0 I am actually getting the same thing on a *Linux* host with dual head setup. Previously, when I fired up a VM and hit Host+F it would go fullscreen on whatever display the VM window was on, but now it just jumps to the primary display every time. This is a bit annoying because it is extremely handy for me to have it on my secondary screen so my panels (Gnome desktop) don't get obscured.

comment:5 follow-up: ↓ 6 Changed 4 years ago by Aphax

Whoops, now I see what poetzsch was talking about, Host+Home gives a menu, in which there is a sub-menu 'View' that lets you put the VM fullscreen window on a different host screen, so that lets me set it up exactly how I wanted it :)

comment:6 in reply to: ↑ 5 Changed 4 years ago by nahun

Replying to Aphax:

Whoops, now I see what poetzsch was talking about, Host+Home gives a menu, in which there is a sub-menu 'View' that lets you put the VM fullscreen window on a different host screen, so that lets me set it up exactly how I wanted it :)

oh you're right, works fine for me too. Guess this bug needs to be closed.

comment:7 follow-up: ↓ 8 Changed 4 years ago by gaborbay

When I hit Host+Home, I'm seeing the same menu that you get when you click on "Machine" at the top left hand corner. I'm not seeing a sub-menu called 'View'. Can someone submit a screenshot? Maybe WinXP Guest is different :(

Changed 4 years ago by gaborbay

Host + Home Screenshot for WinXP

comment:8 in reply to: ↑ 7 Changed 4 years ago by nahun

Replying to gaborbay:

When I hit Host+Home, I'm seeing the same menu that you get when you click on "Machine" at the top left hand corner. I'm not seeing a sub-menu called 'View'. Can someone submit a screenshot? Maybe WinXP Guest is different :(

You have to be in fullscreen mode to see this specific option. Attached a screenshot

Changed 4 years ago by nahun

Menu option to choose which screen

comment:9 Changed 4 years ago by gaborbay

Ok I got it. The key then is to be in Full-screen mode when selecting Host+Home. Not sure why they changed this. Very unintuitive now.

comment:10 Changed 4 years ago by gaborbay

Thx for the clarification!

comment:11 follow-up: ↓ 12 Changed 3 years ago by Commifreak

Hey,

I'm confused, how does it work on VB 4.0.4? There is no View menu, only:

  • Machine
  • Devices
  • Help

Using VB on MacOSX with Ubuntu as guest with installed Tools.

comment:12 in reply to: ↑ 11 Changed 3 years ago by nahun

Replying to Commifreak:

Hey,

I'm confused, how does it work on VB 4.0.4? There is no View menu, only:

  • Machine
  • Devices
  • Help

Using VB on MacOSX with Ubuntu as guest with installed Tools.

Are you in fullscreen or seamless mode?

comment:13 follow-up: ↓ 14 Changed 3 years ago by Commifreak

Iam in windowed mode and want to switch to the fullscreen mode, but the fullscreen should appear on the external monitor, where the windowed Guest currently is :)

comment:14 in reply to: ↑ 13 Changed 3 years ago by nahun

Replying to Commifreak:

Iam in windowed mode and want to switch to the fullscreen mode, but the fullscreen should appear on the external monitor, where the windowed Guest currently is :)

Not sure I understand. Just do Machine->Switch to Fullscreen. Then you'll see the view menu

comment:15 in reply to: ↑ description Changed 23 months ago by Mark

Replying to gaborbay:

I just upgraded from 3.1.6 to 3.2. When I have VBox open in a secondary monitor and hit Full Screen Mode (Host+F), it opens into full screen in the main monitor instead of the Secondary Monitor. This used to work correctly in 3.1.6. If you search the forums under Windows XP Host for "Multimonitor host and singlemonitor guest fullscreen?" you can see that several people have this issue after upgrading to 3.2.

I am running WinXP Pro Host and WinXP Pro Guest.

First, open the tool bar by RightCtrl+Home key. In "view" menu, find "Virtual Screen 1" and change it to "Use Host Screen 2". Now you have full screen in the second monitor. Adjust the resolution to fit the second monitor. Done!

comment:16 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use