VirtualBox

Ticket #6716 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

3.2 Slow guests after update from 3.1.8 -> fixed in SVN (nested paging regression fixed in 3.2.2)

Reported by: pcperfect Owned by:
Priority: critical Component: VMM/HWACCM
Version: VirtualBox 3.2.0 Keywords: nested paging
Cc: Guest type: other
Host type: other

Description

After updating virtualbox 3.1.8 to 3.2 on an Ubuntu 10.04 64-bit host my XP/FLP guest runs very slow. I haven't tried any 3.2 beta.

Disabling "Enable Nested Paging" restored the speed.

Also reported on Mac hosts:  http://forums.virtualbox.org/viewtopic.php?f=8&p=138101

Attachments

VBox.log.1 Download (80.5 KB) - added by pcperfect 4 years ago.
VBox.log Download (81.1 KB) - added by pcperfect 4 years ago.
fast / nested paging disabled
XP box-20100519-Nested.log Download (66.0 KB) - added by NuShrike 4 years ago.
XP32 within Win764 on i5
XP box-20100519-noNested.log Download (70.7 KB) - added by NuShrike 4 years ago.
XP32 within Win764 nested paging OFF
Ubuntu-fast.log Download (44.0 KB) - added by xcolour 4 years ago.
Mac host, Ubuntu 32 Guest, fast (no NP)
Ubuntu-slow.log Download (61.0 KB) - added by xcolour 4 years ago.
Mac host, Ubuntu 32 Guest, slow (yes NP)
VB-PPro2-2010-05-29-10-20-40.log Download (47.1 KB) - added by ToddAndMargo 4 years ago.
windows server 2003 CPU max'ing
VirtualXP-2010-05-29-10-12-00.log Download (44.7 KB) - added by ToddAndMargo 4 years ago.
windows XP Pro Sp3 CPU max'ing

Change History

Changed 4 years ago by pcperfect

comment:1 Changed 4 years ago by sandervl73

Is this really the correct log file? Your CPU doesn't support nested paging.

comment:2 Changed 4 years ago by sandervl73

Attach the log of a normal/fast session where you turned off nested paging too please.

comment:3 Changed 4 years ago by pcperfect

I guess you are right that the CPU of this machine does not supporting nested paging. I had the option enabled since i made this VM though, which was in 3.0.2 if i recall correct.

Guess i never bothered to check if it was supported and just thought since i can select it and my VM works it was ok.

comment:4 Changed 4 years ago by sandervl73

Right, but without support for this feature turning it on or off will not make any difference (it will not be used). So comparing log files of two different sessions (slow vs fast) might reveal more.

Changed 4 years ago by pcperfect

fast / nested paging disabled

comment:5 Changed 4 years ago by pcperfect

Ok, i uploaded the log of the session i was just running.

Changed 4 years ago by NuShrike

XP32 within Win764 on i5

Changed 4 years ago by NuShrike

XP32 within Win764 nested paging OFF

comment:6 Changed 4 years ago by NuShrike

Added my logs of Win7. In fact, the XP32 box refuses to run unless I give it cursor focus and hold down the "enter" button. Otherwise, it sits there frozen with one cpu-core pegged at 100%. Smells like an interrupt problem.

Changed 4 years ago by xcolour

Mac host, Ubuntu 32 Guest, fast (no NP)

Changed 4 years ago by xcolour

Mac host, Ubuntu 32 Guest, slow (yes NP)

comment:7 Changed 4 years ago by xcolour

Attached my logs for a Mac host and Ubuntu 32bit guest. Having the same problem since 3.2.0. Nested paging was enabled in 3.1.8 with no problems. Now, with it enabled, the VM is unresponsive and one CPU (I only give the VM access to one) is pegged at all times.

Core i7 Mac OS X 10.6.3

comment:8 Changed 4 years ago by sandervl73

Marked #6726 as a duplicate.

comment:9 Changed 4 years ago by sandervl73

  • Priority changed from major to critical

comment:10 Changed 4 years ago by sandervl73

  • Keywords nested paging added
  • Host type changed from Linux to other
  • Component changed from other to VMM/HWACCM
  • Guest type changed from Windows to other

comment:11 Changed 4 years ago by sandervl73

  • Summary changed from 3.2 Slow guests after update from 3.1.8 to 3.2 Slow guests after update from 3.1.8 -> fixed in SVN

Ok, found and fixed the problem. This only applies to those Intel CPUs that support both nested paging and unrestricted guest execution.

pcperfect: your case doesn't make any sense unfortunately and you're the only one who's cpu doesn't support nested paging.

comment:12 Changed 4 years ago by pcperfect

Yeah strangly enough i enabled it again, and it's working fine now.

I had stopped/started the VM several times including a host reboot before i even started searching and found the forum thread. Then i disabled nested paging and it was fixed.

Also had installed the 3.2 client additions directly after upgrading, in save mode (don't know if that's still required for 3d).

Next to slowness i also had (pulse)audio stutter like i used to have with older versions. So i could hear directly from the startup sound.

Well anyway nice work on the quick support and fix.

comment:13 Changed 4 years ago by ToddAndMargo

Hi All,

I realize this may be after the fact, but I have the same problem. In case my data helps to verify the fix, here is my data:

I just upgraded from 3.1.6. Motherboard=Supermicro X8SAX; Memory 24GB; Processor=x5650, 6 cores; Host: CentOS 5.5; Guest 1: XP-Pro-SP3, 1 core; Guest 2: Windows Server 2003, 4 cores.

Both my guests are CPU max'ing. And, Nested Paging is enabled on both of them.

I have since downgraded to 2.1.8 and the system is working very, very well.

-T

Changed 4 years ago by ToddAndMargo

windows server 2003 CPU max'ing

Changed 4 years ago by ToddAndMargo

windows XP Pro Sp3 CPU max'ing

comment:14 Changed 4 years ago by tonydiep

Having the same problem. VMs start fine on 3.1.8 and 3.1.6 WinXP and Ubuntu guests will not start on 3.2.0

Host is 64 bit Ubuntu 10.04 kernel 2.6.32-22 on Core i5 M430

comment:15 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please verify that VBox 3.2.2 fixes this bug.

comment:16 Changed 4 years ago by tonydiep

3.2.2 fixed it for me. Thanks for the good work.

comment:17 Changed 4 years ago by ToddAndMargo

3.2.2 works for me too. But (don't you love that word), I only fired up two of my six processors. 3.1.8, under four processors runs slower, than two processors. That bug I have yet to test under 3.2.2 (Both server are production level and I have to be politic about taking them down. The only reason I got to test the first one was that under 3.1.8 and four cores, their terminal server froze up and I had a chance to go in an do some maintenance. It seems to be completely stable now under two processors and 3.2.2)

Thank you!

-T

comment:18 Changed 4 years ago by tonydiep

  • Status changed from closed to reopened
  • Resolution fixed deleted

Problem's back. WinXP very slow. Funny thing is that it was working fine for awhile now it's incredibly slow with one processor at 100%

comment:19 Changed 4 years ago by tonydiep

Happens with two different WinXP guests. Happens with both nested paging on and nested paging off.

Ubuntu recently pushed out a new kernel. 2.6.32-22-generic #36

Tried reinstalling VirtualBox in case kernel modules got screwed up. Doesn't fix problem.

comment:20 Changed 4 years ago by tonydiep

Removed 3.2.2 Reinstalled 3.1.6 from standard Ubuntu repositories Back to normal speeds.

comment:21 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Summary changed from 3.2 Slow guests after update from 3.1.8 -> fixed in SVN to 3.2 Slow guests after update from 3.1.8 -> fixed in SVN (nested paging regression fixed in 3.2.2)

tonydiep: then it's another problem. Please open a new ticket and attach your VBox.log.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use