VirtualBox

Ticket #6704 (closed defect: wontfix)

Opened 4 years ago

Last modified 4 years ago

PXE stack provides 0.0.0.0 as address for TFTP server for WDS' wdsnbp.com

Reported by: paulm Owned by:
Priority: major Component: network
Version: VirtualBox 3.1.6 Keywords: PXE WDS WDSNBP Windows
Cc: Guest type: Windows
Host type: other

Description

I'm using the version of VirtualBox, as distributed by Debian project as part of sid. This has the Debian package name: virtualbox-ose 3.1.6-dfsg-2

I'm trying to use WDS to auto-deploy Windows to a VirtualBox image. As part of this installation process, the central server will attempt to wipe the virtual machine's hard-disk and install a Windows setup.

Here's what happens after the main BIOS initialisation has completed:

  1. the (virtual) machine BIOS/network card issues a DHCP request.
  1. the DHCP server replies with information, including the machine's IP address, PXE image filename and TFTP server's IP address.
  1. the machine successfully downloads (via TFTP) the PXE image: wdsnbp.com
  1. the PXE image (wdsnbp.com) starts.
  1. wdsnbp.com detects the VirtualBox image's architecture (x86)
  1. wdsnbp.com attempts to acquire an architecture-specific installer via TFTP

The problem is with the last step: wdsbnp.com attempts to contact the TFTP server with IP address 0.0.0.0. Not surprisingly, this attempt fails: the attempt to TFTP the required file from this IP address solicits no replies and the attempt eventually times-out.

Inspection of the network packets shows that the DHCP server-provided information does not contain this incorrect IP address; therefore, it seems that either the PXE stack has become corrupted or WDSNBP is expecting the TFTP server's IP address to be stored by some means that the current VirtualBox BIOS/PXE stack doesn't support.

The network driver is connected to a physical interface (eth0) via an internal bridge, so the machine's network adapter is using the "bridge adapter" option.

The above behaviour happens with both the PCnet-FAST III and PCnet-PCI II adapter emulation.

None of the emulated Intel devices (Intel PRO/1000 MT 82540EM, Intel PRO/1000 T 82543GC, Intel PRO/1000 MT 82545EM) succeed with step 1. above: they all fail to issue a DHCP request.

Cheers,

Paul.

Attachments

wdsnbp-failing.png Download (19.4 KB) - added by paulm 4 years ago.
Screenshot of the PXE boot process failing

Change History

Changed 4 years ago by paulm

Screenshot of the PXE boot process failing

comment:1 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to wontfix

Sorry, we do not support OSE builds. The included PXE boot stack there (etherboot) has known limitations. Our own builds come with a different and better PXE stack.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use