VirtualBox

Ticket #6681 (reopened defect)

Opened 7 years ago

Last modified 2 weeks ago

VirtualBox Accessibility for Mac OS X Hosts Reduced, Possibly Others

Reported by: sgucukoglu Owned by:
Priority: major Component: GUI
Version: VirtualBox 3.1.8 Keywords: Accessibility
Cc: Guest type: other
Host type: Mac OS X

Description (last modified by aeichner) (diff)

I checked the changelogs between 3.0.12, when VirtualBox was (imperfectly, but adequately in conjunction with the command-line) accessible on Mac OS X, using VoiceOver. Now, and confirmed as of VirtualBox 3.1.4 by others, whatever accessibility provided by QT disappeared. What has changed? Can we have the accessibility back? I have transitioned one of my machines per force to Fusion, a native app that does accessibility quite well.

To launch VoiceOver, press Cmd+F5.

Change History

comment:1 Changed 13 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

Please reopen if still relevant with a recent VirtualBox release.

comment:2 Changed 2 weeks ago by chibop

Thank you for improving accessibility. It seemed improved quite a bit since last time I tried a couple of years ago.

However, there are still accessibility issues with VB 5.1.26 on Mac with VoiceOver.

  • In VB Manager, you can't tell which vm is slected. VoiceOver reports Grow area is empty.
  • In preference or In VM setting, if you activate one of the tab with control+option+space, Voiceover reports that it's checked. However, it is not. You have to similate a physical mouse click with control+option+shift+space instead.
  • In input tab of preference, VoiceOver can't read nor modify the shortcut list.
  • In VM Setting, can't change pop-up menus with VoiceOver.
  • In storage tab of VM setting, can't read the tree nor add new storage with VoiceOver.

Thank you for your help!

comment:3 Changed 2 weeks ago by chibop

  • Status changed from closed to reopened
  • Resolution obsolete deleted
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use