VirtualBox

Ticket #6638 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

Guest Additions don't work on guest Debian Squeeze

Reported by: paulchany Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Hi,

I have installed Debian GNU/Linux Lenny i686 as host and on VirtualBox version 3.1.6 Debian Squeeze i686 as guest.

I have installed Guest Additions on Squeeze but don't works.

I followed these steps to get installed Guest Additions on Squeeze:

HOST+D
$ su -
# mount /media/cdrom
# cd /media/cdrom
# sh ./VBoxLinuxAdditions-x86.run

This does run without any errors.

Here is the output of installation process from xterm window on guest Debian Squeeze:


root@debian:/media/cdrom# sh VBoxLinuxAdditions-x86.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 3.1.6 Guest Additions for Linux........
VirtualBox Guest Additions installer
Removing installed version of VirtualBox Guest Additions...
Building the VirtualBox Guest Additions kernel modules
Building the main Guest Additions module ...done.
Building the shared folder support module ...done.
Building the OpenGL support module ...done.
Doing non-kernel setup of the Guest Additions ...done.
You should restart your guest to make sure the new modules are actually used

Installing the Window System drivers
Installing experimental X.Org Server 1.7 modules ...done.
Setting up the Window System to use the Guest Additions ...done.
You may need to restart the hal service and the Window System (or just restart the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services components ...done.
root@debian:/media/cdrom#[[BR]]


Then I reboot the guest Debian Squeeze, but Guest Additions don't works.

Then I run:

$ lsmod | grep vbox

and paste here the output.

On my host Debian Lenny I have:


csanyipal@debian-asztal:~$ lsmod | grep vbox
vboxnetadp 6656 0
vboxnetflt 12712 0
vboxdrv 158888 2 vboxnetadp,vboxnetflt

On my guest Debian Squeeze I have:


csanyipal@debian:~$ lsmod | grep vbox
vboxvfs 25516 0
vboxguest 89612 6 vboxvfs
nls_base 4541 2 vboxvfs,usbcore

I believe the guest additions don't work because in the VirtualBox window where the guest Squeeze run I can see another (black) mouse pointer that I can use after clicking in to running Squeeze window.

After that when I want to leave the VirtualBox Squeeze window, I must to use Host key to use the host: Lenny (white) mouse pointer again.

So, when I highlight some text in host environment and want to paste it in to guest environment, I can't do that.

Furtermore, I can't to resize the VirtualBox guest window; it still remain in 800x600 mode.

On guest Debian Squeeze VBoxClient run because I have PID files:
.vboxclient-clipboard.pid
.vboxclient-display.pid
.vboxclient-hostversion.pid
.vboxclient-seamless.pid

Is this a bug?

--
Regards,
Paul Chany

Attachments

50-vboxmouse.conf Download (111 bytes) - added by frank 4 years ago.
xorg.conf Download (2.2 KB) - added by paulchany 4 years ago.
Xorg.0.log Download (35.9 KB) - added by paulchany 4 years ago.

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed with VBox 3.1.8

comment:2 Changed 4 years ago by lcamacho

  • Status changed from closed to reopened
  • Resolution fixed deleted

The problem is still present in VBox 3.1.8 installed on Ubuntu 10.04

comment:3 Changed 4 years ago by paulchany

And the problem is still present in VBox 3.1.8 installed on Debian GNU/Linux Lenny too.

Changed 4 years ago by frank

comment:4 follow-up: ↓ 7 Changed 4 years ago by frank

Please copy the attached file 50-vboxmouse.conf to /usr/share/X11/xorg.conf.d, then reboot the guest.

comment:5 in reply to: ↑ description ; follow-up: ↓ 6 Changed 4 years ago by lcamacho

Thank you Paul, that solve the problem with mouse but the size of the screen is still 800x600

comment:6 in reply to: ↑ 5 ; follow-up: ↓ 12 Changed 4 years ago by paulchany

Replying to lcamacho:

Thank you Paul, that solve the problem with mouse but the size of the screen is still 800x600

It wasn't me who attached the file.

comment:7 in reply to: ↑ 4 Changed 4 years ago by paulchany

Replying to frank:

Please copy the attached file 50-vboxmouse.conf to /usr/share/X11/xorg.conf.d, then reboot the guest.

I did so and get two mouse pointer again, but the mouse pointer integration works, so on guest Debian Squeeze the default black mouse pointer moves when the host Debian Lenny white mouse pointer become over the guest window. The screen resolution still remain in mode 800x600.

comment:8 Changed 4 years ago by frank

Strange, this works here. Seems that the vboxvideo driver is somehow not loaded. Could you attach the /var/log/Xorg.0.log of your guest to this ticket?

comment:9 Changed 4 years ago by michael

And /etc/xorg.conf if there is one on your guest.

Changed 4 years ago by paulchany

Changed 4 years ago by paulchany

comment:10 Changed 4 years ago by paulchany

When I remove the line: Modes "1152x864" from xorg.conf file and reboot (I can't restart X Window because Ctrl+Alt+BackSpace don't works) the resolution still remain in mode 800x600.

comment:11 follow-up: ↓ 13 Changed 4 years ago by michael

In this environment, we don't expect that there will be an xorg.conf file at all. Was that file created automatically when you installed the system, or did you do something to generate it? Removing it should (!) fix the issues you are having by the way.

comment:12 in reply to: ↑ 6 Changed 4 years ago by lcamacho

Replying to paulchany:

Replying to lcamacho:

Thank you Paul, that solve the problem with mouse but the size of the screen is still 800x600

It wasn't me who attached the file.

My mistake, thanks frank.
Now I have Windows installed so I test the VM on windows and everything works, mouse and auto adjust screen size but back to Ubuntu mouse works, screen still 800x600 so I change the xorg.conf and add the Display subsection on Screen section with the full size screen and depth after that something happen that now it recognizes every mode and I have full screen but it doesn't auto adjust the size, I erase the subsection but nothing happen so I still have every mode but it doesn't auto adjust

comment:13 in reply to: ↑ 11 Changed 4 years ago by paulchany

Replying to michael:

In this environment, we don't expect that there will be an xorg.conf file at all. Was that file created automatically when you installed the system, or did you do something to generate it? Removing it should (!) fix the issues you are having by the way.

I remember that I run some command to generate it but which command was that I don't know right now. I removes the /etc/X11/xorg.conf file and relogin to X Window. Now my screen resolution is: $ xdpyinfo | grep 'dimensions:'

dimensions: 1152x864 pixels (304x228 millimeters)

Everything is fine: the mouse integration, the screen resolution only I can't use my mouse to paste the higlighted text from host (Debian Lenny) to guest (Debian Squeeze) system or vica versa.

Thanks!

comment:14 Changed 4 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to invalid

I will set this to invalid, as our Additions installer expects to be run on a system in the default configuration, which means no xorg.conf with recent versions of X.Org (whether or not this is a good thing is another question, but dealing with unknown xorg.conf setups is fiendishly complicated!). Note also that we don't support select-and-paste between host and guest, just copy-and-paste (using the menu or a keyboard shortcut to copy selected text).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use