VirtualBox

Ticket #6630 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

OSE and 3.2.0-Beta1 don't start on MacOSX 64-bit

Reported by: moubctez Owned by:
Priority: major Component: other
Version: Keywords:
Cc: 3.2.0 BETA1 Guest type: other
Host type: Mac OS X

Description

When trying to start OSE or 3.2.0-beta1 on 64-bit Mac OS X, I get:

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/Applications/VirtualBox.app/Contents/MacOS/VirtualBox.dylib",) failed: dlopen(/Applications/VirtualBox.app/Contents/MacOS/VirtualBox.dylib, 10): Library not loaded: /Applications/VirtualBox.app/Contents/MacOS/VBoxREM.dylib

Referenced from: /Applications/VirtualBox.app/Contents/MacOS/VirtualBox.dylib Reason: Incompatible library version: VirtualBox.dylib requires version 3.2.0 or later, but VBoxREM.dylib provides version 0.0.0

Applying this patch to the sources and re-linking VBoxREM.dylib fixes the problem:

--- src/recompiler/Makefile.kmk.orig 2010-05-03 10:10:19.000000000 +0200 +++ src/recompiler/Makefile.kmk 2010-05-03 10:18:39.000000000 +0200 @@ -272,7 +272,7 @@

VBoxREMImp_SONAME = VBoxREM$(SUFF_DLL)

endif

ifdef VBOX_WITHOUT_REM_LDR_CYCLE

  • VBoxREMImp_LDFLAGS.darwin = -install_name $(VBOX_DYLD_EXECUTABLE_PATH)/VBoxREM.dylib

+# VBoxREMImp_LDFLAGS.darwin = -install_name $(VBOX_DYLD_EXECUTABLE_PATH)/VBoxREM.dylib

else

VBoxREMImp_LDFLAGS.darwin = -install_name $(subst @rpath,@executable_path,$(VBOX_DYLD_EXECUTABLE_PATH))/VBoxREM.dylib

endif

Attachments

vbox-REM.pch Download (563 bytes) - added by moubctez 4 years ago.
patch to fix the problem

Change History

Changed 4 years ago by moubctez

patch to fix the problem

comment:1 Changed 4 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to invalid

Thanks for your report, but please don't use this bug tracker for Beta bugs. Use the forum instead. Your problem was already reported  here

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use