VirtualBox

Ticket #6609 (new defect)

Opened 4 years ago

Last modified 4 years ago

Failed to start machine with teleportation enabled on port 0 (auto select port)

Reported by: grimpy Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: other
Host type: other

Description

I was trying to start my virtualmachine after enabling telportation after this i wanted to check the assigned port for the teleportation so i fire up a showvminfo, as a suprise i found status stopping instead of some of the teleport status and telporterport still 0

however when i tried to set the teleporterport myself the entire process worked out fine

Used the following commands

VBoxManage modifyvm 263497339b630c71121d9050d49b2cb4 --teleporter on

VBoxManage startvm 263497339b630c71121d9050d49b2cb4 -t vrdp
Sun VirtualBox Command Line Management Interface Version 3.1.6
(C) 2005-2010 Sun Microsystems, Inc.
All rights reserved.

Waiting for the remote session to open...
Remote session has been successfully opened.

VBoxManage showvminfo 263497339b630c71121d9050d49b2cb4
Sun VirtualBox Command Line Management Interface Version 3.1.6
(C) 2005-2010 Sun Microsystems, Inc.
All rights reserved.

Name:            263497339b630c71121d9050d49b2cb4
Guest OS:        Other/Unknown
UUID:            106ea870-0567-48cf-8b13-9b763280173b
Config file:     /root/.VirtualBox/machines/263497339b630c71121d9050d49b2cb4/263497339b630c71121d9050d49b2cb4.xml
Hardware UUID:   106ea870-0567-48cf-8b13-9b763280173b
Memory size:     512MB
VRAM size:       8MB
Number of CPUs:  1
Synthetic Cpu:   off
CPUID overrides: None
Boot menu mode:  message and menu
Boot Device (1): Floppy
Boot Device (2): DVD
Boot Device (3): HardDisk
Boot Device (4): Not Assigned
ACPI:            on
IOAPIC:          off
PAE:             on
Time offset:     0 ms
Hardw. virt.ext: on
Hardw. virt.ext exclusive: on
Nested Paging:   on
VT-x VPID:       on
State:           stopping (since 2010-04-29T11:11:17.348000000)
Monitor count:   1
3D Acceleration: off
2D Video Acceleration: off
Teleporter Enabled: on
Teleporter Port: 0
Teleporter Address: 
Teleporter Password: bleh
Storage Controller Name (0):            Sata Controller
Storage Controller Type (0):            IntelAhci
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  30
Storage Controller Port Count (0):      30
Sata Controller (0, 0): /opt/qbase3/etc/vmdks/_dev_disk_by_path_ip_10_31_19_18_3260_iscsi_iqn_1986_03_com_sun_02_a4ceb970_232a_ec1b_a8ad_b39e36f5bcb1_lun_0 (UUID: 8faeb7c1-9b34-4eef-aef9-aefe176e5912)
Sata Controller (1, 0): /opt/qbase3/etc/vmdks/_dev_disk_by_path_ip_10_31_19_18_3260_iscsi_iqn_1986_03_com_sun_02_a4ceb970_232a_ec1b_a8ad_b39e36f5bcb1_lun_1 (UUID: 7226a2c1-f7e9-4903-b1c5-07a6ee5ac331)
NIC 1:           MAC: 00163E420016, Attachment: Bridged Interface '46_1', Cable connected: on, Trace: off (file: none), Type: 82543GC, Reported speed: 0 Mbps

Going to attach the detailed logs 2

Attachments

VBox.log Download (66.9 KB) - added by grimpy 4 years ago.
Log of starting machine in teleportatinon

Change History

Changed 4 years ago by grimpy

Log of starting machine in teleportatinon

comment:1 Changed 4 years ago by grimpy

Quote from sdk manual 3.1.6 downloaded

9.20.1.42 teleporterPort (read/write)
unsigned long IMachine::teleporterPort
  The TCP port the target teleporter will listen for incoming teleportations on.
  0 means the port is automatically selected upon power on. The actual value can be
read from this property while the machine is waiting for incoming teleportations.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use