VirtualBox

Ticket #6592 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Additional host-only network settings lost after host restart

Reported by: brunogirin Owned by:
Priority: minor Component: GUI
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

When configuring an additional host-only network in VirtualBox, the settings are lost after a restart of the host system (but not after a restart of the VirtualBox application).

Steps to reproduce

  1. Open VirtualBox OSE
  2. Go to File -> Preferences
  3. Select Network
  4. Click on the "Add" button
  5. Configure the new network with DHCP disabled, IPv4: 192.168.57.1, netmask 255.255.255.0, name vboxnet1
  6. Configure a virtual machine to use vboxnet1 for one of its network interfaces
  7. Start the virtual machine: should start normally
  8. Stop the virtual machine
  9. Close Virtual Box
  10. Restart VirtualBox
  11. Start the virtual machine: should start normally again
  12. Stop the virtual machine
  13. Stop Virtual Box
  14. Shutdown and restart the host
  15. Start VirtualBox
  16. Start the virtual machine that uses vboxnet1
  17. The virtual machine fails to start due to a missing network
  18. Go to File -> Preferences
  19. Select Network
  20. vboxnet1 is no longer listed in the network preferences
  21. Open a terminal and type: cat ~/.VirtualBox/VirtualBox.xml
  22. vboxnet1 is listed in the config file even though it does not appear in the GUI

Expected result

In step 17, the virtual machine that uses vboxnet1 should start normally and in step 20 vboxnet1 should be listed in the list of networks.

Actual result

In step 17, the virtual machine that uses vboxnet1 cannot start and in step 20 vboxnet1 is no longer listed in the list of networks and needs to be re-created. Just clicking on the "Add" button seems to do the trick and the network details are populated as they were before: whether this is due to me choosing default values or the GUI actually re-reading the config file for that network, I don't know.

More info

This bug was originally reported on Ubuntu Linux and file on Launchpad as  bug 510133.

In addition, I also received an email from a CentOS user who encountered the same problem:

I found your bug report online. I am also experiencing the exact same bug. If you could do me a favor and keep me in the loop on this issue, I would appreciate it. Also, if you have any questions from me as to what I'm running, please ask.


Host
OS: CentOS 5.4
Kernel: 2.6.18-164.11.1.el5

Change History

comment:1 Changed 4 years ago by frank

  • Description modified (diff)

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #6341.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use