VirtualBox

Ticket #6588 (closed defect: fixed)

Opened 4 years ago

Last modified 11 months ago

Importing Appliance -- Error-Message: VBOX_E_FILE_ERROR

Reported by: trofab Owned by:
Priority: trivial Component: OVF
Version: VirtualBox 3.1.6 Keywords: import appliance
Cc: Guest type: other
Host type: Windows

Description (last modified by aeichner) (diff)

Please read this carefully. I'm a computer specialist and software developer; I know what I'm talking about. ;-)

On importing an appliance (a.k.a 'ovf'-file) into VirtualBox I receive the error message: "Couldn't calculate SHA1 digest for file 'Xubuntu_9.10.ovf' (VERR_FILE_NOT_FOUND)."

As it is often the case this errormessage is misleading at best. The real reason -- and I'm certain of this -- is that the directory path leading to the 'ovf'-file contains German umlauts (characters like 'ö', 'ä', 'ü' and the like).

It seems that the characters of the directory path are somehow misinterpreted if they are German umlauts and VirtualBox is subsequently not able to locate the 'mf'-file containing the SHA1-digests.

I verified that and I'm 100% certain that's the real problem. Please look into it. Thank you.

Attachments

Xubuntu_9.10.ovf Download (4.8 KB) - added by trofab 4 years ago.

Change History

comment:1 Changed 4 years ago by umoeller

This is hard to verify without having the files in question. Could you at least attach the OVF file that causes this so we can try to reproduce the problem? Have you tested whether this problem occurs only on Windows hosts?

comment:2 Changed 4 years ago by trofab

The particular OVF file is unimportant for reproducing this bug. In my case the OVF file doesn't contain any German umlauts at all. Just do the following: Open a new directory on your harddrive. Call the directory 'übung' (without single quotes of course, but with the German umlaut 'ü') then copy any OVF file in this directory and try to import this as a new appliance into VBox. That should be sufficient to reproduce the error. Just tried it on my Ubuntu 10.04 machine with VBox 3.2.4 (I don't have a Windows machine at hand right now) and the bug didn't show up again. So either it is fixed in version 3.2.4 or it just occurs on Windows hosts. I think the latter. When I have access to my Windows machine again, I will try again and post results. I will also attach the OVF file, but I don't think it will be of great help to you. Thank you

Changed 4 years ago by trofab

comment:3 Changed 11 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Tried that with the most recent release here on a Windows 7 host. Works without problems so likely fixed, closing the defect. Please reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use