VirtualBox

Ticket #658 (closed defect: duplicate)

Opened 7 years ago

Last modified 4 years ago

Seamless window and dualscreen

Reported by: adrien Owned by:
Priority: minor Component: GUI/multiview
Version: VirtualBox 1.5.0 Keywords: seamless window dual screen
Cc: Guest type: other
Host type: other

Description

With virtualbox 5 on debian stable (etch) dual screen with nvidia binary driver (xinerama activated) The seamless mode only works on the first screen, if used on the second screen there is a lot of display problems

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by sandervl73

The same with 1.5.2?

comment:2 in reply to: ↑ 1 Changed 6 years ago by adrien

Replying to sandervl73:

The same with 1.5.2?

Still not working. (ubuntu 7.10)

comment:3 Changed 6 years ago by crucify

VirtualBox 1.5.6 gentoo linux xorg-server-1.4.0.90-r3 xfce4-4.4.2

still not working.

comment:4 in reply to: ↑ description Changed 6 years ago by jsnel

Replying to adrien:

With virtualbox 5 on debian stable (etch) dual screen with nvidia binary driver (xinerama activated) The seamless mode only works on the first screen, if used on the second screen there is a lot of display problems

I second this for VirtualBox 1.6.2 running on a Linux x86_64 architecture with nVidia drivers using a dual head setup (as configured by Sax). The problem is the following:

  • When in dual head mode, Virtualbox works as expected on the primary monitor, seamless mode works. But on the second screen going into seamless mode mode causes the VM machine (Windows XP in this case) to be completely hidden from view, no previously opened applications are visible anymore. The easy solution is to leave seamless mode and move the window to the other screen, but it would be nice if one would have a choice as to what window is used.

comment:5 Changed 6 years ago by frank

  • Component changed from other to GUI/multiview

comment:6 Changed 6 years ago by pestilent

I am experiencing the same.

VirtualBox 2.0.2 Windows XP Guest Gentoo Linux Host Nvidia 7800 GT 3200x1200 Resolution using twinview (no Xinerama)

VirtualBox functions flawlessly on both screens in windowed mode, but will only display on my primary in seamless mode.

comment:7 Changed 5 years ago by plastikman

I am having the same problem here.

Fedora 11 with Radeon HD 3650 using radeon driver x86_64 virtualbox 2.2.4.

I have tried enabling dual monitors in Virtualbox using the following

VBoxManage modifyvm <vmname> -monitorcount 2

Each time seamless mode is entered on the second screen the VM disapears, if i start seamlessmode on the primary monitor it works fine.

I would love to use seamless mode on my secondary monitor.

Thanks

comment:8 Changed 4 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1322.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use