VirtualBox

Ticket #6540 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

provided DHCP information wrong after update of network config on host during runtime

Reported by: Don Owned by:
Priority: trivial Component: network/NAT
Version: VirtualBox 3.1.6 Keywords: DHCP
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

The nameservers provided through the DHCP-Server of VirtualBox don't update if the host DNS configuration changes during runtime of the guest.

In other words: On startup the guest gets the current nameservers as expected. Now the nameservers on the host change (after startup of the guest). If I attempt to update the nameservers using dhclient it will receive the old nameservers.

Such changes on the host might occur when a VPN connection is established, to name one example.

The closure and reopening of the guest refreshes the data. Rebooting doesn't suffice.

Change History

comment:1 Changed 4 years ago by frank

  • Component changed from network to network/NAT
  • Description modified (diff)

You are talking about a NAT interface, correct?

comment:2 follow-up: ↓ 3 Changed 4 years ago by Don

That is correct.

comment:3 in reply to: ↑ 2 ; follow-ups: ↓ 4 ↓ 5 Changed 4 years ago by Hachiman

Replying to Don:

That is correct.

Could you please try  host resolver? That should resolve issue for you.

comment:4 in reply to: ↑ 3 Changed 4 years ago by Don

Replying to Hachiman:

Could you please try  host resolver? That should resolve issue for you.

Setting this property to 0 or 1 makes the VM unbootable. It fails with: Configuration error: Failed to get the "MAC" value (VERR_CFGM_VALUE_NOT_FOUND). Unknown error creating VM (VERR_CFGM_VALUE_NOT_FOUND).

Details:

Fehlercode: E_FAIL (0x80004005) Komponente: Console Interface: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

Unsetting the value solved this problem.

comment:5 in reply to: ↑ 3 Changed 4 years ago by Don

Replying to Hachiman:

Could you please try  host resolver? That should resolve issue for you.

Sorry, I forgot to translate the German parts of the message, here the correction

Setting this property to 0 or 1 makes the VM unbootable. It fails with:
Configuration error: Failed to get the "MAC" value (VERR_CFGM_VALUE_NOT_FOUND).
Unknown error creating VM (VERR_CFGM_VALUE_NOT_FOUND).

Details:
Errorcode: E_FAIL (0x80004005)
Component: Console
Interface: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

Unsetting the value solved this problem.

comment:6 Changed 4 years ago by Don

This ticket can be closed or merged with  #6540. It describes the same issue only on Mac.

comment:7 Changed 4 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate #3847

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use