VirtualBox

Ticket #6520 (closed defect: fixed)

Opened 4 years ago

Last modified 18 months ago

guru meditation running memtest in guest

Reported by: gijobarts Owned by:
Priority: major Component: VMM/RAW
Version: VirtualBox 3.1.6 Keywords: guru meditation ubuntu linux
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

I was running memtest inside a guest that had just been running Ubuntu 9.10. I've done this before without problems. (I know that isn't a good way to test memory; I was using it as a quick and dirty wipe of the guest's memory.)

A message popped up saying there was a critical error, telling me to send in a bug report, and advising that I shut down the VM, but giving me the option of leaving it running for debugging. (Sorry, no such skills here.)

Host is VB 3.16 on Ubuntu 9.10 (fully updated) on Lenovo Thinkpad X61 Tablet. Will post log files.

(This is my first time using the bug tracker.)

Attachments

VBox.log Download (127.4 KB) - added by gijobarts 4 years ago.
VBox.png Download (7.3 KB) - added by gijobarts 4 years ago.
VBox.2.log Download (67.8 KB) - added by pgreening 18 months ago.
log from ubuntu install gone wrong

Change History

Changed 4 years ago by gijobarts

Changed 4 years ago by gijobarts

comment:1 Changed 4 years ago by gijobarts

Oops, I shouldn't have said "Linux" for the guest, as Linux wasn't running at the time. memtest runs straight from GRUB.

comment:2 Changed 4 years ago by frank

  • Component changed from other to VMM/RAW
  • Guest type changed from Linux to other

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

comment:4 Changed 3 years ago by divanorama

  • Status changed from closed to reopened
  • Resolution fixed deleted

I experience memory errors in VirtualBox 4.0.4, or at least it looks so. Host (Gentoo Linux, amd64, Phenom II x3, 8g ram) doesn't detect any errors, while on guest(Gentoo Linux, amd64, 3 cores, all virtualization on, 6.7g ram) heavy applications(like gcc 4.5 compilation) or sometimes memtest crash or detect memory errors.

Tests done so far:

  1. Memtester on host - no errors
  2. Memtester on guest first run - random errors, appears quickly on the first test
  3. Memtester on guest second+ runs - ok (that is strange, memtester releases memory and then each new run mlocks it again and gets no errors)
  4. Memtester on guest after guest app crash - random errors
  5. Memtester on guest and on host simultaneously - no errors on host no matter guest having errors or not
  6. Plain guest memtest (no linux guest) - no errors
  7. Rechecked that hardware isn't overheated - no effect

My guesses:

  1. There is a bug in Linux guest kernel
  2. Virtualbox have a bug on some combination of my hardware, guest kernel, huge guest ram
  3. My hardware fails, maybe it is cpu virtualization features

Any directions on how to debug this?

comment:5 Changed 22 months ago by frank

  • Description modified (diff)

divanorama, still relevant with VBox 4.1.18? If so, please attach a VBox.log file for a memtest session showing errors.

comment:6 Changed 22 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

The original reporter has a lightly changed hardware environment and cannot reproduce this problem anymore. So let's close this ticket.

comment:7 Changed 18 months ago by pgreening

i am able to consistantly reproduce this bug. I am running host AMD64 based debian uanme -a Linux allamonkey 3.2.0-3-amd64 #1 SMP Mon Jul 23 02:45:17 UTC 2012 x86_64 GNU/Linux virtualbox 4.1.18_debian r78361 I am attempting to install Ubuntu quantal with the 20101020ubuntu186 installer, both 32 and 64-bit versions. Host hardware passes 48 hour memtest endurance burnin with zero errors after install of quantal ubuntu, installer reboots and goes into memtest (no grub), which fails after a few minutes. Will attach log shortly. This is obviously two bugs... the preseeding file I am using somehow is failing to install any kernel other than the memtest, so it boots to memtest. But memtest should not fail, which is the vbox issue.

Changed 18 months ago by pgreening

log from ubuntu install gone wrong

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use