VirtualBox

Ticket #652 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

DHCP doesn't work for FreeBSD guests

Reported by: techie Owned by:
Priority: major Component: network
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: BSD
Host type: other

Description

Guest FreeBSD on Win2000 host can't get any DHCPOFFER from VirtualBox when Network configured in "Host Interface" mode. Static address works ok to communicate with host machine.

Attachments

FailedDHCP Download (1.4 KB) - added by pennystinker 6 years ago.
WireShark trace of Failed DHCP attempt

Change History

comment:1 Changed 7 years ago by webograph

i can confirm that for windows nt 4 guest in linux host, with host side network card bridged via tun/tap into the rest of the network and nt4's auto-detected "AMD PCNET PCI Ethernet-Adapter" (german) in the guest.

(on the same vm, dhcp works for booting from lan; nt4 with statically configure ip works as well)

comment:2 Changed 7 years ago by markrian

I've encountered this with a Windows 2000 guest OS, Debian etch host OS. I have gotten DHCP working a couple of times pretty randomly - I have no idea how :(

comment:3 Changed 6 years ago by frank

For having DHCP work with a host interface you have to make sure that there is a DHCP server is running and that there are free leases available. DHCP will not work out-of-the-box, you have to install a DHCP server yourself. A network traffic dump with wireshark for the host interface would be helpful. webograph, especially from you, the whole dump of the host interface could help to isolate the problem.

comment:4 Changed 6 years ago by pennystinker

I am having a similar problem, host Gentoo Linux:

$ uname -a Linux phoenix 2.6.23-gentoo-r3 #4 SMP Tue Jan 22 15:49:08 EST 2008 i686 Genuine Intel(R) CPU 1400 @ 1.83GHz GenuineIntel GNU/Linux

VirtualBox 1.5.4_OSE

Guest Windows 2003 Server

The guest used to be able to use a host bridge network up until I installed .NET 2.0 Service Pack 1 then after rebooting I can only NAT.

I followed these directions for setting up the bridge:

 http://gentoo-wiki.com/HOWTO:_VirtualBox

Like I said, bridged network DID work, then suddenly stopped. I have a capture via WireShark that I will attach to this bug report.

Changed 6 years ago by pennystinker

WireShark trace of Failed DHCP attempt

comment:5 Changed 6 years ago by frank

  • Summary changed from DHCP doesn't work for guest to DHCP doesn't work for FreeBSD guests

There is a known problem with FreeBSD when accessing the network card VirtualBox is emulating. The current workaround is to use the other PCNet network type -- select PCNet PCI II (Am79C970A) as type for the network card.

comment:6 Changed 6 years ago by biophysics

Can anyone please update the FAQ to include "DHCP doesn't work for FreeBSD guests" Many thanks

comment:7 Changed 6 years ago by frank

Done.

comment:8 Changed 6 years ago by frank

  • Component changed from other to network
  • Guest type changed from other to BSD

comment:9 Changed 4 years ago by Technologov

Is this still relevant ?

( I doubt it because both NAT and Host networking changed so very much )

Besides, there is no more Win2000 host. Dropped in v1.6

-Technologov

comment:10 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use