VirtualBox

Ticket #6513 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Deleting directories on shared folder fails with EBUSY => Fixed in SVN

Reported by: foobar42 Owned by:
Priority: major Component: shared folders
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: Solaris
Host type: Linux

Description

Host is Linux with ext3/ext4, guest is Solaris 10u8. Doing 'rm -rf ...' on the Solaris guest on a directory in a shared folder deletes all files, but leaves a bunch of folders; usually (but not always) it prints out errors like

rm: Unable to remove directory <directory>: Device busy

Trying to 'rmdir' those directories sometimes succeeds and sometimes fails with a similar error:

rmdir: directory "<directory>": Directory is a mount point or in use

truss shows

<pid>:  rmdir("<directory>")             Err#16 EBUSY

The easiest way to reproduce this is probably to unpack some tar or zip with a bunch of directories and files, and then try to 'rm -rf' it again.

It seems like VB itself may be keeping the directories busy, because A) 'lsof' and 'fuser' show nobody using them, B) running 'rmdir' several times it may fail a few times and then suddenly succeed, and C) using wildcards I can almost never delete subdirectories (i.e. 'rmdir dir/*'), but if I wait a bit and delete them individually ('rmdir dir/a') then they usually succeed.

Note that 'rm -rf' always successfully deletes all files - it's just the directories that have issues.

Change History

comment:1 Changed 4 years ago by ramshankar

  • Summary changed from Deleting directories on shared folder fails with EBUSY to Deleting directories on shared folder fails with EBUSY => Fixed in SVN

This is now fixed internally in SVN and should be part of the next VirtualBox release. Thank you for the report.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3.1.8

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use