VirtualBox

Ticket #6498 (closed defect: fixed)

Opened 4 years ago

Last modified 2 years ago

USB not working on 3.1.4 and 3.1.6 on Vista 64

Reported by: Vlatko Owned by:
Priority: critical Component: USB
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Hi,

I was using Portable Virtualbox and all worked OK. Than I upgraded to Virtualbox 3.1.4 and USB stopped working. Than I upgraded to 3.1.6, and USB still doesn't work. Status is always captured or busy.

I thought it might be something with Portable Virtualbox, so I installed proper, full version of Virtualbox on my Vista 64 machine. Now, drivers in Windows host have version 3.1.6. Guest Additions in VMs have version 3.1.6.

USB still doesn't work. So, I'm stuck at 3.1.2 where everything works fine, even though drivers and Guest Additions are from higher version.

Attachments

Logs.zip Download (37.7 KB) - added by Vlatko 4 years ago.
Two installed Virtualbox logs, and one Portable Virtualbox log.

Change History

Changed 4 years ago by Vlatko

Two installed Virtualbox logs, and one Portable Virtualbox log.

comment:1 Changed 4 years ago by Vlatko

Please disregard this post. Seems at the same time Vista auto-installed some of its own USB drivers that prevented VB USB from attaching. All works fine now.

Sorry for the noise. :-(

comment:2 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

comment:3 Changed 4 years ago by Vlatko

  • Status changed from closed to reopened
  • Resolution invalid deleted

Hi,

I must reopen this issue. It is definitely something with Virtualbox. I'm back to 3.1.2 again.

comment:4 Changed 4 years ago by Vlatko

Problem still exists in 3.1.8.

comment:5 Changed 4 years ago by Vlatko

Problem still existed in 3.2.0, but it turned out it is not VB problem at all. :-)

Our "nice" Windows stores all installed drivers in DriverStore, and use drivers as they see appropriate. And in my case, Windows were using two old VboxUSB drivers, 3.0.8 and 3.1.2. That is why 3.1.2 was always working.

If someone has similar problem, here is my solution: In administrative CMD prompt run "phputil -e" to list all OEM drivers. Search for VB drivers (still listed under SUN), if you see a driver version that is not your current VB version, remember the two digit number in OEMxx.inf run "phputil -f -d OEMxx.inf". Restart and all works fine. :-)

I still can't attach scanner, but it is not this issue.

Please, close this issue as solved.

comment:6 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use